External audio pass through

Bug #355945 reported by Sean M. Pappalardo on 2009-04-06
70
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Matthew Mikolay
1.10
Wishlist
Unassigned
1.11
Wishlist
Unassigned
2.0
Wishlist
Matthew Mikolay

Bug Description

It would be nice, for those of us using vinyl control, to be able to click a radio button on the GUI that disables the waveform and just connects the aux input for vinyl control on that deck to the channel output (so it passes through the cross-fader & fx (if possible,) etc.) That way we can very easily mix external media into our sets, especially when using a MIDI mixer controller instead of a hardware mixer.

Changed in mixxx:
importance: Undecided → Wishlist
description: updated
summary: - Channel pass through
+ External audio pass through
tags: added: vinylcontrol
RJ Skerry-Ryan (rryan) wrote :

This is a common enough request that I think we should probably implement it -- possibly a 1.8 side project.

Changed in mixxx:
milestone: none → 1.9.0
Changed in mixxx:
milestone: 1.9.0 → none
Changed in mixxx:
status: New → Confirmed
Bill Good (bkgood) on 2010-06-27
tags: added: passthrough
Bill Good (bkgood) on 2010-07-26
Changed in mixxx:
assignee: nobody → Bill Good (bkgood)
Owen Williams (ywwg) wrote :

Albert's suggestion was to target this for 1.10, which is also when my features_vinyl stuff is supposed to go in. This would help make 1.10 The Big Vinyl Release :)

tags: added: mic microphone pass radio talkover through
Owen Williams (ywwg) wrote :

Fixed in r3357

Changed in mixxx:
milestone: none → 1.12.0
status: Confirmed → Fix Committed

Sounds interesting, but any notes on how to use it? Any new controls in the UI or preferences settings needed?

On Saturday, May 4, 2013 at 6:46 AM, Owen Williams wrote:

> Fixed in r3357
>
> ** Changed in: mixxx
> Milestone: None => 1.12.0
>
> ** Changed in: mixxx
> Status: Confirmed => Fix Committed
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/355945
>
> Title:
> External audio pass through
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/355945/+subscriptions
>
>

Owen Williams (ywwg) wrote :

There is a new controlobject called ChannelX,passthrough_enabled which toggles the passthrough state. It is default off so there are no preferences needed, but there will need to be some sort of UI required. In my own version I had the vinyl status widget turn blue when passthrough was on, but this patch just enables the behavior. (We should probably open a separate bug to complete the UI for it)

RJ Skerry-Ryan (rryan) on 2013-05-07
Changed in mixxx:
assignee: Bill Good (bkgood) → Matthew Mikolay (mattmik)
RJ Skerry-Ryan (rryan) on 2013-05-10
Changed in mixxx:
milestone: 1.12.0 → none
Guy Lunardi (guy-m) wrote :

Built 'master' a couple of hours ago. All seems to work.

Could I please get a quick pointer, I would like to update the Hercules RMX script I'm using to enable it for this feature please?
Even just the commit on GIT for another script that's been updated would be enough I hope.

Not sure where to request this (tried IRC).

Great app!

Owen Williams (ywwg) wrote :

I just sent this note to someone else, so I'll paste it here:

Right now the passthrough mode isn't revealed in the user interface, but it's possible to assign that function to a key or midi button. For instance to add a keyboard shortcut, you'd make sure your keyboard config file (as described here: http://mixxx.org/manual/latest/chapters/advanced_topics.html#making-a-custom-keyboard-mapping) has:

[Channel1]
passthrough_enabled Ctrl+g

[Channel2]
passthrough_enabled Ctrl+h

or whatever keys you want to use.

I think that function is learnable in the midi control wizard if you
want to assign passthrough to a midi button.

Guy Lunardi (guy-m) wrote :

When using either a customer midi binding or the keyboard mapping, I get a similar error:

Debug [Controller]: "MIDI status 0xB0 (ch 1, opcode 0xB), ctrl 0x13, val 0x00"
Debug [Controller]: Not a function

Warning [Main]: ControlObject::getControl returning NULL for ( "[Channel1]" , "passthrough_enabled" )
Debug [Main]: Warning: Keyboard key is configured for nonexistent control: "[Channel1]" "passthrough_enabled"

Is there a way to double check that the EnginePassthrough is loading properly?

Thought these were the names for the configurations::
          m_pEnabled(new ControlObject(ConfigKey(pGroup, "passthrough_enabled"))),
          m_pPassing(new ControlPushButton(ConfigKey(pGroup, "passthrough"))),

Sorry to be a bother.

Owen Williams (ywwg) wrote :

I'm going to open a new bug for this issue.

jus (jus) wrote :

In latest https://github.com/mixxxdj/mixxx/tree/master It works using "passthrough", not "passthrough_enabled", e.g.

[Channel1]
passthrough Ctrl+g

[Channel2]
passthrough Ctrl+h

RJ Skerry-Ryan (rryan) on 2015-12-30
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints