drag & drop into wave display does not work in Windows

Bug #325337 reported by VooDoo Chicken on 2009-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Unassigned
1.7
Medium
Sean M. Pappalardo

Bug Description

dragging from track list into wave display does not work. when i hoover over the display, it shows a little + instead of the not allowed sign right by the side of the pointer, but dropping does nothing. i load the tracks with right click (win xp)

Related branches

lp:mixxx/1.7 (Merged)
Albert Santoni (gamegod) wrote :

What version of Mixxx are you using?

Was filetype were you trying to drag onto the waveform? Where were you dragging from?
Was it a second disk drive or anything special we should be aware of?'

Thanks

Changed in mixxx:
status: New → Incomplete

I can corroborate this on Windows XP 64-bit SP3 with the 1.6.2 branch: when dragging a file (from the same local drive as the Mixxx installation) to the waveform, there are two issues:

1) The track name text that's supposed to follow the mouse cursor is three inches to the left of it and blank
2) Nothing happens when you drop the file into a waveform

This might be the cause of bug #253293 which crashes Mixxx on Windows Vista doing the same thing.
Also may be related to bug #253022 which deals with network shares.

Changed in mixxx:
importance: Undecided → Medium
status: Incomplete → Confirmed
RJ Ryan (rryan) wrote :

Since this is probably an easy fix, should we fix this for 1.7.0?

Changed in mixxx:
milestone: none → 1.7.0

Sure, knock yourself out. :) I don't know where to begin on this.

Note that this is ONLY a problem when loading files from the local drive! It works fine from a network location (UNC path in my case.) The GUI issues remain though, and the little box isn't blank, it contains the artist name. (I was loading a FLAC file that had nothing in the artist column.)

Changed in mixxx:
milestone: 1.7.0 → none
status: Confirmed → New

I tried to do some more testing and found the following hopefully useful information:
- A library comprised of only UNC-path files works
- If any local files are added to the same library, the locals don't work but the UNC ones do during that session. Once Mixxx is restarted, neither work.
- Dragging & dropping a local file from outside of Mixxx works
- The problem happens regardless of skin
- qDebugs placed as the first lines in WWaveformViewer::dragEnterEvent and WWaveformViewer::dropEvent never print whether the drop works or not

Albert suggested that the file path for local files dragged from the library is getting hosed somehow.

Just tested with a mapped drive letter (to the same network location, incidentally) and that doesn't work dragging from the library, but does dragging from outside Mixxx. So there's a problem with the drive letter/colon handling.

Fixed in r2446, though it feels like a hack. I wonder if there's a bug in QUrl::isValid() since it isn't marking a URL starting with "X:/" as invalid. Perhaps we should be using QUrl::fromLocalFile() in wtracktablemodel.cpp line 191?

Fixed better in r2447 using QUrl::fromLocalFile which is not hacky. Just hoping it doesn't break anything on OSX or Linux.

RJ Ryan (rryan) on 2009-08-11
Changed in mixxx:
status: New → Fix Committed
Albert Santoni (gamegod) wrote :

Added another fix for this that lets you drag and drop from the library to waveform on Windows when files are on weird disks (eg. L:\). I'm not sure if Windows/Qt thinks this is a network share or what, but what my new fix does is just try loading the straight QUrl's toString() if the toLocalFile() fails...

Also, I'm not sure if this mysteriously broke because of the new library or what... :)

(Fix is in r2354.)

For completeness, try loading from a UNC path as well, \\server\share\music\ or similar.

RJ Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers