Ogg tags loaded with wrong encoding

Bug #310666 reported by TonyK on 2008-12-22
2
Affects Status Importance Assigned to Milestone
Mixxx
Undecided
Albert Santoni

Bug Description

I am using Mixx 1.6.1. When I load any ogg file I get the artist and title wrong encoded. I am using unicode (utf8) for encodnig the tags. I just want to note that the used language is Bulgarian. We are useing Cyrillic.

RJ Skerry-Ryan (rryan) on 2009-04-05
tags: added: library

TonyK: is this still a problem with Mixxx 1.7? Please download the latest version and let us know.

Changed in mixxx:
status: New → Incomplete

В 09:54 +0000 на 12.02.2010 (пт), Pegasus написа:
> TonyK: is this still a problem with Mixxx 1.7? Please download the
> latest version and let us know.

I've attached screenshots for ogg, flac and mp3. I Browser mode
filenames are displayed properly. But tags are not. I think it is up to
UTF-8 encode/decode.

Best regards,
--
Anton Katsarov <email address hidden>

Changed in mixxx:
status: Incomplete → Confirmed
milestone: none → 1.8.0
assignee: nobody → Albert Santoni (gamegod)
assignee: Albert Santoni (gamegod) → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) on 2010-02-21
summary: - ogg tags
+ Ogg tags loaded with wrong encoding
Albert Santoni (gamegod) wrote :

I reproduced this bug using an Ogg Vorbis file with UTF-8 encoded Cyrillic in the artist/title fields. The problem was that we weren't decoding Ogg Vorbis comment strings as UTF-8. The Vorbis specification explicitly states the comment strings are encoded as UTF-8, so I fixed our header parsing.

The problem is fixed in r2347 of trunk, and will be included in Mixxx 1.8.0 Beta2 and onwards.

Thanks for reporting this and attaching the screenshots TonyK!

Albert

Changed in mixxx:
assignee: RJ Ryan (rryan) → Albert Santoni (gamegod)
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers