crashes on startup when Powermate USB found (linux x86-64)

Bug #252451 reported by Mark Glines on 2008-07-28
2
Affects Status Importance Assigned to Milestone
Mixxx
Low
Unassigned

Bug Description

Hi,

Here's a backtrace. Note ControlObjectThread::slotSet is called with a
null "self" pointer.

This is on mixxx-1.6.0~beta4 built from source. Mixxx seems to work
fine when the Powermate USB device is not plugged in.

More info available on request.

Mark

Mark Glines (infinoid) wrote :

Please check to see if this is still a problem in v1.6.1 and report back here.

Powermate is not supported moving forward.

Changed in mixxx:
status: New → Won't Fix
Albert Santoni (gamegod) wrote :

We need to at least remove the powermate code then.... The bug is still valid because there IS a crash and fixing it by removing the powermate code is still a task that needs doing to resolve the bug.

Changed in mixxx:
importance: Undecided → Low
milestone: none → 1.8.0
status: Won't Fix → Confirmed
RJ Skerry-Ryan (rryan) wrote :

There aren't any references to the old powermate code anymore so I'm marking this fixed.

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers