Library scanner only scans files that are in the library directory.

Bug #239883 reported by Albert Santoni on 2008-06-13
8
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Daniel Schürmann
1.10
Medium
Unassigned
1.11
Medium
Daniel Schürmann
1.8
Medium
Unassigned
1.9
Medium
Unassigned

Bug Description

Per comment #7, the scanner does not check on entries that are in Mixxx's database but not in a subtree of the library directory.

Daniel James (daniel-64studio) wrote :

A bit more information - it doesn't matter what I select in the combo box. So for example if I have nothing in the play queue, and I select
Play Queue in the combo box, I still see the old library list. The Browse and Playlist options do nothing either. This happens with all skins.

The package version is 1.6.0-beta3 on GNU/Linux, built for Ubuntu Hardy.

Daniel James (daniel-64studio) wrote :

May be related to the bug reported on OS X: https://bugs.launchpad.net/mixxx/+bug/240991

The common theme is that the library window is not being updated.

Daniel James (daniel-64studio) wrote :

The combo box is fixed in 1.6.0 final, thanks! The library refresh still doesn't work though, here are the steps to reproduce:

1. Delete track A from your music library, e.g. in file manager.

2. Click menu item to refresh library - result: no change in the library list.

3. Remove track B from the library list with a right click, it vanishes from the list.

4. Restart Mixxx.

5. The manually deleted track A is gone from the library list, as it should be. But the removed track B is back in the library list! :-)

Daniel James (daniel-64studio) wrote :

Another aspect to this bug - if you later add more files to your music directory, then do Library -> Rescan Library, the new files aren't listed in the library view. The only way to get them to show up is to delete ~/.mixxxtrack.xml manually, and Mixxx will then do the rescan the next time it is started.

Albert Santoni (gamegod) on 2009-02-02
Changed in mixxx:
assignee: nobody → gamegod
importance: Undecided → Medium
milestone: none → 1.6.3
status: New → Confirmed
Changed in mixxx:
milestone: 1.8.0-moving → 1.8.0
RJ Skerry-Ryan (rryan) wrote :

I don't think we've seen this in 1.8.0, can we close it?

Daniel James (daniel-64studio) wrote :

I will test Mixxx 1.8.0-beta1 and get back to you, thanks :-)

RJ Skerry-Ryan (rryan) on 2010-06-17
Changed in mixxx:
status: Confirmed → Fix Committed
Changed in mixxx:
status: Fix Committed → Confirmed
Daniel James (daniel-64studio) wrote :

Sorry guys, the problem is still there in 1.8.0-beta2 and a fresh bzr checkout from yesterday.

Another way to reproduce it is to setup Mixxx on the first run with a certain directory, then later change this in Options -> Preferences -> Library to another directory. Do a Library -> Rescan Library, and there will still be files in the Library view which can't be loaded (I get an error message about a missing file). These missing files aren't listed under the Missing view though.

Does this problem only affect GNU/Linux, or Ubuntu, perhaps?

Cheers!

Daniel

RJ Skerry-Ryan (rryan) wrote :

I can confirm that if I start the scan in one directory (A) then switch to another (B), then the files in A are no longer kept track of by Mixxx. This is because Mixxx only scans over files that are within its Library folder on bootup, so it will not notice if files not somewhere within the current library directory move or are renamed.

Bill Good (bkgood) on 2011-01-02
Changed in mixxx:
milestone: 1.8.0 → 1.9.0
RJ Skerry-Ryan (rryan) on 2011-03-26
Changed in mixxx:
milestone: 1.9.0 → 1.9.1
Changed in mixxx:
assignee: Albert Santoni (gamegod) → nobody
milestone: 1.9.2 → none
RJ Skerry-Ryan (rryan) wrote :

This is hinging on a serious library scanner revamp that isn't going to happen in 10.x. I believe Tobias and Daniel are working on some library scanner improvements, so hopefully we can get this fixed in 1.11.

summary: - Library rescan doesn't work sometimes
+ Library scanner only scans files that are in the library directory.
description: updated
tags: added: scanner
Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

Attached patch solves the bug.

Daniel Schürmann (daschuer) wrote :

This bug was successful tested by Nanovarium, see Bug #975895.

RJ, is this a candidate for 1.11 Milestone?

Daniel Schürmann (daschuer) wrote :

this is an updated patch for lp:mixxx #3283

Daniel Schürmann (daschuer) wrote :

patch committed to lp:mixxx/1.11 #3305

RJ Skerry-Ryan (rryan) on 2012-07-09
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → In Progress
Changed in mixxx:
status: In Progress → Fix Committed
Owen Williams (ywwg) wrote :

This patch breaks mixxx for me. I have many many tracks outside of my library path that got pulled in to the database at some point, and this patch inefficiently does a database exec for each file individually. This process takes so long (and with no progress bar to indicate that something is happening) that the database ends up being locked and lots of other functionality fails, soon resulting in a crash.

This patch needs to be written with a proper transaction so the changes can be applied all at once.

Daniel Schürmann (daschuer) wrote :

I will have a look!

Changed in mixxx:
status: Fix Committed → In Progress
Daniel Schürmann (daschuer) wrote :

The attached patch introduces progress and cancel feature for tracks outside library feature.
Owen, did it solve your issues?

Owen Williams (ywwg) wrote :

Yup, the scoped transaction fixes it. Thanks for getting on this so quickly! The progress bar isn't even necessary for me but it's probably good for the netbook crowd.

Daniel Schürmann (daschuer) wrote :

patch committed to lp:mixxx/1.11 #3316

Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers