Activity log for bug #1941743

Date Who What changed Old value New value Message
2021-08-26 12:21:59 Uwe Klotz bug added bug
2021-08-26 12:22:24 Uwe Klotz description AutoDJ is just handy to demonstrate this bug, but it does not actually cause the bug: - Duplicate the empty.mp3 test file from the Mixxx repo multiple times - Start Mixxx on this new library of empty files - Enable AutoDJ after queuing up multiple files The first debug assertion occurs is in WOverview::slotLoadingTrack(). The race condition itself is caused by signals sent independently from BaseTrackPlayer, EngineBuffer, and maybe other actors. Reported here: https://mixxx.discourse.group/t/tracks-skipped-in-auto-dj-mode-and-eventually-mixxx-crashes/22899 How to test: - Duplicate the empty.mp3 test file from the Mixxx repo multiple times - Start Mixxx on this new library of empty files - Enable AutoDJ after queuing up multiple files The first debug assertion occurs is in WOverview::slotLoadingTrack(). AutoDJ is just handy to demonstrate this bug, but it does not actually cause the bug. The race condition itself is caused by signals sent independently from BaseTrackPlayer, EngineBuffer, and maybe other actors. Reported here: https://mixxx.discourse.group/t/tracks-skipped-in-auto-dj-mode-and-eventually-mixxx-crashes/22899
2021-09-07 07:08:36 Daniel Schürmann mixxx: status New Confirmed
2021-09-07 07:38:55 Daniel Schürmann mixxx: importance Undecided High
2021-09-07 07:38:59 Daniel Schürmann mixxx: status Confirmed In Progress
2021-09-07 07:39:01 Daniel Schürmann mixxx: assignee Daniel Schürmann (daschuer)
2021-09-20 13:12:19 Daniel Schürmann mixxx: status In Progress Fix Committed
2021-09-20 13:12:21 Daniel Schürmann mixxx: milestone 2.3.1
2021-09-29 21:42:29 Daniel Schürmann mixxx: status Fix Committed Fix Released
2022-10-08 21:40:30 Swiftb0y bug watch added https://github.com/mixxxdj/mixxx/issues/10504
2022-10-08 21:40:31 Swiftb0y lock status Unlocked Comment-only