unable to change vinyl lead in time

Bug #1915483 reported by PL
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fix Released
Nino MP

Bug Description

Since v2.3 I am no longer able to change the lead-in time. I can type a value in the field, but whenever I press apply it will reset to the default lead-in time.
I tried it both on Mac an windows with the same result, so it should be a platform independent issue. When I hover with the mouse over the field, the cursor also rapidly switches between the arrow and text form.

The only way to get around this at the moment is to manually edit the config file, but that value also resets to the standard again every few restarts (or when I change other settings related to the vinyl mode.

This renders the absolute mode for Serato cds unusable, as there seems to be an offset with the cd you're able to download from the Serato website. Not sure if this is another bug or a systemic error of the positional information, as it behaves the same across all my machines, also independent of the medium I'm playing the timecode from. Even virtual dj hast the same (about 0.5s) offset.

Be (be.ing)
Changed in mixxx:
importance: Undecided → Medium
Revision history for this message
Daniel Schürmann (daschuer) wrote :

This happens also on Ubuntu Bionic

Changed in mixxx:
status: New → Confirmed
milestone: none → 2.3.0
tags: added: easy vinylcontrol
removed: lead-in vinyl
Nino MP (ninomp)
Changed in mixxx:
assignee: nobody → Nino MP (ninomp)
status: Confirmed → In Progress
Revision history for this message
Nino MP (ninomp) wrote :
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
Revision history for this message
Swiftb0y (swiftb0y) wrote :

Mixxx now uses GitHub for bug tracking. This bug has been migrated to:

lock status: Metadata changes locked and limited to project staff
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.