Absolute positioning vinyl control not working correctly

Bug #186341 reported by Sean M. Pappalardo on 2008-01-27
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Albert Santoni
1.6
Undecided
Unassigned

Bug Description

Using:

- Mixxx 1.6.0-beta1 from Debian repository (i386) on Debian Lenny (testing,) kernel 2.6.22-3-686 #1 SMP
- Also in 1.6.0-beta2 built on same system as above. Occurs with and without CPU optimization compile option.
- Also in 1.6.0-beta3 built from source on same system but on kernel 2.6.24-1-686.
- Also in 1.6.0-beta4 built from source on same system also on kernel 2.6.24-1-686 and on Windows XP Home x86 and Pro x64.
- Pioneer CDJ-700S with Serato Scratch Live CD (burned from download using CD Architect)
- Numark X2 (hybrid deck)

Issues:
- When I cue the CD at the beginning of track 1 (the main control track,) then hit PLAY, Mixxx jumps to 0:30 into the track instead of the beginning.
- If I repeatedly tap CUE (producing a sampler effect) Mixxx just keeps advancing the track instead of jumping back to the cue point. After about 4 track seconds pass while doing this, it jumps back to 0:30(.59) (This is now in bug 253318)

I also tested with XWax 0.3 and 0.4 (from binary) and none of these problems exist. (Different problems do. :) )

Albert Santoni (gamegod) wrote :

Thanks for the bug report!

1) Your first problem is a known issue, I happened to break the lead-in time setting just before the beta1 release. I'd like to have it fixed before beta2.

2) When you mention tapping CUE, are you talking about on your CDJ or in Mixxx? Were you using vinyl control simultaneously?

Albert

Changed in mixxx:
assignee: nobody → gamegod
importance: Undecided → Medium

I was talking about tapping CUE on the CDJ which should effectively spit out the timecode signal from the cue point, and do it repeatedly each time I tap it. If I hold it down, it's like pressing PLAY from the cue point, but as soon as I release it, it returns back to the cue point. With a regular CD, this creates a sampler effect.

One question: How quickly can I (read: should I be able to, if everything is working correctly) repeatedly tap the CUE button on the CDJ? (I.e. How much time is needed (ms) for the software to get a reliable absolute timecode?)

Albert Santoni (gamegod) wrote :

If I remember correctly, with a Serato record it should take ~20 ms to read enough bits off the record to grab the position. However, that's in the ideal case that your signal is good. If your signal is too weak or is too loud (clipping), it won't pick up the position correctly.

If it's jumping back to 0:30, then it's definitely related to the first problem. I'm not properly adding the lead-in time into my calculations, and it sounds like Mixxx's calculated position (pos. from timecode - Lead-in) is going negative, which is forced to zero instead. (And somewhere along the way it ends up at 0:30...)

Just out of curiosity, what is your lead-in time set at in the vinyl control preferences?

Thanks again,
Albert

Clarifications:
- Yes, Vinyl control mode was on. (If not, Mixxx doesn't respond to the CDJ.)
- I find that when I first tap & hold CUE on the CDJ, Mixxx jumps to 0:30. If I tap CUE for short durations after that, it will slowly advance to 0:33(.59) then jump back to 0:30. (Again, XWax doesn't exhibit this behavior.) If I set another cue point (on the CDJ) later in the track, Mixxx does the same thing only that much later in the track.

Also: I just discovered that when I pause the CDJ (where it repeatedly stutters the current couple of frames so you can tell exactly where to set the cue point) Mixxx just slowly plays the track (sounds like wiggling your finger on a record as it plays) ahead 3-4 seconds, then bounces back to the pause point and repeats. (Very similar behavior as above and I'm sure it's caused by the same problem since the timecode looks about the same to Mixxx in both situations.)
Here again, XWax handles this correctly (though not 100%...it does stutter, but drifts a little on each stutter.)

> Just out of curiosity, what is your lead-in time set at in the vinyl control preferences?

0 seconds, absolute mode. Preamp is 0.

Also, I got the circles set nicely in XWax and I'm using the same input, I'm sure the signal level is good.

Albert Santoni (gamegod) wrote :

Ok, thanks for the details. This'll help me when I sit down to troubleshoot and fix this. :)

Albert Santoni (gamegod) on 2008-03-01
Changed in mixxx:
status: New → Triaged
Natt (iliandp) wrote :

Hi, i'm new to Mixxx, and pretty much loving it so far!
I've been using a SSL02 vinyl on a SL 1210 turntable (almost new) through a ESI Quatafire soundcard (has preamps, i've set the input level to a nice steady high signal) and it's working quite well. Though i have experienced some problems similar to Pegasus.

-When putting the needle at the start of the record it jumps to around 0:23 and plays from there.

-Sometimes the track playing skips half a beat backwards. Basically this just comes out of nowhere, but i suppose the reason could be any.

Anyway, keep up the good work!

Oh, and i'm running the 1.6.0beta2 version.

Albert Santoni (gamegod) on 2008-04-07
Changed in mixxx:
status: Triaged → Confirmed
description: updated
Albert Santoni (gamegod) on 2008-04-26
Changed in mixxx:
importance: Medium → High

The same behavior exists in 1.6.0~beta3 on the same system.

description: updated
description: updated
Albert Santoni (gamegod) wrote :

Latest commit (r2033) in SVN should help combat some of the symptoms people have described here, but I'm having lots of problems testing Serato CD. (It's a long story, but it's hard to do without a CDJ) :)

This is still a problem in Beta4. I also noticed that if I switch tracks while the timecode CD is playing, the software acts like its set to relative mode even though it isn't. I have to restart the software to recover from this.

description: updated
Albert Santoni (gamegod) wrote :

Thanks for the update Pegasus.

Can you open Audacity, make sure the device is set to an ALSA device, and record a sample from your CDJ with the Serato CD? (post a screenshot of what the sample looks like, if you can)

Also, maybe you can try running xwax with an ALSA device. You can do this by running:
xwax -a plughw:0
(or plughw:1, whatever your soundcard is)

This still feels like a volume level problem to me, because absolute mode can behave like relative mode when the volume level is too quiet or too loud, and I've seen it do funky jumping things. I could still be wrong though, and it sucks that I'm having a very hard time testing Serato CD support.

Albert Santoni wrote:
> Thanks for the update Pegasus.
>
> Can you open Audacity, make sure the device is set to an ALSA device,
> and record a sample from your CDJ with the Serato CD? (post a screenshot
> of what the sample looks like, if you can)

Why not just download the WAV file from Rane and burn it to CD?
http://rane.com/scratchlivecontrol.zip
You can just use a Discman or your computer CD drive if you have to, as
you'll still see the :30 jump thing when you play from the track start.

> Also, maybe you can try running xwax with an ALSA device. You can do this by running:
> xwax -a plughw:0
> (or plughw:1, whatever your soundcard is)

Holy crap. When I do that, it tears through the track at 4x the correct
speed but sounds like buzzing/noise. I see tons of "ALSA: playback
xrun." with a "ALSA: capture xrun." once in awhile in the console. I
fiddled with the kmix settings but nothing helps. (I usually run it with
-d /dev/dsp )

BTW, it's still an issue where Mixxx seems to have the preamp turned on
even though it's not, compared to xwax anyway. I can counter that though
by using the output pot on my mixer.

<<--------------------------------------------------------------------------------->>
This E-Mail message has been scanned for viruses
and cleared by >>SmartMail<< from Smarter Technology, Inc.
<<--------------------------------------------------------------------------------->>

description: updated
Albert Santoni (gamegod) wrote :

Fixed seed value for LFSR in SVN. Should we close this bug now?

That would be nice, but there are still problems with the second issue: repeatedly tapping CUE for a sampler effect. Mixxx still keeps advancing about 4 seconds then jumps back to the cue point. Its as if it's not looking for the absolute position within 4s of a seek.

Albert Santoni (gamegod) on 2008-07-30
Changed in mixxx:
status: Confirmed → Fix Committed
description: updated

We've moved the remaining cueing issue to bug 253318.

Natt: The skipping 1/2 beat backwards thing is also related to bug 253318 so you'll likely want to subscribe to that too.

Changed in mixxx:
status: Fix Committed → Fix Released
Meade (kincke) wrote :

This still occurs for me in the latest mixxx

Matt C. (matt-clark66) wrote :

I'm experiencing this exact issue on Mixxx 1.8.2, running on Ubuntu Lucid 64 bit and Serato vinyls. I usually have the lead-in time set to 0. I've tried setting it to 45, and then I can manually cue the record back to the beginning of the song. Oddly enough, Mixxx appears to get stuck while cueing at the very beginning of the song. To get it moving, I have to pretty much scratch the record back and forth.

Matt C. (matt-clark66) wrote :

Actually, to get Mixxx "un-stuck", I have to manually force the record to spin faster...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers