DEBUG ASSERT at src/util/db/dbnamedentity.h:25

Bug #1861431 reported by Daniel Schürmann
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Uwe Klotz

Bug Description

Critical [Main]: DEBUG ASSERT: "normalizeName(name) == name" in function void DbNamedEntity<T>::setName(const QString&) [with T = CrateId] at src/util/db/dbnamedentity.h:25

This was reported here
https://bugs.launchpad.net/mixxx/+bug/1861421
and seems to be unrelated to the original report.

Revision history for this message
Uwe Klotz (uklotzde) wrote :

Caused by invalid (= empty) crate names that slipped into the database before some validation has been added.

Revision history for this message
Daniel Schürmann (daschuer) wrote :

Ok, so nothing to do here, except to ask the user to rename it's empty need crate?

Revision history for this message
Uwe Klotz (uklotzde) wrote :

Batch renaming of crates is not possible, because the uniqueness constraint might be violated:

UPDATE crates SET name = TRIM(name) where name <> TRIM(name);

Uwe Klotz (uklotzde)
Changed in mixxx:
importance: Undecided → Low
assignee: nobody → Uwe Klotz (uklotzde)
status: New → In Progress
milestone: none → 2.3.0
Revision history for this message
Uwe Klotz (uklotzde) wrote :
Changed in mixxx:
milestone: 2.3.0 → 2.2.4
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers