When pulse is used as output the gui hangs on first open attempt

Bug #1848310 reported by Claude van der Ryst on 2019-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Undecided
Unassigned

Bug Description

OS: Linux Mint 19.1 Cinnamon (Cinnamon 4.0.10 and kernel 4.15.0-46-generic)
CPU: Intel© Core™ i3-5005U CPU @ 2.00GHz × 2
Video: Intel Corporation HD Graphics 5500
Sound: Alto Live 1604 USB audio interface

Steps to reproduce the problem: When I open Mixxx the first time and click on the Enable Auto DJ button (with tracks already added in the list for Auto DJ), deck 1 will hang with the message "Loading Track". If I force close Mixxx and open Mixxx again, and use the Enable Auto DJ button again, the track gets loaded in deck 1 and starts playing as if nothing was wrong.

Claude van der Ryst (pcevdryst) wrote :
ronso0 (ronso0) wrote :

Thank you for reporting this bug.

Which version of Mixxx do you use? Also, please attach the Mixxx log from the session when the error occurs.
Does the error also occur when you manually load a track, or does it only happen with AutoDJ? If only AutoDJ is affected, please change the bug title accordingly.

Claude van der Ryst (pcevdryst) wrote :

Hi

I'm using Mixxx 2.2.2 x64. I have attached the Mixxx log file. I have tested it when loading a track manually and pressed the play button which seems to have the same result. So I doubt it would be a bug in the AutoDJ code handler. Let me know if I should still change the bug title. What I did found is if I change the output directly to the device, I don't have this problem, though I can't use other applications that makes use of sound as Mixxx has exclusive access to the device and pulse can't access the device then. (I have to close Mixxx every time to in order for the other application's sound to play) I hope this is clear and makes sense. Please let me know if you require more info.

tags: removed: pulse
ronso0 (ronso0) wrote :

Please update to Mixxx 2.2.4 and test if that issue persists.

If so, please test if it works after disabling pasuspender:
https://github.com/mixxxdj/mixxx/wiki/troubleshooting#other-programs-do-not-make-sound-while-mixxx-is-running

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers