Inconsistent database: LibraryScanner

Bug #1846971 reported by Uwe Klotz
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Uwe Klotz

Bug Description

Due to various bugs and inconsequent usage of transactions the Mixxx database accumulates inconsistent entries over time. Those inconsistent contents cause consecutive bugs:

https://bugs.launchpad.net/mixxx/+bug/1603348
https://bugs.launchpad.net/mixxx/+bug/1846775
https://bugs.launchpad.net/mixxx/+bug/1846945

How-to-fix: Periodically (e.g. after upgrading the database schema on startup) remove inconsistent rows from all tables for which the referential integrity constraints are violated.

Uwe Klotz (uklotzde)
Changed in mixxx:
milestone: 2.2.3 → none
assignee: Uwe Klotz (uklotzde) → nobody
status: In Progress → New
Revision history for this message
Uwe Klotz (uklotzde) wrote :

Fix only inconsistencies caused by LibraryScanner: https://github.com/mixxxdj/mixxx/pull/2321

Changed in mixxx:
milestone: none → 2.2.3
assignee: nobody → Uwe Klotz (uklotzde)
status: New → In Progress
summary: - Inconsistent database
+ Inconsistent database: LibraryScanner
Uwe Klotz (uklotzde)
description: updated
Uwe Klotz (uklotzde)
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers