Purging multiple tracks is awfully slow

Bug #1845837 reported by Uwe Klotz
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Uwe Klotz

Bug Description

When purging tracks Mixxx tries to delete those tracks from every playlist.

The only playlists I have are history playlists, many. Purging tracks from each playlist invokes PlaylistTableModel::select() for each processed playlist which could be slow for a big library. As a consequence, the UI is stalled for minutes!!

This bug is caused by invoking PlaylistDAO::removeTracksFromPlaylist() in a loop in PlaylistDAO::removeTracksFromPlaylists(). Each emitted changed(playlistId) signal triggers a PlaylistTableModel::select() operation.

Uwe Klotz (uklotzde)
description: updated
Uwe Klotz (uklotzde)
description: updated
Changed in mixxx:
status: New → Confirmed
description: updated
Uwe Klotz (uklotzde)
description: updated
Uwe Klotz (uklotzde)
Changed in mixxx:
assignee: nobody → Uwe Klotz (uklotzde)
milestone: none → 2.3.0
importance: Undecided → Low
status: Confirmed → In Progress
Revision history for this message
Uwe Klotz (uklotzde) wrote :
Changed in mixxx:
milestone: 2.3.0 → 2.2.4
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers