2.2.2 Sound drops out during recording (ubuntu 18.04)

Bug #1842679 reported by Randy
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Critical
Uwe Klotz

Bug Description

i had the same issue during the previous release at a gig last May and it happened again while trying to record today.

Warning []: CachingReader - ERROR: No LRU chunk to free in allocateChunkExpireLRU.
Warning []: CachingReader - ERROR: Couldn't allocate spare CachingReaderChunk to make CachingReaderChunkReadRequest.

The problem developed after mixing a few tracks and the above is the repeated serious of error messages and once I stopped the recording. Performance went back to normal once I stopped the recording. REcording format was set to MP3

If it matters, I currently have the recording directory the same as my music library, on the same HDD partition, and will experiment tomorrow to see if recording to a separate physical drive makes a difference

Revision history for this message
Uwe Klotz (uklotzde) wrote :

The issue is unrelated to recording.

How many decks and samplers are you using at once?

We should consider increasing the hard-coded limits of CachingReader to prevent such a shortage of resources.

Changed in mixxx:
importance: Undecided → Critical
assignee: nobody → Uwe Klotz (uklotzde)
milestone: none → 2.2.3
Revision history for this message
Uwe Klotz (uklotzde) wrote :

Trying to mitigate or prevent this issue:
https://github.com/mixxxdj/mixxx/pull/2265

Changed in mixxx:
status: New → Incomplete
status: Incomplete → In Progress
Revision history for this message
Uwe Klotz (uklotzde) wrote :

Do you have the complete log from that session?

We have never seen this error before. It's difficult to reason about what exactly blocked the processing and recycling of cached sample data chunks. As a consequence incoming read requests have been dropped.

Revision history for this message
Randy (eberlin) wrote :

2 decks, no samplers.

ivy bridge, 8gb ram, nvidia sound (now running latest nvidia driver)

I don't know how much ram was in use as I did have Chrome open, but the case in May (unfortunately no log available) was only running mixxx. In March I successfully made a few recordings, browser open and all.

Due to partitioning, my main library is the same partition as my primary, but I have a physically separate internal HDD (neither are solid state) where I somehow still have other library titles. I sometimes forget to mount the drive, as I did in this case, but cannot remember if that was the case in May.

Revision history for this message
Uwe Klotz (uklotzde) wrote :

Strange. It really looks like that recording has somehow interfered with the processing of audio decoding and the CachingReader ran out of resources.

Revision history for this message
Randy (eberlin) wrote :

I tried another session this evening, just throwing in tracks to get some stuff recorded. It did hiccup again, but eventually powered through.

I don't know if it matters, but just before the session with the problem in May, Mixxx was ready to go when I had a power outage (didn't know I was on battery power and that ran out) and I had to manually reset the journal indexing in Ubuntu/grub2 or whatever that process is called

Revision history for this message
Randy (eberlin) wrote :

ok, changing the recording directory to another hard drive worked. I use 320k mp3s and flacs of mostly 6-7 minute long songs and save to 320k mp3 for a sense of how big the file sizes are

Uwe Klotz (uklotzde)
Changed in mixxx:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Uwe Klotz (uklotzde)
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers