M4A support no longer possible in Debian Buster due to removal of libmp4v2

Bug #1842208 reported by Bob Ham on 2019-09-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Uwe Klotz

Bug Description

The libmp4v2 library has been removed from Debian Buster:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=921127

Which means it's no longer possible to compile Mixxx with M4A support. The Debian bug mentions that "better alternatives exist". Perhaps Mixxx could switch to an alternative?

Uwe Klotz (uklotzde) wrote :

An alternative solutio is waiting to be merged, requires FFmpeg 4.x:

https://github.com/mixxxdj/mixxx/pull/1356

I already use this exclusively for my custom builds instead of FAAD2.

Changed in mixxx:
milestone: none → 2.3.0
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Uwe Klotz (uklotzde)
Be (be.ing) on 2019-09-14
Changed in mixxx:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers