track pegs mixxx at 100% when adding to library

Bug #1832325 reported by Igor
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Critical
Uwe Klotz

Bug Description

1. start with a fresh install of mixxx (i removed my `.mixxx` directory)
2. add a library that is just a single directory containing this track: https://igor.moomers.org/random/of%20porcelain%20--%20and%20here%20i%20am%20free%20(original%20mix).mp3
3. mixxx cpu becomes 100% and the file is never added to the track list

this is on ubuntu 19.04 disco. i've built mixxx 2.2.1 with scons but the same issue occurs with 2.2.0 from the default repository as well as on 2.1.8 that i also built from source.

Revision history for this message
Igor (igor47) wrote :

this is what the output of `mixxx --developer` looks like:

Debug [LibraryScanner 1]: LibraryScanner - slotStartScan()
Debug [LibraryScanner 1]: LibraryScanner - Recursively scanning library.
Debug [LibraryScanner 1]: SqlTransaction - Started new SQL database transaction on "MIXXX-2"
Debug [Thread (pooled)]: Importing track "/home/igor47/Music/music/of porcelain/and here i am free (original mix).mp3"
Debug [LibraryScanner 1]: GlobalTrackCache - Resolving track by canonical location "/home/igor47/Music/music/of porcelain/and here i am free (original mix).mp3"
Debug [LibraryScanner 1]: GlobalTrackCache - Cache miss - allocating track ["/home/igor47/Music/music/of porcelain/and here i am free (original mix).mp3" | "/home/igor47/Music/music/of porcelain/and here i am free (original mix).mp3" | -1]
Debug [LibraryScanner 1]: GlobalTrackCache - Cache miss - inserting new track into cache ["/home/igor47/Music/music/of porcelain/and here i am free (original mix).mp3" | "/home/igor47/Music/music/of porcelain/and here i am free (original mix).mp3" | -1] QObject(0x0)
Debug [LibraryScanner 1]: SoundSourceProxy - SoundSourceProvider "MAD: MPEG Audio Decoder" created a SoundSource for file "file:///home/igor47/Music/music/of porcelain/and here i am free (original mix).mp3" of type "mp3"

Revision history for this message
Uwe Klotz (uklotzde) wrote :

Confirmed. Caused by an invalid BPM value (NaN).

Changed in mixxx:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Uwe Klotz (uklotzde)
milestone: none → 2.2.2
Revision history for this message
Uwe Klotz (uklotzde) wrote :

This bug also affects 2.1.8.

Revision history for this message
Uwe Klotz (uklotzde) wrote :
Uwe Klotz (uklotzde)
Changed in mixxx:
status: In Progress → Fix Committed
Uwe Klotz (uklotzde)
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers