AutoDJ mix cant save to playslist in same order?

Bug #1829601 reported by Mikael
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Daniel Schürmann

Bug Description

I have put 100 tracks in the AutoDJ section and arrange the ordering.
I want to save that "list" in exact order to my "Playlist" section.
When i do that all the tracks follows. But they are not in the same order as in the AutoMix!?
Can fix that?

Changed in mixxx:
status: New → Confirmed
importance: Undecided → High
milestone: none → 2.2.2
Revision history for this message
geozubuntu (geozubuntu) wrote :

Partially confirm it in Linux mint.

Mixxx 2.3.0-alpha-pre (build master r6796) for Linux Mint 19.1 Tessa (downloaded from https://downloads.mixxx.org/builds/master/release/ ) works partially.

The problem occurs only with Drag and drop. If select multiple tracks in Auto DJ and *drag* them to the playlist the order is NOT correct. No matter if select all or some.

But
21 tracks in auto DJ - change the order - select them - right click - Add to playlist and select the desired playlist (or create a new) it works correctly.
Go to playlists open the list and they are here, transferred with the correct order as it should.

So most probably the problem starts from the drag and drop function.

Thanks

Revision history for this message
Mikael (mike999x) wrote : Re: [Bug 1829601] Re: AutoDJ mix cant save to playslist in same order?

 Uploaded the version latest 64x and that did it. Now the list gets in right order..ThanksMike

    On Saturday, May 18, 2019, 2:10:48 PM GMT+2, geozubuntu <email address hidden> wrote:

 Partially confirm it in Linux mint.

Mixxx 2.3.0-alpha-pre (build master r6796) for Linux Mint 19.1 Tessa
(downloaded from https://downloads.mixxx.org/builds/master/release/ )
works partially.

The problem occurs only with Drag and drop. If select multiple tracks in
Auto DJ and *drag* them to the playlist the order is NOT correct. No
matter if select all or some.

But
21 tracks in auto DJ - change the order - select them - right click - Add to playlist and select the desired playlist (or create a new) it works correctly.
Go to playlists open the list and they are here, transferred with the correct order as it should.

So most probably the problem starts from the drag and drop function.

Thanks

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1829601

Title:
  AutoDJ mix cant save to playslist in same order?

Status in Mixxx:
  Confirmed

Bug description:
  I have put 100 tracks in the AutoDJ section and arrange the ordering.
  I want to save that "list" in exact order to my "Playlist" section.
  When i do that all the tracks follows.  But they are not in the same order as in the AutoMix!?
  Can fix that?

To manage notifications about this bug go to:
https://bugs.launchpad.net/mixxx/+bug/1829601/+subscriptions

Revision history for this message
geozubuntu (geozubuntu) wrote :

The same as in my comment #1 above occurs also in windows 7 x86 and Mixxx 2.3.0-alpha-pre-master-git6792. 32 bits

Drag and drop a batch of tracks from Auto Dj to playlist shuffles the order of the tracks.

Right click and Add to Playlist works correctly .

The linux mint I wrote above is 64 bits.

Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Revision history for this message
Uwe Klotz (uklotzde) wrote :

We should release 2.2.2 asap. When is this fix supposed to be ready?

Revision history for this message
Daniel Schürmann (daschuer) wrote :

I don't see a chance I can fix this during this week. So it schold not block 2.2.2

On the other hand there is a one liner hack possible.
https://github.com/mixxxdj/mixxx/blob/8deb7427a4e016f47e4f6a4d767e8158d7147235/src/library/playlistfeature.cpp#L110

"if (false)"

addMultipleTracks() keeps the order.

A better solution would be to pass a flag if the order should be persist and consider also the source pointer.

If you find time, please take over.

Revision history for this message
Daniel Schürmann (daschuer) wrote :

Now the refactoring solution is here for review:
https://github.com/mixxxdj/mixxx/pull/2237

Uwe Klotz (uklotzde)
Changed in mixxx:
milestone: 2.2.2 → 2.2.3
Uwe Klotz (uklotzde)
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers