Dropping Track from finder does not work

Bug #1822424 reported by Daniel Schürmann
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
High
Daniel Schürmann

Bug Description

This was reported here https://mixxx.zulipchat.com/#narrow/stream/109171-development/topic/2.2E1.2E8.20release

The URL reported by finder is somehow unknown by Mixxx 2.1.8

mixxx.log snipped:

Debug [Main]: handleTrackDragEnterEvent()
Debug [Main]: dropEventFiles() true (QUrl("file:///.file/id=6571367.1629051") )
Debug [Main]: mimeData.hasText() false ""
Debug [Main]: event->ignore();

Finder reports the "File reference URL" Instead of the URL build from the path.

The issue is discussed here:
https://bugreports.qt.io/browse/QTBUG-40449?page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel&showAll=true

Tags: osx Edit Tag help
Changed in mixxx:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Daniel Schürmann (daschuer)
milestone: none → 2.1.8
tags: added: osx
Revision history for this message
Daniel Schürmann (daschuer) wrote :
Revision history for this message
Daniel Schürmann (daschuer) wrote :
Revision history for this message
Foss-4 (foss-4) wrote :

fix has been commited, manually updating status, as no automatic mechanism between github / launchpaad seems to be in place.

Changed in mixxx:
status: In Progress → Fix Committed
summary: - Dopping Track from finder does not work
+ Dropping Track from finder does not work
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers