Mixxx build fails in misleading ways if libqt5x11extras5-dev not installed

Bug #1808892 reported by Owen Williams on 2018-12-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Be

Bug Description

I was doing a build and I got messages from scons that I was missing a lot of libraries, like "libshout not installed", even though they definitely were there. When looking at the config.log, the real problem was that libqt5x11extras5-dev was not installed. We should check for that explicitly early on in the dependency checking to avoid the misleading error messages.

Be (be.ing) on 2018-12-18
Changed in mixxx:
importance: Undecided → Medium
status: New → Confirmed
milestone: none → 2.2.0

Using conf.CheckLib to check for it then throw an exception instead of
adding it to LIBS w/ env.Append would fix the issue

On Mon, Dec 17, 2018 at 6:00 PM Be <email address hidden> wrote:

> ** Changed in: mixxx
> Importance: Undecided => Medium
>
> ** Changed in: mixxx
> Status: New => Confirmed
>
> ** Changed in: mixxx
> Milestone: None => 2.2.0
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/1808892
>
> Title:
> Mixxx build fails in misleading ways if libqt5x11extras5-dev not
> installed
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/1808892/+subscriptions
>

Be (be.ing) wrote :
Changed in mixxx:
assignee: nobody → Be (be.ing)
status: Confirmed → In Progress
Be (be.ing) on 2018-12-20
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers