Loading a track with the exact same speed as the currently running one sometimes results in double speed

Bug #1808697 reported by xerus
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Daniel Schürmann

Bug Description

Sometimes, when I have a track currently playing that has e.g. 100 BPM and load a track with 100 BPM into the other deck while having auto-sync enabled on both decks, the newly loaded track will suddenly be sped up by +100, rarely also slowed down by -50. This is simply annoying and nearly drives me crazy, because when it starts happening it keeps on happening and I have to release auto-sync to manually fix it every time.

I use Mixxx 2.2.0-rc on Linux

Revision history for this message
Daniel Schürmann (daschuer) wrote :

What means "will suddenly be sped up by +100"?

+100 BPM? 200%?
Does it start playing with the correct speed? How long does it takes until the track speeds up? Does it stick with +100 or does it go down again?

Revision history for this message
xerus (xerus2000) wrote :

It speeds up instantly to +100% and keeps at it.

Changed in mixxx:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Daniel Schürmann (daschuer)
milestone: none → 2.1.6
Revision history for this message
Daniel Schürmann (daschuer) wrote :

I have managed to see the issue with 2.2 but not with 2.1 and
https://github.com/mixxxdj/mixxx/pull/1955 merged.

Maybe i have fixed it along with:
https://bugs.launchpad.net/mixxx/+bug/1808698

Changed in mixxx:
milestone: 2.1.6 → 2.1.7
Revision history for this message
Daniel Schürmann (daschuer) wrote :

@xerus Can you confirm that this is fixed now?

Revision history for this message
xerus (xerus2000) wrote :

Well, it was not 100% reproducible when it happened either, Quite likely that you fixed it with the other bug. We can close and I can reopen if it appears again.

Revision history for this message
Daniel Schürmann (daschuer) wrote :

Thank you.

Changed in mixxx:
status: Confirmed → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
Revision history for this message
xerus (xerus2000) wrote :

It happened again, and when pausing and playing even propagated to the other track - running 2.3.0-alpha-pre!

xerus (xerus2000)
Changed in mixxx:
status: Fix Released → Confirmed
Revision history for this message
Daniel Schürmann (daschuer) wrote :

What exactly did you done step by step and what does Mixxx wrong?
How do you manage to set A to > 100 % rate.

I see how this case is odd, however I don't see anything wrong from your screenshot.

The sync feature calculated the half/double factor by using the file BPM. This is done for a good sound at any slider position.

Your case is this:
             A B
Current BMP 210,77 421,54
Rate 100,73 142,27
File BMP 105 174

Since 174 is closer to 210 than to 105, (36 vs 69) the rate at unity A is adjusted to 20 %.
If you now adjust A to 100 rate B becomes 140, which is correct.

Syncing to B to 210 might be expected in this case, but that creates other odd cases in less exceptional cases.

Revision history for this message
xerus (xerus2000) wrote :

Yeah, it calibrated itself upwards, sort of...
I can't recall the exact steps now, I'll see what I can do...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers