double click Loads wrong track, after delte search and scroll

Bug #1803148 reported by Daniel Schürmann on 2018-11-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
High
Daniel Schürmann

Bug Description

* Search a track using the search box
* Remove the search
* scroll the library
* double click on a track
-> a different track is loaded to the deck.

I first thought it was my fault at late night, but I can reproduce it here using the current master build.

Changed in mixxx:
importance: Undecided → High
Uwe Klotz (uklotzde) wrote :

I remember experiencing a similar issue during the development of https://github.com/mixxxdj/mixxx/pull/1762. Fixed it assuming that I have broken it.

Please check if you can reproduce the issue with the refactored widget and signal handling.

Daniel Schürmann (daschuer) wrote :

https://github.com/mixxxdj/mixxx/pull/1762 is also effected as well as the current 2.1 branch.

Changed in mixxx:
milestone: none → 2.1.6
assignee: nobody → Daniel Schürmann (daschuer)
Uwe Klotz (uklotzde) wrote :

I'm able to reproduce it with 2.2 beta/rc.
I'm not able to reproduce it with https://github.com/mixxxdj/mixxx/pull/1762.

Workflow as described, using the same tracks for each test.

Daniel Schürmann (daschuer) wrote :

I have probably tricked myself. Now I am not able to reproduce the problem with any build on my Trusty development machine. On my Bionic machine I can reproduce it with any version. I have no https://github.com/mixxxdj/mixxx/pull/1762 there.

The difference is that on Trusty the focus border moved to the track table on Bionic not.
Wen I click into the table the scrolling is restored under the mouse. It looks like we restore the old scroll position twice.

Do you have an idea what has fixed the issue for you?

Uwe Klotz (uklotzde) wrote :

I think my last commit in #1762 fixed it: "Don't restore vscroll position when search becomes inactive "

Uwe Klotz (uklotzde) wrote :

But all the signal handling has been modified substantially.

Daniel Schürmann (daschuer) wrote :

Ok, the signal changes are a very reasonable part of the fix of this issue here.
In addition there is some mess with the stored scroll position we need to fix.
I think it is time to back-port your PR to 2.1.6.
I will give it a try.

Daniel Schürmann (daschuer) wrote :
Changed in mixxx:
status: New → In Progress
Uwe Klotz (uklotzde) on 2018-11-18
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers