Echo effect is not synchronized with actual tempo

Bug #1793232 reported by Uwe Klotz
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Be

Bug Description

I usually adjust the time parameter of the echo effect to the 12 o'clock position to get a beat synchronized echo out effect. This doesn't seem to work correctly when pitching the playing track. The synchronization only takes the nominal tempo of the track into account, but not the actual tempo.

Currently the echo effect cannot be used for a beat synchronized echo out on tracks that are not played with their original tempo. This is a very common case when trying to match tracks with different tempos somewhere in the middle between their original tempos. For some tracks this is barely noticeable while others are producing weird double beats when activating the echo effect.

Revision history for this message
Uwe Klotz (uklotzde) wrote :
description: updated
Revision history for this message
Be (be.ing) wrote :

This was implemented in https://github.com/mixxxdj/mixxx/pull/1350 for 2.1. Has there been a regression?

Revision history for this message
Uwe Klotz (uklotzde) wrote :

Confirmed for both 2.1.4 as well as 2.2 :(

Be (be.ing)
Changed in mixxx:
importance: Undecided → High
status: New → Confirmed
milestone: none → 2.1.5
Revision history for this message
Be (be.ing) wrote :

I compiled commit c74c08f from that pull request and indeed the issue is present there too. I guess I did not test carefully enough when working on that.

Revision history for this message
Uwe Klotz (uklotzde) wrote :
Revision history for this message
Be (be.ing) wrote :
Changed in mixxx:
assignee: nobody → Be (be.ing)
status: Confirmed → In Progress
Uwe Klotz (uklotzde)
Changed in mixxx:
milestone: 2.1.5 → 2.1.6
Be (be.ing)
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers