Mixxx 2.2.0: In Preview and Sampler Decks, right-click on playing track jumps to start of track but does not stop playing

Bug #1779468 reported by Paul Felts on 2018-06-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann

Bug Description

Mixxx 2.2.0: In Preview and Sampler decks (LateNight Skin), right-click on deck's PLAY button, while playing track, jumps to start of track but does not stop playing. The tooltip for Preview and Sampler Decks indicates that a right-click should jump to start of track and stop playing. The track will jump to start but continue playing. The issue occurs whether the track's LOOP button is clicked or not. I will check if the issue occurs with other skins, besides LateNight, and report here.

EDIT: the issue is the same in other skins

EDIT EDIT: Ah. The issue is related to CUE mode. I had my CUE mode set to CUP. Changing my CUE mode to MIXXX mode restores the deck behavior which is indicated by the tooptip for the Preview and Sampler decks. So, maybe the tooltip could/should change depending on chosen CUE mode? Or maybe CUE mode shouldn't affect the right-click behavior of the Preview and Sampler decks?

Thanks for reading.

Paul Felts (h-pa5l-v) on 2018-06-30
description: updated
Daniel Schürmann (daschuer) wrote :
Changed in mixxx:
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Daniel Schürmann (daschuer)
milestone: none → 2.1.2
ronso0 (ronso0) on 2018-08-10
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers