Mixxx may crash when importing TagLib ID3v2 APIC frames

Bug #1774790 reported by Uwe Klotz
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Critical
Uwe Klotz

Bug Description

Mixxx may crash when reading TagLib ID3v2 APIC frames if their runtime type differs from the compile time expectations, e.g. when an APIC frame is actually not a TagLib::ID3v2::AttachedPictureFrame.

Reported in the forums:
https://www.mixxx.org/forums/viewtopic.php?f=3&t=11872&p=38590#p38585

Solution:
We need to use a dynamic_cast at runtime instead of a static_cast at compile time to identify the actual type of a frame and prevent crashes caused by corrupt or malformed files.

Uwe Klotz (uklotzde)
Changed in mixxx:
assignee: nobody → Uwe Klotz (uklotzde)
Revision history for this message
Uwe Klotz (uklotzde) wrote :
summary: - Mixxx may crash when reading TagLib ID3v2 frames
+ Mixxx may crash when importing TagLib ID3v2 frames
summary: - Mixxx may crash when importing TagLib ID3v2 frames
+ Mixxx may crash when importing TagLib ID3v2 APIC frames
description: updated
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers