cannot add to auto dj from itunes within Mixxx

Bug #1766360 reported by Daniel Schürmann
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Uwe Klotz

Bug Description

Changed in mixxx:
milestone: none → 2.1.1
importance: Undecided → High
Revision history for this message
Uwe Klotz (uklotzde) wrote :

1st Add to Auto DJ through iTunes:
- Selected track is added to Mixxx library as expected
- Selected track does not appear in Auto DJ

2nd Add to Auto DJ through iTunes:
- Failed to add selected track to Mixxx library again:
Debug [Main]: TrackDAO: Adding track "<<FILE PATH>>"
Debug [Main]: src\library\dao\trackdao.cpp 371 FAILED QUERY [ "INSERT INTO track_locations (location,directory,filename,filesize,fs_deleted,needs_verification) VALUES (?,?,?,?,?,?)" ] QSqlError(19, "Unable to fetch row", "UNIQUE constraint failed: track_locations.location") Skip inserting duplicate track location "<<FILE PATH>>"
Warning [Main]: QSqlQuery::value: not positioned on a valid record
- Selected track does not appear in Auto DJ (as before)

Adding the track directly from the Mixxx library through 'Tracks' to Auto DJ works as expected.

Changed in mixxx:
status: New → Confirmed
Uwe Klotz (uklotzde)
Changed in mixxx:
assignee: nobody → Uwe Klotz (uklotzde)
Uwe Klotz (uklotzde)
Changed in mixxx:
status: Confirmed → In Progress
Revision history for this message
Uwe Klotz (uklotzde) wrote :
Revision history for this message
Uwe Klotz (uklotzde) wrote :

It turns out that on Windows track locations contain backslashes and track lookup silently fails without any proper error handling and logging. Lots of hours wasted to get there :((

Uwe Klotz (uklotzde)
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers