Sampler: position in overview doesn't match actual Cue position

Bug #1744170 reported by ronso0 on 2018-01-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann

Bug Description

* load a track to a deck
* set the Cue point somewhere in the middle of the track
(so you can esily distinguish it from the track beginning in the overview)
* drag that track to any sample deck
 = playposition in sampler's overview seems to be at start
* hit Play(from Cue)
 = play position jumps to previously set Cue point and plays from there

So, playback is fine, only the feedback via overview appears unreliable.

ronso0 (ronso0) wrote :

After restart, On the other hand, any sample deck loaded in the previous session shows wrong play position after restart, but plays correctly.
Drag any of those tracks with wrong play position from sampler to a deck:
 > play position matches Cue.
Drag that track back to a sample deck:
 > play position matches Cue.

ronso0 (ronso0) wrote :

Maybe a clue or not, but the same happens within decks when reloading a skin or switching to another:
Before, PlayPosition was at Cue point, afterwards it's at the track's beginning.

Changed in mixxx:
status: New → Confirmed
milestone: none → 2.1.0
importance: Undecided → Medium
Be (be.ing) on 2018-04-05
Changed in mixxx:
importance: Medium → Low
milestone: 2.1.0 → 2.2.0
Changed in mixxx:
milestone: 2.2.0 → 2.1.1
Changed in mixxx:
milestone: 2.1.1 → 2.1.2
Changed in mixxx:
milestone: 2.1.2 → 2.1.3
Changed in mixxx:
milestone: 2.1.3 → 2.1.4
Changed in mixxx:
milestone: 2.1.4 → 2.1.5
Changed in mixxx:
milestone: 2.1.5 → 2.1.6
Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Uwe Klotz (uklotzde) on 2018-11-18
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers