Heavy Aux input buffer underflows

Bug #1683924 reported by Daniel Schürmann
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Daniel Schürmann

Bug Description

This was reported here:
(Including a recording)

If you setup the ALSA loopback device for using the system sound as AUX input, it is heavily distorted. It does not happen if you pick "Experimential (no delay)" for Multi Soundcard sync.

Changed in mixxx:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Daniel Schürmann (daschuer)
milestone: none → 2.1.0
Revision history for this message
Ron granger (ron-granger) wrote :

It is distorted as well when I select "Experimental (no delay)". I hear crackles in the sound.
With Rubberband instead of Soundtouch it sounds better but it isn't gone. Additionally I get a delay of more than 2 seconds and when turning the sound up in pulseaudio (Mixxx is directly connected to ALSA) I hear a heavily distortion again.

Revision history for this message
Ron granger (ron-granger) wrote :

Switching to 41kHz as sample rate using the maximum audio buffer of 92.9 ms and using default (not Experimental!) sounds better.
But sometimes (and when changing the pulseaudio volume) I think it skips or repeats a part of the last played sound, I think there is a problem with buffering? Additionally a 100% pulseaudio output will result in clipping in Mixxx.

Be (be.ing)
Changed in mixxx:
milestone: 2.1.0 → none
Revision history for this message
RJ Skerry-Ryan (rryan) wrote :

Looks like this bug got lost in the shuffle. Does it still occur with Mixxx 2.1.4?

Revision history for this message
RJ Skerry-Ryan (rryan) wrote :

friendly ping @Daniel

Revision history for this message
Marco (c-moon) wrote :

I can confirm this issue isn't fixed yet in recent 2.3.0 Beta of Mixxx.
I was curious about the quality of the built-in RIAA preamp in my Denon MC7000, so I did a quick test and connected a turntable directly to it. In Mixxx I selected the Denon device as AUX1 in settings, so I can do recordings also from the analogue inputs of the Denon MC7000.
It worked but with crackling sound in the recordings as described above. If I pick "Experimental" and raise the audio buffer to 92,9 ms, the recording seems quite OK.

I also did a second test and configured Pulseaudio as AUX1 input and played some music through Pulseaudio as loopback device. This worked flawlessly without any changes in my normal settings to buffer (5,8 ms) or Multi Soundcard Sync (Default (long delay)).

So this problem could probably be related to ALSA itself, but it's just a guess (tested with Gentoo Linux 64-bit, Kernel 5.4 with RT-Patch).


Revision history for this message
Swiftb0y (swiftb0y) wrote :

Mixxx now uses GitHub for bug tracking. This bug has been migrated to:

lock status: Metadata changes locked and limited to project staff
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.