OSX 10.11: "Enter Full Screen" automatically added to View menu

Bug #1534292 reported by RJ Skerry-Ryan
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
jus

Bug Description

Apple has another "automagic" menu item we have to deal with and this time Qt doesn't handle it for us.

https://github.com/atom/electron/issues/3038
https://code.google.com/p/chromium/issues/detail?id=538872

Qt doesn't provide us any notification when we enter full screen so our existing menu item doesn't get updated to have the proper check state.

Workarounds:
*Add something like '\u200C' to the View item string so it doesn't string-equal "View" so Apple doesn't know to add it.
* Disable with the following objective-c snippet:

- (void)applicationWillFinishLaunching:(nonnull NSNotification *)notification {
    [[NSUserDefaults standardUserDefaults] setBool:NO forKey:@"NSFullScreenMenuItemEverywhere"];
}

Given we don't currently depend on having an objective-C compiler, the View hack is looking much more attractive.

Revision history for this message
RJ Skerry-Ryan (rryan) wrote :
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Sean M. Pappalardo (pegasus-renegadetech) wrote :

Looks like a bug on Apple's side, since that doc says it adds it "if an equivalent menu item isn't found." So it's obviously not seeing that we've added one.

Revision history for this message
jus (jus) wrote :
Revision history for this message
jus (jus) wrote :
Changed in mixxx:
milestone: none → 2.3.0
assignee: nobody → jus (jus)
status: Confirmed → In Progress
Be (be.ing)
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers