Crash on analyzing tracks

Bug #1530141 reported by Jay Harvey on 2015-12-30
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

I was so Happy to Download my new copy of Mixxx 2.0

Installed it over Mixxx 1.11 and all went well... Once it opened up on my Screen, I immediately load in my music directory... :( I had 46 not analyzed yet, so I ran them through the analyzer and by the 28 song Mixxx 2.0 crashed.

I am Running on Windows 10 Home Edition
CPU Type Intel Pentium III Xeon, 2600 MHz
Video Adapter Intel(R) G33/G31 Express Chipset Family (256 MB)
3 GB of Memory

I going to try a fresh install today and see what happens

In the meantime suggestions are welcome.

Jay Harvey (jharveysxm) wrote :
summary: - analyzing Tracks
+ Crash on analyzing tracks
Sébastien BLAISOT (sblaisot) wrote :

From lp:1530107 : 32 bit Windows and 32 bit Mixxx

Jay Harvey (jharveysxm) wrote :

Bug Trace report attached

Jay Harvey (jharveysxm) wrote :

I have a question can a faulty Drive be cause of this problem? Last night drive crashed on me

Of course it could. Faulty hard drives cause all kinds of problems, specifically taking thousands of times longer than expected to respond to application requests. This can cause OS libraries or Mixxx's dependent libraries to time out with undefined behavior.

Changed in mixxx:
status: New → Incomplete
RJ Skerry-Ryan (rryan) wrote :

Hm, that's possible Jay (sorry to hear that!).

Once you get a known good drive it'd be great to see if you can still reproduce the issue?

Changed in mixxx:
importance: Undecided → Critical
milestone: none → 2.0.1
Jay Harvey (jharveysxm) wrote :

The Problem seem to be a bad drive.... the drive crashed and load all the music on a new drive and it worked well

But Mixxx (we) got to work on this, the Mixxx should not crash, no other DJ software this crash happened with.

Uwe Klotz (uklotzde) wrote :

Hardware failures are out of our control. I don't see any practical follow-up activity related to this report and will close it as invalid.

Changed in mixxx:
status: Incomplete → Invalid
Be ( on 2017-11-12
Changed in mixxx:
milestone: 2.0.1 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments