hierarchical library display

Bug #1321841 reported by Be on 2014-05-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Joan

Bug Description

Currently, Mixxx always displays every single file in the library in a huge list that is somewhat difficult to navigate, even after using a search filter. I find it easier to navigate a large list of tracks when it is organized hierarchically like in Amarok. I feel that this method of displaying tracks is much less cluttered and easier to navigate. The default library display in Amarok organizes files by artist, which can be expanded to show album names alongside thumbnails of album covers, which can be expanded to show each track in the album in order by track number. This hierarchy can be customized to use different tags on different levels. An example use case to illustrate how this feature would be helpful is when a user wants to cue a track by a particular artist but does not remember the name of the specific track and is not certain which of two albums the track is on. In this case, a user could search for the artist, then look through only the two albums that they suspect the track is on without having to scroll through the clutter of every other track by that artist.

Be (be.ing) wrote :
Daniel Schürmann (daschuer) wrote :

Thank you for the bug report.

This is an aspect of:
Bug #671632
Bug #783833

Changed in mixxx:
status: New → Confirmed
importance: Undecided → Wishlist
Be (be.ing) wrote :

Actually, I think for Mixxx it would make more sense to imitate Banshee's library display than Amarok's.

Also, this is related but different from Bug #783833. That request is asking for a hierarchical display in the sidebar. I am proposing a rework of the tracklist display area.

Be (be.ing) wrote :

Taking another look at that screenshot, I don't think it would be good to imitate that exactly in the track list area. I propose a sort of hybrid between that Banshee screenshot and iTunes' interface. That is, the leftmost column would list artist, the column to the right would list album titles with cover thumbnails and year, and the column to the right of that would list tracks with track number, title, and duration. Which tag is listed in each column should be configurable. For example, some users may want a genre column to the left (or perhaps right) of the artist column. Which tags are displayed in what positions should be configurable in the track column as they are currently in the library display.

I think this would end up making considerably better use of limited screen space, particularly for small screens. Personally, I feel that the library display is kinda cramped and awkward to navigate in most skins currently. This may obviate the desire for the ability to detach the library display from the main window (I cannot remember where I saw that proposed).

Daniel Schürmann (daschuer) wrote :

Thank you for your good ideas. The library layout is defiantly a candidate for improvements.
We have already some nice mokups here Bug #986704.
You are welcome to add your own or improve or comment an existing one.

Be (be.ing) wrote :

Thanks, I'll read through that thread when I have more time.

I plan on starting to learn C++ & Qt soon so I can contribute code to Mixxx and Amarok.

Daniel Schürmann (daschuer) wrote :

Thank you. Any help is welcome. A good starting point is http://www.mixxx.org/wiki/doku.php/bugfix_workflow

Be (be.ing) wrote :

I thought of a simpler way to implement something like this that would not require a total revamp of the library GUI. There could be a way to specify a hierarchy of sorting the library columns. The simplest (and I presume easiest to implement) and least flexible way would be to sort left-to-right. For example, if I put the columns, from left to right, Artist, Album, disc # (see Bug 1411120), Track #, Title, then Mixxx would first sort by artist, then within each artist, sort by album, then within each album, sort by disc #, then within each disc #, sort by track #. Alternatively, there could be a little editor window to specify the sort priority of columns so they could be sorted and displayed in any arbitrary order.

Daniel Schürmann (daschuer) wrote :

Hi Be, thank you for the report. This request is tracked in Bug #753287

naught101 (naught101) wrote :

See also: https://bugs.launchpad.net/mixxx/+bug/671632

Personally, I think hierarchical crates is more useful, because there's a whole lot of metadata that you can manage with crates, that you don't really want to have in the file itself. But there's no reason they wouldn't work together.

Be (be.ing) on 2015-11-20
Changed in mixxx:
status: Confirmed → Invalid
status: Invalid → Confirmed
Be (be.ing) wrote :
Changed in mixxx:
status: Confirmed → In Progress
Be (be.ing) on 2017-12-28
Changed in mixxx:
milestone: none → 2.2.0
Be (be.ing) on 2018-06-24
Changed in mixxx:
assignee: nobody → Joan (jmigual)
Be (be.ing) on 2018-07-02
Changed in mixxx:
milestone: 2.2.0 → 2.3.0
Be (be.ing) on 2019-09-14
Changed in mixxx:
milestone: 2.3.0 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers