Bundle LAME mp3 plugin required for Recording and Streaming

Bug #1294128 reported by jus
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
RJ Skerry-Ryan

Bug Description

"How to obtain and install the mp3 codec, because Recording and Streaming mp3 wont work?"
This is one of the most common support request.

We would do many users and ourselves a favor, if we finally make the whole process user friendly. The current way of downloading from unreliable 3rd-party sites, renaming files and copying to the correct location is error prone, and should be a thing of the past.

I understand that we can not distribute lame binaries, be we can sideload, like in other apps.

Proposal:
If user tries to activate mp3 streaming/recording, do not only display a popup with links too wiki/manual, but allow to download and install the correct codec to the expected location by the click of a single button.

RJ Skerry-Ryan (rryan)
Changed in mixxx:
importance: Undecided → Wishlist
status: New → Confirmed
Owen Williams (ywwg)
Changed in mixxx:
milestone: none → 2.1
milestone: 2.1 → none
Revision history for this message
jus (jus) wrote :

Now that Fraunhofer IIS terminated the MP3 patent-licensing program [1], we can seek to have the mp3 codec legally bundled by default. Fraunhofer recommend [2] to get in touch [3] for official query.

[1] https://www.iis.fraunhofer.de/en/ff/amm/prod/audiocodec/audiocodecs/mp3.html
[2] http://www.audioblog.iis.fraunhofer.com/mp3-software-patents-licenses/
[3] https://www.iis.fraunhofer.de/en/ff/amm/prod/audiocodec/audiocodecs/mp3.html#tabpanel-2

Revision history for this message
Daniel Schürmann (daschuer) wrote :

This is how fedora deals with it.
https://fedoramagazine.org/full-mp3-support-coming-soon-to-fedora/

I think we can now just bundle LAME, without a risk to being sued.

I thing we should continue to go with lame, because it is still "maintained" and known to work well.

Revision history for this message
jus (jus) wrote :

Nice, changed subject accordingly.

summary: - Automatically download and install the LAME mp3 plugin required for
- Recording and Streaming
+ Bundle LAME mp3 plugin required for Recording and Streaming
Revision history for this message
RJ Skerry-Ryan (rryan) wrote :
Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
status: Confirmed → In Progress
milestone: none → 2.2.0
Revision history for this message
RJ Skerry-Ryan (rryan) wrote :
Changed in mixxx:
milestone: 2.2.0 → 2.3.0
Revision history for this message
RJ Skerry-Ryan (rryan) wrote :
RJ Skerry-Ryan (rryan)
Changed in mixxx:
status: In Progress → Fix Committed
Revision history for this message
RJ Skerry-Ryan (rryan) wrote :
RJ Skerry-Ryan (rryan)
tags: added: broadcast
removed: shoutcast
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.