Allow persistent Control Objects

Bug #1190797 reported by Justin Loser on 2013-06-14
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
RJ Skerry-Ryan

Bug Description

Wishlist item: When making edit to items such as EQ, Gain, headphone volume etc, Mixxx currently reverts back to default values when exited and reopened. It would be nice to have the last setting be saved so that re-EQing etc would not be necessary.

And to take it one step further, to have a "Set current config as default" might be an appreciated addition.

Changed in mixxx:
status: New → Confirmed
importance: Undecided → Wishlist
summary: - WISHLIST: Return to last setting
+ Allow persistent Control Objects
Changed in mixxx:
milestone: none → 1.12.0
Daniel Schürmann (daschuer) wrote :

Thank you for the bug report.
Yes, we should do this for 1.12!

I can see the bug reports now :)

Report: "Mixxx doesn't make sound anymore"
Cause: "You turned the master volume all the way down and every time you
restart it resets to all the way down."

On Fri, Jun 14, 2013 at 1:27 AM, Daniel Schürmann <
<email address hidden>> wrote:

> Thank you for the bug report.
> Yes, we should do this for 1.12!
>
> ** Changed in: mixxx
> Status: New => Confirmed
>
> ** Changed in: mixxx
> Importance: Undecided => Wishlist
>
> ** Summary changed:
>
> - WISHLIST: Return to last setting
> + Allow persistent Control Objects
>
> ** Changed in: mixxx
> Milestone: None => 1.12.0
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/1190797
>
> Title:
> Allow persistent Control Objects
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/1190797/+subscriptions
>

Owen Williams (ywwg) wrote :

Yeah I don't like this, it seems ripe for confusion and not really that useful. (How often do you want to preserve eq settings across launches?)

Daniel Schürmann (daschuer) wrote :

For me this is a natural feature for our new control object api.

For me it is anoying to setup sings like "Head mixxx" or "Volume" everytime I restart Mixxx. So it depends on the type of contol if it schould be persistant or not.
But of cause we can add an option for disable persistant control objects.

By the way: All DJ controller yuser have aleady this feature because. No on Zeros all their knops if mixxx is restarted ;-).

RJ Skerry-Ryan (rryan) on 2014-01-19
Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) wrote :

Merged

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2015-12-30
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions