Ignore preview cloumn when exporting cvs file

Bug #1181172 reported by Daniel Schürmann on 2013-05-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
Nicu Badescu

Bug Description

The preview column dos not contain significant info.

tags: added: easy
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
Nicu Badescu (badescunicu) wrote :

Hi! I want to tackle this bug as my first contribution for mixxx. How can I reproduce it? I can't seem to find any export to cvs menu, or button.

Thanks!

Daniel Schürmann (daschuer) wrote :

Hi Nicu,

thank you for offering contributions to Mixxx.

You can reproduce the bug, by right click a playlist and select "Export playlist". Save the playlist with .csv suffix.

Btw.: Did you read http://www.mixxx.org/wiki/doku.php/bugfix_workflow?

Kind regards,

Daniel

Nicu Badescu (badescunicu) wrote :

Yes, I've read the bugfix workflow.

However, what seems to be the problem here? I managed to export a playlist as a csv file and also to import it. Do you want to remove the preview column for imported csv playlists?

Thanks,
Nicu

Daniel Schürmann (daschuer) wrote :

The preview column should not be part of the exported cvs. It puts only unwanted noise to the file. That the issue.

Nicu Badescu (badescunicu) wrote :

Thank you, I'll see what I can do.

Changed in mixxx:
assignee: nobody → Nicu Badescu (badescunicu)
Nicu Badescu (badescunicu) wrote :

I've sent a pull request on Github and I am waiting for your feedback. :-)

jus (jus) on 2013-10-05
Changed in mixxx:
milestone: none → 1.12.0
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :
Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2015-12-30
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers