mouse pointer vanished turning a knob

Bug #1130794 reported by slartibarfast
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Mixxx
Fix Released
High
Daniel Schürmann

Bug Description

Win 7
Intel Atom N2600 1.6 ghz duo
Intel GMA 3650
Realtek (!) sound... :(

Tags: gui macos windows
RJ Skerry-Ryan (rryan)
Changed in mixxx:
importance: Undecided → High
Revision history for this message
jus (jus) wrote :

This happened with the latest Mixxx "2.0.0-rc1" git 1.12 r5669
OSX 10.10.5

I use the trackpad to turn knobs, once in a while the mouse pointer disappears. Have to restart the app to bring the pointer back.
We did introduce some code to hide the mouse on knob movement, may need a check.

Changed in mixxx:
status: New → Confirmed
Revision history for this message
eapo (eaposztrof) wrote :

Same situation here:
Using touchscreen will hide the mouse pointer well, but sometimes* will not reappear at mouse move and stays hidden over the canvas, but hovering effects are showing the position.
* i am not able to reproduce, but happening time to time.

Running [i]Debian 9.9[/i] with [i]Mixxx "2.0.0" "(git 1.12 r5772[/i] on [i]ThinkPad T450s[/i] with [i]Touchscreen[/i].

Revision history for this message
Garry H (garryhy) wrote :

My experience is a bit different.

I'm on a Macbook Pro with OS 10.13.6 (High Sierra) using a trackpad, and Mixxx Build 2.2-r6690.

I find the pointer frequently disappears on launching the app (as it did with an earlier build too). In fact it disappears and locks out the pointer for all apps until I Command-Q quit Mixxx. It rarely takes more than 3 attempts to get the app and pointer working as expected.

I've noted this in the log file, wondering if this gives a clue to the problem? I don't know what libdispatch actually does.

Jun 13 16:56:14 Garrys-MBP Mixxx[947]: BUG in libdispatch client: kevent[mach_recv] monitored resource vanished before the source cancel handler was invoked
Jun 13 16:56:19 Garrys-MBP kcm[950]: DEPRECATED USE in libdispatch client: Setting timer interval to 0 requests a 1ns timer, did you mean FOREVER (a one-shot timer)?

tags: added: gui
removed: interface
Revision history for this message
Jasper Rebane (rebane2001) wrote :

I've been able to consistently reproduce this issue in Mixxx 2.3.0 on a M1 MacBook Air running MacOS 11.5.1.
It seems like the issue is caused by turning the knobs in Mixxx while your computer is also under load. This lags Mixxx and causes it to not show the cursor even after letting go of a knob. Clicking knobs again doesn't seem to fix the issue, only restarting the application does.

Steps to reproduce:
1. Be under high load (I was rendering a video in the background for an example).
2. Play a track in Mixxx.
3. Mess with the knobs until the cursor disappears.

I have also recorded a quick video demonstrating the issue in case it helps: https://www.youtube.com/watch?v=v8XbCjXFo08
Note that when I shake the cursor in the video, MacOS shows it anyways, this is unrelated to this issue and Mixxx in general, so just ignore that.

I would suggest adding a setting to disable hiding the cursor altogether as a temporary solution.

Revision history for this message
ronso0 (ronso0) wrote :

@rebane2001
Please make sure this is not related to one of your input devices accidentally being activated as HID controller. Go to Preferences > Controllers and check if any of your touch pad / mouse is listed there (in the tree view). Bold label indicates the devices is enabled. In that case click on the item and uncheck 'Enabled' in the controller overview page.

Revision history for this message
Jasper Rebane (rebane2001) wrote :

@ronso0
Thanks for the suggestion, but it seems like all of my controllers are set as disabled.

Revision history for this message
Be (be.ing) wrote :

From the video it looks like this is triggered by moving the knobs with the mouse. Can you confirm that? Does it also occur moving the faders with the mouse? Do any other widgets do this?

Revision history for this message
Jasper Rebane (rebane2001) wrote :

Yes, however it happens very rarely when there is no lag. The cursor always disappears when I move the knobs, but it reappears when I let go. When there is lag, it sometimes doesn't reappear after letting go and stays invisible.

Revision history for this message
Be (be.ing) wrote :

Interesting... does the cursor eventually come back if you wait a long time?

Revision history for this message
Jasper Rebane (rebane2001) wrote :

It does not reappear after waiting for a couple minutes, I haven't tested for longer than that. Clicking on the knobs again, minimizing, alt+tabbing etc does not make the cursor reappear, only a restart of Mixxx does.

Revision history for this message
Diego C (garethsl) wrote :

I have the same problem with Mixxx 2.3.1 but using a logitech wireless mouse

tags: added: windows
tags: added: macos
summary: - mouse pointer vanished
+ mouse pointer vanished turning a knob
Revision history for this message
Gesualdo (gesualdo777) wrote :

Hello, I have the same problem. The pointer disappears when I turn the nobs by touchpad. What’s more, sometimes I can’t turn mixer eq nobs by pressing touchpad and moving left/righ. I can only do it by moving coursor to the nob and – without pressing – scrolling up/down. There is no rule, once I can do it and once I can’t.

Can enybody tell me, if this issue could be reproduce in other way than turnig the eq nobs? In other words, if I won't touch those nobs, Mixxx will be stable? I am DJ-ing soon and I have to be sure, that the coursor won’t disappear.

My computer: Macbook Pro Retina Mid 2015, MacOS 10.14.6. Mixx ver. 2.3.1

Revision history for this message
Foss-4 (foss-4) wrote :

Another data point: Unable to reproduce
Mixxx: 2.4-alpha-1073-gf1c7217570 (main)
macOS 11.6.2

Turning EQ knobs or effect knob with trackpad does not result in vanishing mouse pointer. Or is the bug that the mouse pointer vanishes for the time the knob is turned? For me it returns as soon as I let go.

@Gesualdo: how is the nightly build behaving for you? https://mixxx.org/download/ under developer snapshots.

Revision history for this message
ronso0 (ronso0) wrote :

Nightly builds are alpha or beta builds, so anyone testing those should better have a backup of the Mixxx settings and database, see https://github.com/mixxxdj/mixxx/wiki/Testing

Revision history for this message
Gesualdo (gesualdo777) wrote :

@Foss-4
I tryed this version: mixxx-2.4-alpha-1091-g75af4e2b3a-macosintel.dmg (from 23.01.22) and the problem is the same. Jasper Rebane in post from 03.09.22 described the issue. It is very quickly reproducebile, while the computer is under the load. I started render film and opened video on Internet browser and after 2 seconds I could reproduce the issue in Mixxx.

Revision history for this message
Nicholas Niendorf (niendorf21) wrote :

FYI this is still happening for me as well.

Revision history for this message
nPrevail (nprevail) wrote :

Perhaps these two issues are related? Seems to be more common in Macs(?)

https://bugs.launchpad.net/mixxx/+bug/1969278

Revision history for this message
Daniel Schürmann (daschuer) wrote :
Changed in mixxx:
milestone: none → 2.3.3
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers