woverview current position marker is inacurate

Bug #1087437 reported by Daniel Schürmann on 2012-12-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann

Bug Description

It starts and ends about 3 pixel within the overview widget.
Due to the visual sample rate optimization the summary waveform is sometimes some pixel smaller than the overview window window.
This effect is most noticeable when loading a short track.

Daniel Schürmann (daschuer) wrote :

Depends on Bug #1084551

Daniel Schürmann (daschuer) wrote :

Parts of this issue are now fixed by the patches of Bug #1084551 and Bug #1086965.

There is still an issue with the cursor position.
It looks like a rounding error.

The waveform overview position is scaled from 14 to 114 (Can one explain why?)

If you move the slider to the track end it jumps back to some pixel before. This is because Mixxx does not report 114 at track end.
In my case it was 113,2.

The time display suffer the same issue. It is not possible to move to 0:00 remaining time.
It is an aspect of Bug #780021

jus (jus) on 2012-12-21
tags: added: waveform
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
Daniel Schürmann (daschuer) wrote :

This was introduced in #1545 to tweaks MIDI centering behaviour and is a part if this issue.
14 should become 0 and 114 should become 1.0000
But 114 evaluates to 1.0079
And in reverse direction 1.0000 evaluates to 113,21

So we need to add add another scaling area to hit 114 at 1.000

Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
milestone: none → 1.11.0
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

with the attached patch it works like a charm :-)

RJ Skerry-Ryan (rryan) wrote :

yea, it's odd but 14 is 0 and 114 is 1. We added this when we added the track lead-in area.

RJ Skerry-Ryan (rryan) wrote :

I've always thought it's pretty silly that the widget values in getValueToWidget / getValueFromWidget for all the control object variants scale the value between the 7-bit MIDI range. This has been around since the early days of the control system. For Mixxx 1.12 we should look at scaling all the widget values for potmeters between 0.0 and 1.0.

RJ Skerry-Ryan (rryan) wrote :

I would love to just change getValueToWidget/getValueFromWidget in ControlPotmeter but I think some of the widgets (e.g. WKnob) rely on it for centering and as you said I believe MIDI does rely on this for making value 64 the true center point.

The patch looks good as a band-aid for 1.11. I think in the future all of this code needs a re-work though. Maybe with the next version of hte control system :).

Daniel Schürmann (daschuer) wrote :

Committed to lp:mixxx/1.11 revision 3646.

Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers