Loop Is Going Out Of Sync

Bug #1025007 reported by Paolo Zeta on 2012-07-15
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mixxx
High
RJ Skerry-Ryan
1.10
High
RJ Skerry-Ryan
1.11
High
RJ Skerry-Ryan
2.0
High
RJ Skerry-Ryan

Bug Description

If a loop 4 beats and sync it with the song playing in the other deck, the first one goes rapidly out of sync.
This happens also if the same song is playing in both decks. Everything work fine if instead of 4 beats I loop 8 or more Beats.

I'm using this mixxx version: "mixxx-1.11.0-beta2-pre-release-1.11.x-bzr3314-x86"

My system is an Intel Core i5 3 Ghz with internal GPU, Hercules MK4.

This is the link to a video that shows the problem: http://dl.dropbox.com/u/1467875/MixxxBug1.mp4

No audio, but the problem is clearly seen graphically,

Owen Williams (ywwg) wrote :

Try reducing your latency. I've noticed that loops fall out of sync when the latency is above ~20ms.

(This is still a bug, but I'd like to figure out if it's the same one I think it is)

Max Linke (max-linke) wrote :

What kind of audio files did you use and on which Operating System do you use.

I can't reproduce the error with a VBR or CBR MP3 file.

Paolo Zeta (paolo-075) wrote :

I used an mp3 file with windows x86 version of the program.

I've tried with the same results also on a laptop equipped with T8400 2,4 Ghz and a Nvidia GPU.
When I recorded the video my latency was 11,6 at 44.100 Hz, using Windows WASAPI driver. The same I've ever used on Mixx.

I've Tried to decrease latency to 5.8 ms as suggested by Owen and with this setting the problem is gone.

Paolo Zeta (paolo-075) wrote :

Update on the bug:

With the latest beta [mixxx-1.11.0-beta2-pre-release-1.11.x-bzr3345-x86.exe] the track goes out of sync also if I set the smallest latency of "1.45 ms". No way to stay in sync.
Tested with both asio and wasapi driver on Windows 7.

RJ Skerry-Ryan (rryan) on 2012-09-04
Changed in mixxx:
milestone: none → 1.11.0
importance: Undecided → High
vininim (vininim) wrote :

I can't reproduce this on Linux(Ubuntu 12.10) using Alsa ouput with 21.3 ms latency (and pulse-alsa plugin). Not even visually with the LateNight skin.

RJ Skerry-Ryan (rryan) wrote :

Can't reproduce either. Can you confirm that these steps reproduce the problem:

1) Load same track on deck 1 and 2.
2) HIt 'D' and 'L' at the same time to start both at the same time.
3) Hit 'Q' and 'U' to start a 4-beat loop on both decks.

RJ Skerry-Ryan (rryan) wrote :

(I've tried at every latency)

RJ Skerry-Ryan (rryan) wrote :

Sorry, should have watched your video first.

Using the exact steps:

1) Load track in deck 1 and 2.
2) Set hotcue on a beat.
3) Seek deck 1 and 2 to the same hotcue (both stopped)
4) Set a 4-beat loop on 1 and 8-beat on 2.
5) Simultaneously hit 'D' and 'L' to start them.

I can run this for hours at any latency and not reproduce the problem. Maybe we have fixed this without noticing it? Could you try a more recent build of 1.11 to confirm it's still a problem?

Changed in mixxx:
status: New → Incomplete
assignee: nobody → RJ Ryan (rryan)

Tonight I'll test the latest version and I'll post the result, thanks.

Paolo Zeta (paolo-075) wrote :

Hi, sorry for having replied so late.

I've just tested this mixxx version :

mixxx-1.11.0-pre-bzr3710-x86.exe

On Windows 7 x86, Core 2 duo laptop using Hercules MK4.

The decks are out of sync!! Sadly I still have the problem.

Paolo.

tags: added: looping
removed: loop
enry (enrydj) wrote :

The problem affect me, too (build r3818, Ubuntu 12.04). It's like loop length were not exact.

ernest (mbuleloe) wrote :

on ubuntu 12.04 mixxx 1.11.0 beta2 this problem affect me in this manner:

1. load same track on deck 1 and 2
2. turn the quantize feature On on deck 1 only
3. play both tracks and sync them
4. loop deck 1 to 4 beat

RJ Skerry-Ryan (rryan) wrote :

Just FYI, I still can't reproduce this issue with any of the provided reproduction steps. Can you provide more details on how to reproduce? I can run 2 loops for hours at any latency and they stay in sync.

RJ Skerry-Ryan (rryan) wrote :

Ernest -- did you mean keylock instead of quantize? I can reproduce this with keylock on on only one deck!

Changed in mixxx:
status: Incomplete → In Progress
RJ Skerry-Ryan (rryan) wrote :

Well, I spent my weekend digging in to this problem and I think I've found the root cause! An optimization in our scaling code was dropping samples. It only affects certain combinations of tracks / loops / samplerates / latencies so that explains why it was hard to reproduce.

RJ Skerry-Ryan (rryan) wrote :

A fix is now in trunk. lp:mixxx r3424.

Changed in mixxx:
milestone: 1.11.0 → none
status: In Progress → Fix Committed
Paolo Zeta (paolo-075) wrote :

Thanks Ryan, Happy to hear that!

2013/6/10 RJ Ryan <email address hidden>:
> A fix is now in trunk. lp:mixxx r3424.
>
> ** Changed in: mixxx
> Milestone: 1.11.0 => None
>
> ** Changed in: mixxx
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1025007
>
> Title:
> Loop Is Going Out Of Sync
>
> Status in Mixxx:
> Fix Committed
> Status in Mixxx 1.10 series:
> Won't Fix
> Status in Mixxx 1.11 series:
> In Progress
> Status in Mixxx 1.12 series:
> Fix Committed
>
> Bug description:
> If a loop 4 beats and sync it with the song playing in the other deck, the first one goes rapidly out of sync.
> This happens also if the same song is playing in both decks. Everything work fine if instead of 4 beats I loop 8 or more Beats.
>
> I'm using this mixxx version: "mixxx-1.11.0-beta2-pre-
> release-1.11.x-bzr3314-x86"
>
> My system is an Intel Core i5 3 Ghz with internal GPU, Hercules MK4.
>
> This is the link to a video that shows the problem:
> http://dl.dropbox.com/u/1467875/MixxxBug1.mp4
>
> No audio, but the problem is clearly seen graphically,
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/1025007/+subscriptions

RJ Skerry-Ryan (rryan) on 2015-12-30
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers