Table is not sorted when analyse-view is selected

Bug #1024769 reported by Max Linke on 2012-07-14
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann
1.11
Low
Daniel Schürmann

Bug Description

When analyse is selected the table should be ordered by artist (default) but it's not and you have to click on the artist column header to activate it

jus (jus) on 2012-08-01
Changed in mixxx:
importance: Undecided → Low
status: New → Confirmed
Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
Daniel Schürmann (daschuer) wrote :

The attached patch solves the problem against lp:mixxx/1.11 #3542

Changed in mixxx:
status: Confirmed → In Progress

This looks like it disables sorting in the analyze view. Is think that's a
bit too drastic since the "All" and "New" selector is just selecting what
tracks are shown and doesn't seem like it needs to restrict their order.

On Tue, Dec 4, 2012 at 3:47 PM, Daniel Schürmann <<email address hidden>
> wrote:

> ** Changed in: mixxx/1.11
> Milestone: None => 1.11.0
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/1024769
>
> Title:
> Table is not sorted when analyse-view is selected
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/1024769/+subscriptions
>

Daniel Schürmann (daschuer) wrote :

Hi RJ,

sorry for the confusion. The patch also includes removing a double select() from dlgrecording.
This was always not sortable.

RJ Skerry-Ryan (rryan) wrote :

Ah I missed that. Also, doesn't setting the search to RECENT_FILTER ignore
the All vs. Recent setting?

On Wed, Dec 5, 2012 at 1:36 PM, Daniel Schürmann <<email address hidden>
> wrote:

> Hi RJ,
>
> sorry for the confusion. The patch also includes removing a double
> select() from dlgrecording.
> This was always not sortable.
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/1024769
>
> Title:
> Table is not sorted when analyse-view is selected
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/1024769/+subscriptions
>

Daniel Schürmann (daschuer) wrote :

Committed to lp:mixxx/1.11 revision 3584.

The "All vs. Recent" setting is not stored in preferences. Recent is always selected after restart Mixxx.

Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers