No way to stop Auto DJ from removing songs.

Reported by Matt White on 2012-07-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Daniel Schürmann

Bug Description

I just discovered Mixxx the other day and this program is hands-down the best DJ program I've ever used.
My only problem is the Auto DJ removes songs after playing them and you don't have the choice of telling it not to.
I do live streaming via Icecast2 and formerly through Shoutcast, so being able to have an Auto DJ continue to play music (and perhaps even judge which song to play next from it's play count) would make this product perfect in my opinion.
Please fix this so we have the ability to modify the Auto DJ and tell it to refrain from removing songs?

Changed in mixxx:
status: New → Confirmed
importance: Undecided → Wishlist
Daniel Schürmann (daschuer) wrote :

Hi Matt,

which version of Mixxx do you using?

I am not sure if I understand your use case right. Why do you need this feature?

Currently the Auto DJ Queue is not a play list, it is a more like a queue whit the topmost song on top.
I know other media player which have a feature to step through a specific play list.
This is currently not possible with Mixxx.
But you can load an entire play list to Auto DJ.
And from Version 1.11 all played songs are stored in a History play list, for later reference.

Matt White (djzemar) wrote :

I'm using Version 1.10.1 and sorry, I didn't mean playlist. I mean the queue will remove songs from the queue after being played.
I would like to see an option to turn off song-removal so the queue can play 24/7. I stream to an internet radio so I need to stream 24/7, so the reason I need this feature is so I can stream without the queue emptying itself.

Daniel Schürmann (daschuer) wrote :

Ah, Thank you.

Ok, Auto DJ may queue up played tracks again. Does this fit to your problem? Or do you have any other suggestions?

I have already thought to a feature where you can define, what will happens after Auto DJ queue is running out of tracks.
Options:
* Stop (Disable Auto DJ) (current behaviour)
* Add random tracks from specific crate(s)
* Add a specific play list (Endless Loop, Your use case? )

Matt White (djzemar) wrote :

That sounds perfect actually.
Also perhaps have "Repeat Queue" in case the music isn't from a specific playlist.
But those options would do great, it would make Mixxx the best option for 24/7 internet streaming, I really hope to see this implemented!

Matt White (djzemar) wrote :

Quick question, will I be notified if this is bumped up to blueprint?
If not, could you send an alert if it does?

Daniel Schürmann (daschuer) wrote :

If you have enabled bug notification, you will be informed!

Scott Stewart (smstewart91) wrote :

Here is a quick patch that will allow you to have AutoDJ loop through the playlist. I added a ReQueue checkbox in AutoDJ to turn this option on, and then AutoDJ will simply add a song to the end of the playlist once it is played, instead of removing it.

Matt White (djzemar) wrote :

You're a miracle worker, thanks!
It may take me a bit to figure how to compile, but I'm really stoked about it!

Scott Stewart (smstewart91) wrote :

If you go to http://www.mixxx.org/wiki/doku.php/start#build_mixxx there is instructions for compiling, and googling "bzr patch" should help getting the patch inserted

Matt White (djzemar) wrote :

I've been working on this all night but I can't get Bazaar to checkout anything.
If anyone could compile this for Windows 7, either 32 or 64 bit, I'd be extremely grateful!
I'm still attempting to patch it though because I really need it lol

Daniel Schürmann (daschuer) wrote :

I have tested the patch and it works fine. Thank you Scott.
I have committed it to lp:~daschuer/mixxx/daschuers_trunk.
Scott, can you make the ReQueue flag persistent?
I would prefer not having camel notation in GUI Strings.

Matt, You may find builds on http://builds.mixxx.org/builds/experimental-daschuers_trunk/
(if its back online)

Please Note: These experimental builds are only for testing propose. They are based on 1.11.0-alpha with an updated database schema. So its a good Idea to backup your "Local Settings\Application Data\Mixxx" folder first.

Changed in mixxx:
status: Confirmed → In Progress
assignee: nobody → Scott Stewart (smstewart91)
Scott Stewart (smstewart91) wrote :

Here is a patch that includes a persistent Requeue flag. I also changed the ConfigKey to "[Auto DJ]", "Requeue" (instead of ReQueue). Is this what you meant by not having camel notation in GUI strings?

Matt White (djzemar) wrote :

It seems the trunk is offline, but I'll keep trying and see if I can get to it.
And sounds good, I'll back up my appdata for it and treat it like an alpha program.

Matt White (djzemar) wrote :

Never mind, I just realized now that the SVN is online, the trunk is accessible via HTTP. Successfully downloaded 1.11.0-beta1 and the new features seem to be working nicely. I love the Fade Now button as well. The only problem is the Auto DJ Re-queue doesn't seem to be working. I tested for the auto re-queue with normal playing as well as the Fade Now feature.

Matt White (djzemar) wrote :

So far I've tested multiple releases of Mixxx both on dascheur's trunk as well as the main 1.11.0 trunk and none of the AutoDJ Recue functions work, at least not for any of the Windows binaries. Let me know if anything gets changed or updated, thanks!

Matt White (djzemar) wrote :

Alright, I just tested it on Windows 7 64-bit (both the x86 and x64 binaries) and neither worked with the Auto Recue. I also noticed that it seems the label for the item is overlaying another label underneath it for the "CDJ Mode; Simple" dropdown menu. Let me know if you have any more builds to test and I'll try to test them and tell you the result a little sooner.. I also appreciate all the work you've been doing, this will really be a ground-breaking feature for 24/7 internet radio streamers!

RJ Ryan (rryan) on 2012-09-28
Changed in mixxx:
milestone: none → 1.11.0
RJ Ryan (rryan) on 2012-11-21
Changed in mixxx:
milestone: 1.11.0 → 1.11.1
Changed in mixxx:
assignee: Scott Stewart (smstewart91) → Daniel Schürmann (daschuer)
milestone: 1.11.1 → 1.11.0
Daniel Schürmann (daschuer) wrote :

I will commit a patch which introduces the config:

[Auto DJ]
Requeue 1

for the moment without a GUI controls.

The original patch causes issues in the in Outline 800er skin but works fine with the others.

We could move the requeue checkbox to preferences to have a clear interface for all other users.
I will provide a patch.

Daniel Schürmann (daschuer) wrote :

For me the attached patch should be part of 1.11 as well.

Max Linke (max-linke) wrote :

I would prefer a toogle button in the autoDj view for this. If I didn't knew mixxx I would only discover this feature by chance looking through the options. The rest looks good to me

Daniel Schürmann (daschuer) wrote :

Hi Max,

thank you for reviewing. I fully agree with you to have this feature in the Auto DJ View.
But for a short term version we simple haven't enough space for all skins and all translations.

So my quick fix is intended to allow radio DJs to use Mixxx at all, without annoy party DJs with a n overloaded GUI.

The final solution should be part of https://blueprints.launchpad.net/mixxx/+spec/three-column-library-layout.

Matt White (djzemar) wrote :

Just tried the r3678 build and it doesn't seem to be working yet.. I'll keep my eyes out for any changes.
Also, I love Max's input on the subject. I can't wait to see the full release for 1.11, it's gonna be great!

Daniel Schürmann (daschuer) wrote :

It is for now a hidden feature.
You can use it by adding

[Auto DJ]
Requeue 1

to your mixxx.cfg file.

Or you could try my trunk with this option in preferences GUI.
http://builds.mixxx.org/builds/experimental-daschuers_trunk/

Matt White (djzemar) wrote :

Ah okay! It's working great, thanks so much!
I just tested the fade now, manual track changes, etc.. It's all flawless. Brilliant work, guys!

jus (jus) wrote :

+1 for adding the "Auto DJ Requeue" to the interface preferences as a temp solution.
While it might be not the most elegant solution, it makes the feature accessible without fiddling with *.cfg files. Moreover we don't have to to do any additional work on the skins.

tags: removed: auto dj options remove setting song
Daniel Schürmann (daschuer) wrote :

Committed patch from #20 to lp:mixxx/1.11 revision 3683

Changed in mixxx:
status: In Progress → Fix Committed
Matt White (djzemar) wrote :

Just a quick update.. The "Re-queue tracks in Auto DJ" feature in the preferences works great!
I did want to note, though it's of low-importance, you may wish to remove the "Auto Recall Cue" preference since it was just replaced by "Re-queue tracks in Auto DJ."

It doesn't cause any problems, but for aesthetic purposes, you might wish to remove it before the official release of 1.11.0.

However, everything is working extremely great! I've been running the Auto DJ, streaming to my icecast radio 24/7 and have had virtually no problems. Brilliant work, guys!

Daniel Schürmann (daschuer) wrote :

Thank you for testing and your praise :-)

I do not understand your note about "Auto Recall Cue".
This setting controls, if a track is loaded at Cue point or at start position.
It should still work fine, and should not be removed.

Matt White (djzemar) wrote :

Oops, my bad then.. I saw it added turning the production of this feature and must have mistaken it for a re-queue feature.

And absolutely, the re-queue feature has saved me hours of stress and effort.. (And a few gigabytes of ram freed up, lol)

RJ Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers