save track after analysis

Bug #1000866 reported by RJ Skerry-Ryan on 2012-05-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann

Bug Description

Right now after a track is analyzed it isn't saved immediately. Since it's in the track cache it won't be saved until either 5 more tracks are loaded or until Mixxx shutdown. If Mixxx crashes then we lose the analysis.

Previously we didn't manually save due to perf. reasons (preventing too much stuff going on at track load). I think that since the analyser queue adds a significant delay, saving the track when it's finished is not a big deal and we should do it.

RJ Skerry-Ryan (rryan) on 2012-05-17
Changed in mixxx:
importance: Undecided → Low
status: New → Confirmed
milestone: none → 1.11.0
RJ Skerry-Ryan (rryan) on 2012-11-21
Changed in mixxx:
milestone: 1.11.0 → 1.11.1
Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

The attached patch does what is requested.

If someone can review it in time we may commit it to 1.11.0.

Owen Williams (ywwg) wrote :

Sorry to post a nitpick instead of a proper code review, but please be consistent about using "type_t* object" and not "type_t *object" -- even if it was done that way in the code you're editing.

Daniel Schürmann (daschuer) wrote :

Attached you find a beautified patch.

Changed in mixxx:
milestone: 1.11.1 → 1.11.0
RJ Skerry-Ryan (rryan) wrote :

* analyserqueue.cpp:326 should be emit(trackDone(...)) since it's a signal.

Otherwise, looks good. Thanks for cleaning up all that cruft of the AQ being stored in the player classes.

Daniel Schürmann (daschuer) wrote :

Committed to lp:mixxx/1.11 revision 3703

Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers