Menubar always visible in fullscreen mode Mac OSX

Bug #1000187 reported by jus on 2012-05-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Daniel Schürmann

Bug Description

Mixxx 1.10 & current trunk
*if you got into fullscreen mode, the native MacOSX Menu bar is hidden. A separate menu bar ist always shown instead with only the Mixxx controls visible.

Mixxx 1.9
*if you got into fullscreen mode, the MacOSX Menu bar is hidden. if you move with the mouse on top of the screen the native OSX menu bar appears with all the system controls + the various mixxx options . If you move the mouse down again , the menu bar disappears. This is the correct behavior.

We should make sure to restore the correct behavior as the current one overrides the OS defaults and is probably a reason for rejection from the app store too.

jus (jus) wrote :
jus (jus) wrote :
Daniel Schürmann (daschuer) wrote :

This might be a regression due to Bug #885890

Daniel Schürmann (daschuer) wrote :
Changed in mixxx:
status: New → In Progress
assignee: nobody → Daniel Schürmann (daschuer)
jus (jus) wrote :

Could you please check the link from #4 - i got 404 Not Found

jus (jus) wrote :

Link from #4 gives still 404. Applied your changes from mixxx-1.11.0-alpha2-daschuer~daschuers-trunk-bzr2980 to current trunk and the issue is partly solved. Its all fine if going full screen and as long as you are in full screen. But if you come out of full screen, all menu items in the menu bar are gone. See screen shot

Changed in mixxx:
importance: Undecided → Low
milestone: none → 1.11.0
Daniel Schürmann (daschuer) wrote :

Hi Jus,
http://builds.mixxx.org/builds/experimental-daschuers_trunk/mixxx-1.11.0-alpha2-daschuer~daschuers-trunk-bzr2984-macintel32.dmg
is an other try to fix the problem.
Can you please also verify if the menu bar is fine after skin change?
Thank you,
Daniel

jus (jus) wrote :

We`re getting close.
Menu bar is now fine if going full screen and back to windowed view.

After skin change the menu items in the menu bar are gone like in #6.

jus (jus) wrote :

Thanks Daniel,
tested latest mixxx-1.11.0-alpha2-daschuer~daschuers-trunk-bzr2985-macintel32.dmg and can confirm that fullscreen works flawless again with OSX 10.5.8 & 10.6.8.
Unfortunately Mixxx does not start in my 10.7 VM due to OpenGL errors.

If someone with a native 10.7.x installation could test please....

jus (jus) wrote :

Fix confirmed working with OSX 10.7.4 too.

Daniel Schürmann (daschuer) wrote :

fix commited in l:mixxx #3201

Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers