If a surface is deleted before its decoration is painted miral-shell can crash, or hang on exit

Bug #1673038 reported by Alan Griffiths on 2017-03-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MirAL
High
Alan Griffiths

Bug Description

In testing bug 1672012 I found that I get miral-shell into a state where it hangs on exit. What I know so far:

The "decorations" internal client thread is hanging in mir_connection_release().

The Mir "main loop" is hung in a pre-shutdown hook that joins the internal client threads.

To reproduce:

    $ miral-app
    $ miral-xrun vlc

(Takes some time to start)

Right click on vlc, the menu shows for a split second and closes. Or, sometimes, miral-shell crashes.

Alt-F4 to exit vlc, Alt-F4 exit terminal

Related branches

Alan Griffiths (alan-griffiths) wrote :

This seems to be an entirely separate bug to 1672012 - although they are triggered by the equivalent scenarios.

description: updated
summary: - miral-shell can hang on exit
+ If a surface is deleted before its decoration is painted miral-shell can
+ crash, or hang on exit
Changed in miral:
status: In Progress → Fix Committed
Changed in miral:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers