Mouse cursor disappears (or just never changes) when entering the windows of Qt apps

Bug #1625853 reported by Brandon Schaefer on 2016-09-20
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Daniel van Vugt
Mir
Triaged
Medium
Unassigned
MirAL
Low
Alan Griffiths
mir (Ubuntu)
Medium
Unassigned
qtubuntu (Ubuntu)
High
Daniel van Vugt

Bug Description

To reproduce:
1) Open qtcreator in mir
2) Move mouse around window

Expect:
Able to see cursor

Result:
Cursor goes away as if disabled.

Related branches

summary: - [QT5] QtCreator the cursor disappears when entering the window
+ [Qt5] QtCreator the cursor disappears when entering the window
Alan Griffiths (alan-griffiths) wrote :

This sounds like the missing I-beam text cursor in the Mir default theme. (I can't find a bug for that right away.)

Daniel van Vugt (vanvugt) wrote :

Seems to work for me (Unity8 on yakkety). Regardless, this proves the I-beam text cursor works with this app and works with Mir.

I'm not sure where your failure might be. Unfortunately I can't figure out how to get Qt apps to run at all in Mir servers other than Unity8.

Changed in mir:
status: New → Invalid
Changed in miral:
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

Whoops, other way round. Using mirrun I can reproduce the bug in a non-MirAL shell. So this is not a MirAL bug.

I can get a cursor in qterminal running under Xmir on Mir, but not native qterminal. Xmir however uploads raw bitmap cursors so yes this does sound like some cursors are missing.

Cursors are also missing in GTK but GTK is so broken right now I would ignore that.

Changed in mir:
status: Invalid → Confirmed
Changed in miral:
status: Incomplete → Invalid
Daniel van Vugt (vanvugt) wrote :

The GTK issue is bug 1607681

Changed in qtubuntu (Ubuntu):
status: New → Confirmed
affects: mir → qtubuntu
Changed in qtubuntu:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in qtubuntu (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in qtubuntu:
status: Confirmed → In Progress
Changed in qtubuntu (Ubuntu):
status: Confirmed → In Progress
summary: - [Qt5] QtCreator the cursor disappears when entering the window
+ Mouse cursor disappears when entering the windows of Qt apps
Changed in qtubuntu:
importance: Undecided → High
Changed in qtubuntu (Ubuntu):
importance: Undecided → High
tags: added: cursor
summary: - Mouse cursor disappears when entering the windows of Qt apps
+ Mouse cursor disappears (or just never changes) when entering the
+ windows of Qt apps
Changed in canonical-devices-system-image:
status: New → In Progress
Changed in qtubuntu:
importance: High → Medium
importance: Medium → High
Changed in canonical-devices-system-image:
importance: Undecided → Medium
assignee: nobody → Daniel van Vugt (vanvugt)
milestone: none → 14
Daniel van Vugt (vanvugt) wrote :

The bug actually exists in Unity8 too. But Unity8 defaults to just keeping the existing cursor unchanged instead of blanking it. Same bug, fixed by the above branch.

Gerry Boland (gerboland) wrote :

Why is there not a better fallback cursor than a fully blank one?

Daniel van Vugt (vanvugt) wrote :

Excellent question. Mir even has a "default" cursor that should be used in such a case.

Changed in miral:
status: Invalid → In Progress
importance: Undecided → Low
assignee: nobody → Alan Griffiths (alan-griffiths)
Changed in miral:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Also affects Mir. Because we can and should be choosing the "default" cursor if an unknown cursor name is given. Not the blank or "disabled" cursor.

Changed in mir:
importance: Undecided → Medium
status: New → Triaged
Changed in miral:
milestone: none → 0.2
Changed in miral:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtubuntu - 0.63+17.04.20161024-0ubuntu1

---------------
qtubuntu (0.63+17.04.20161024-0ubuntu1) zesty; urgency=medium

  [ Daniel d'Andrada ]
  * Some logging fixes

  [ Daniel van Vugt ]
  * Implement named cursors that Mir understands (LP: #1625853) (LP:
    #1625853)

  [ Gerry Boland ]
  * Stricter enum use, avoid default switch case
  * Use mir-client-debug to map window coordinates to screen coordinates
    (LP: #1346633)
  * Fix rendering of apps using QQuickWidget

 -- Michael Zanetti <email address hidden> Mon, 24 Oct 2016 11:33:40 +0000

Changed in qtubuntu (Ubuntu):
status: In Progress → Fix Released
Daniel van Vugt (vanvugt) wrote :

Strange. Where did it land; just distro? QtUbuntu trunk hasn't got it yet:
   https://code.launchpad.net/~phablet-team/qtubuntu/trunk
and the branch itself hasn't landed yet:
   https://code.launchpad.net/~vanvugt/qtubuntu/fix-cursor/+merge/306597

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2017-03-13
no longer affects: qtubuntu
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:miral at revision 559, scheduled for release in miral, milestone Unknown

Changed in miral:
status: Fix Released → Fix Committed
Changed in miral:
status: Fix Committed → Fix Released
Michał Sawicz (saviq) wrote :

Syncing task from Mir.

Changed in mir (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers