Mir

Nested Mir-on-X fails to initialize EGL

Bug #1696974 reported by Alan Griffiths
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Alan Griffiths

Bug Description

$ bin/mir_demo_server
$ bin/mir_demo_server --no-file --host $XDRUNTIME_DIR/mir_socket --test-client bin/mir_demo_client_eglplasma

expect: nested session shows plasma demo
actual: Can't eglInitialize

(This works fine with Mir 0.26.2, but fails with lp:mir)

Related branches

Revision history for this message
Alan Griffiths (alan-griffiths) wrote :

May also have a problem with Mir-on-KMS (same scenario):

[2017-06-09 12:37:26.000134] <DEBUG> eglstream: EGLStream platform is unsupported: Missing required extensions: EGL_EXT_platform_device EGL_EXT_device_base

Revision history for this message
Alan Griffiths (alan-griffiths) wrote :

This looks like a potential problem:

std::vector<mir::ExtensionDescription> mgn::NestedDisplayPlatform::extensions() const
{
    return {}; // TODO can we support extensions transitively?
}

Changed in mir:
assignee: nobody → Alan Griffiths (alan-griffiths)
Revision history for this message
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.27.0

Changed in mir:
status: In Progress → Fix Committed
tags: added: nested regression
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers