Mir

mir_window_spec_set_cursor_render_surface does not work

Bug #1679836 reported by Alberto Aguirre on 2017-04-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Alberto Aguirre

Bug Description

To set a custom cursor, mir_window_spec_set_cursor_render_surface can be used, but currently does not work.

Related branches

Alberto Aguirre (albaguirre) wrote :

There's no acceptance tests associated with mir_window_spec_set_cursor_render_surface.

The root cause is mf::SessionMediator::modify_surface should call stream->suitable_for_cursor instead of trying to check the pixel format itself.

Changed in mir:
milestone: none → 0.28.0
assignee: nobody → Alberto Aguirre (albaguirre)
importance: Undecided → High
status: New → In Progress
tags: added: clientapi cursor
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.28.0

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
milestone: 0.28.0 → 0.27.0
no longer affects: mir/0.27
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers