Mir

[regression] mir_demo_standalone_render_surfaces fails to start (std::exception::what: cannot find buffer by id)

Bug #1663130 reported by Daniel van Vugt on 2017-02-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Alan Griffiths

Bug Description

$ sudo mir_demo_standalone_render_surfaces

Rendering 5 surfaces
ERROR: /build/mir-1Sl_GZ/mir-0.26.0+17.04.20170126.3/src/server/compositor/buffer_map.cpp(105): Throw in function std::map<mir::IntWrapper<mir::graphics::BufferIdTag, unsigned int>, mir::compositor::BufferMap::MapEntry>::iterator mir::compositor::BufferMap::checked_buffers_find(mir::graphics::BufferID, const std::unique_lock<std::mutex>&)
Dynamic exception type: boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<std::logic_error> >
std::exception::what: cannot find buffer by id

Related branches

Changed in mir:
importance: Undecided → Medium
summary: - [regression] mir_demo_standalone_render_surfaces fails to start with
- mesa-kms (std::exception::what: cannot find buffer by id)
+ [regression] mir_demo_standalone_render_surfaces fails to start
+ (std::exception::what: cannot find buffer by id)
Daniel van Vugt (vanvugt) wrote :

Bisected. The regression started in:

------------------------------------------------------------
revno: 3941 [merge]
author: Kevin DuBois <email address hidden>
committer: Tarmac
branch nick: development-branch
timestamp: Mon 2017-01-16 14:04:32 +0000
message:
  server: remove mg::BufferProperties in some interfaces. mg::BufferProperties is problematic because it contains mg::BufferUsage, an outdated concept now that we have platform-specific extensions.
  .

  Approved by mir-ci-bot, Alan Griffiths, Cemil Azizoglu.
------------------------------------------------------------

Changed in mir:
status: New → Triaged
Daniel van Vugt (vanvugt) wrote :

Happening on krillin too, with the latest lp:mir -

Rendering 5 surfaces
ERROR: /home/dan/bzr/mir/trunk/src/server/compositor/buffer_map.cpp(114): Throw in function std::map<mir::IntWrapper<mir::graphics::BufferIdTag, unsigned int>, mir::compositor::BufferMap::MapEntry>::const_iterator mir::compositor::BufferMap::checked_buffers_find(mir::graphics::BufferID, const std::unique_lock<std::mutex>&) const
Dynamic exception type: N5boost16exception_detail10clone_implINS0_19error_info_injectorISt11logic_errorEEEE
std::exception::what: cannot find buffer by id

Changed in mir:
assignee: nobody → Alan Griffiths (alan-griffiths)
status: Triaged → In Progress
Alan Griffiths (alan-griffiths) wrote :

This program has outlived its usefulness. The approach it uses doesn't work because we've restructured the code, and we do not recommend doing this.

Changed in mir:
milestone: none → 0.28.0
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.28.0

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers