Mir

libmirclient-dev missing build depndency on libmircore-dev

Bug #1662942 reported by Stephen M. Webb on 2017-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Alan Griffiths
0.26
Fix Released
Medium
Alan Griffiths
mir (Ubuntu)
Medium
Unassigned

Bug Description

There is a broken build-dep in the Mir 0.26 packaging.

Dialogue taken from IRC revealing the details:

<hikiko> alan_g, when I include mir_toolkit header files in chromium I get this error:
<hikiko> In file included from /usr/include/mirclient/mir_toolkit/events/event.h:90:
<hikiko> #include "mir_toolkit/mir_input_device_types.h"
<hikiko> and apt-file search doesn't return anything
<hikiko> I wonder what I am missing
<hikiko> is this a bug or there's a lib I should have installed?
<hikiko> locate also cant find this file
<alan_g> that's in libmircore-dev. What do you get from $ pkg-config --cflags mirclient
<hikiko> $ pkg-config --cflags mirclient
<hikiko> -pthread -I/usr/include/mirclient -I/usr/include/mircookie -I/usr/include/mircore
<hikiko> that lib was missing :)
<alan_g> Then /usr/include/mircore/mir_toolkit/mir_input_device_types.h ought to be there
<hikiko> :s
<hikiko> ok installing mircore-dev fixed that
<hikiko> apt-file should return it though :/
<alan_g> Hmm. $ apt depends libmirclient-dev doesn't list libmircore-dev - sounds like a bug
<hikiko> yes, when I ran apt-get build-dep libmirclient-dev mircore-dev was not installed

Alan Griffiths (alan-griffiths) wrote :

The transitive dependency is already there, but lacking a version...

$ apt depends libmirclient-dev
libmirclient-dev
  Depends: libmirclient9 (= 0.26.0+17.04.20170126.3-0ubuntu1)
  Depends: libmircommon-dev (= 0.26.0+17.04.20170126.3-0ubuntu1)
  Depends: libmircookie-dev (= 0.26.0+17.04.20170126.3-0ubuntu1)
  Depends: libprotobuf-dev (>= 2.4.1)
$ apt depends libmircommon-dev
libmircommon-dev
  Depends: libmircommon7 (= 0.26.0+17.04.20170126.3-0ubuntu1)
  Depends: libmircore-dev <<==== ===== ===== ===== ===== ===== This seems to be the issue
  Depends: libprotobuf-dev (>= 2.4.1)
  Depends: libxkbcommon-dev
  Breaks: <mircommon-dev> (<< 0.6)
  Replaces: <mircommon-dev> (<< 0.6)

Changed in mir:
importance: High → Medium
status: Triaged → In Progress
tags: added: clientapi
Changed in mir:
milestone: 0.26.1 → 1.0.0
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 1.0.0

Changed in mir:
status: In Progress → Fix Committed
Changed in mir (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.26.1+17.04.20170209.1-0ubuntu1

---------------
mir (0.26.1+17.04.20170209.1-0ubuntu1) zesty; urgency=medium

  * New upstream release 0.26.1 (https://launchpad.net/mir/+milestone/0.26.1)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI unchanged at 43
      . mircommon ABI unchanged at 7
      . mirplatform ABI bumped to 15
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI bumped to 12
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI unchanged at 6
      . mircore ABI unchanged at 1
    - Enhancements:
      . Support for MirBuffer API that allows for better management of
        hardware/software buffers.
      . Support for MirPresentationChain API that allows better control
        over {de}queueing of individual buffers {from}to the server.
      . Interim support for MirRenderSurface API that provides a unit of
        renderable for lower level content such as MirBufferStreams and
        MirPresentationChains, etc.. MirRenderSurface API is marked
        deprecated as it (and the relevant entry points) will be renamed to
        MirSurface before general availability. It will initially be used for
        revamping support for EGL drivers.
      . Synchronous version of mir_prompt_session_new_fds_for_prompt_providers()
        API (mir_prompt_session_new_fds_for_prompt_providers_sync()) added for
        convenience.
      . Better name for MirPersistentId-->MirWindowId. MirPersistentId has now
        been deprecated.
    - Bugs fixed:
      . [regression] Unity8 stutters constantly (like half frame rate).
        (LP: #1661128)
      . mir 0.26 - spinner loading animation, minimize, maximize too fast.
        (LP: #1661072)
      . [regression] Nested server segfaults or rapidly logs exceptions when a
        fullscreen client starts [in mir_presentation_chain_set_dropping_mode
        ... std::exception::what: Operation not permitted] (LP: #1661508)
      . mir_window_request_persistent_id_sync seg faults when called twice.
        (LP: #1661704)
      . [regression] Windowed clients of nested servers are all black.
        (LP: #1661521)
      . Mir graphics platform ABI broke in series 0.26 but sonames never
        changed (LP: #1662455)
      . Fixes for 0.26 changelog.
      . [regression] mirscreencast hangs during screencast creation. (LP: #1662997)
      . libmirclient-dev missing build dependency on libmircore-dev. (LP: #1662942)
      . mir_window_spec_set_cursor_name() doesn't trigger
        mir::scene::SurfaceObserver::cursor_image_set_to. (LP: #1663197)
      . [regression] Software clients of nested servers are all black in Mir 0.25.0
        and later. (LP: #1663062)

 -- Cemil Azizoglu <email address hidden> Thu, 09 Feb 2017 21:46:32 +0000

Changed in mir (Ubuntu):
status: Triaged → Fix Released
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir/0.26 at revision 4021, which was released in Mir 0.26.1

Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers