Mir

[regression] Segfault on detect_fd_leaks during acceptance tests (in DisplayConfiguration/{DisplayFormatSetting,DisplaySubpixelSetting})

Bug #1661498 reported by Cemil Azizoglu on 2017-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Cemil Azizoglu
0.26
Fix Released
Critical
Cemil Azizoglu
mir (Ubuntu)
Medium
Unassigned

Bug Description

I've seen this quite often in a silo... Not so often in CI.

8: [ RUN ] DisplayConfiguration/DisplayFormatSetting.can_get_all_output_format/3
8: [2017-02-03 01:05:22.479325] mirserver: Starting
8: [2017-02-03 01:05:22.479397] mirserver: Selected driver: mir:stub-graphics (version 0.26.1)
8: [2017-02-03 01:05:22.489793] mirserver: Using software cursor
8: [2017-02-03 01:05:22.492185] mirserver: Selected input driver: mir:stub-input (version: 0.26.1)
8: [2017-02-03 01:05:22.492233] mirserver: Mir version 0.26.1
8: [2017-02-03 01:05:22.492401] mirserver: Initial display configuration:
8: [2017-02-03 01:05:22.492420] mirserver: Output 1: VGA connected, used
8: [2017-02-03 01:05:22.492430] mirserver: Physical size 0.0" 0x0mm
8: [2017-02-03 01:05:22.492436] mirserver: Power is on
8: [2017-02-03 01:05:22.492444] mirserver: Current mode 4x3 10.00Hz
8: [2017-02-03 01:05:22.492451] mirserver: Preferred mode 4x3 10.00Hz
8: [2017-02-03 01:05:22.492457] mirserver: Orientation normal
8: [2017-02-03 01:05:22.492463] mirserver: Logical size 4x3
8: [2017-02-03 01:05:22.492468] mirserver: Logical position +0+0
8: [2017-02-03 01:05:22.492474] mirserver: Output 2: VGA disconnected
8: [2017-02-03 01:05:22.492480] mirserver: Output 3: VGA connected, unused
8: [2017-02-03 01:05:22.492486] mirserver: Physical size 0.0" 0x0mm
8: [2017-02-03 01:05:22.492491] mirserver: Power is off
8: [2017-02-03 01:05:22.511553] mirserver: New display configuration:
8: [2017-02-03 01:05:22.511586] mirserver: Output 1: VGA connected, used
8: [2017-02-03 01:05:22.511597] mirserver: Physical size 0.0" 0x0mm
8: [2017-02-03 01:05:22.511603] mirserver: Power is on
8: [2017-02-03 01:05:22.511611] mirserver: Current mode 4x3 10.00Hz
8: [2017-02-03 01:05:22.511618] mirserver: Preferred mode 4x3 10.00Hz
8: [2017-02-03 01:05:22.511624] mirserver: Orientation normal
8: [2017-02-03 01:05:22.511629] mirserver: Logical size 4x3
8: [2017-02-03 01:05:22.511635] mirserver: Logical position +0+0
8: [2017-02-03 01:05:22.511661] mirserver: New base display configuration:
8: [2017-02-03 01:05:22.526758] mirserver: Stopping
8: /<<BUILDDIR>>/mir-0.26.1+17.04.20170203/tools/detect_fd_leaks.bash: line 84: 27470 Segmentation fault (core dumped) $@ 2>&1
8: 27471 Done | detect_fd_leaks
 8/20 Test #8: mir_acceptance_tests ..............................***Failed 81.66 sec
Running main() from main.cpp
Note: Google Test filter = -:
[==========] Running 517 tests from 86 test cases.

Related branches

Changed in mir:
importance: Undecided → High
milestone: none → 1.0.0
Daniel van Vugt (vanvugt) wrote :

Not happening on a daily basis so we can deprioritize.

Although I'm pretty sure this is an old issue. Wonder if it's a duplicate...

Changed in mir:
importance: High → Medium
Cemil Azizoglu (cemil-azizoglu) wrote :

It happens very frequently on silos.

tags: added: silo
Changed in mir:
importance: Medium → High
tags: added: testsfail
Cemil Azizoglu (cemil-azizoglu) wrote :
Changed in mir:
importance: High → Critical
milestone: 1.0.0 → 0.26.2
Daniel van Vugt (vanvugt) wrote :

This has been happening for a long time (years?) in CI. It doesn't usually happen often though.

Changed in mir:
milestone: 0.26.2 → 1.0.0
importance: Critical → Undecided
Daniel van Vugt (vanvugt) wrote :

It appears it's probably bash crashing:

8: /<<BUILDDIR>>/mir-0.26.1+17.04.20170203/tools/detect_fd_leaks.bash: line 84: 27470 Segmentation fault (core dumped) $@ 2>&1
8: 27471 Done | detect_fd_leaks

Although would be easy to confirm if we could get that core file.

Changed in mir:
assignee: nobody → Cemil Azizoglu (cemil-azizoglu)
Changed in mir:
status: New → In Progress
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir/0.26 at revision 4046, scheduled for release in Mir 0.26.2

summary: - seg fault on detect_fd_leaks
+ Segfault on detect_fd_leaks during acceptance tests:
+ DisplayConfiguration/{DisplayFormatSetting,DisplaySubpixelSetting}
Changed in mir:
importance: Undecided → High

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 1.0.0

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

OK, turns out it was an old one linger for just over a year before we fixed it...

------------------------------------------------------------
revno: 3343 [merge]
author: Christopher James Halse Rogers <email address hidden>
committer: Tarmac
branch nick: development-branch
timestamp: Fri 2016-02-26 12:21:22 +0000
message:
  New, extensible, display and enumeration API.

  Hide all the structs behind the API so we can extend them with all the extra information - scale, form factor, etc - that QtMir would like to have.

  This currently does not have any form of configuration setting interface, as that's not
  needed for QtMir's immediate needs.

  Approved by mir-ci-bot, Alexandros Frantzis, Alan Griffiths, Andreas Pokorny, Kevin DuBois, Cemil Azizoglu.
------------------------------------------------------------

Daniel van Vugt (vanvugt) wrote :

*lingering

tags: added: regression
Changed in mir:
importance: High → Medium
summary: - Segfault on detect_fd_leaks during acceptance tests:
+ [regression] Segfault on detect_fd_leaks during acceptance tests:
DisplayConfiguration/{DisplayFormatSetting,DisplaySubpixelSetting}
summary: - [regression] Segfault on detect_fd_leaks during acceptance tests:
- DisplayConfiguration/{DisplayFormatSetting,DisplaySubpixelSetting}
+ [regression] Segfault on detect_fd_leaks during acceptance tests (in
+ DisplayConfiguration/{DisplayFormatSetting,DisplaySubpixelSetting})
Changed in mir (Ubuntu):
status: New → Fix Released
importance: Undecided → Medium
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers