Mir

[regression] Development headers reference unknown header "mir_toolkit/mir_input_device_types.h" so some clients can't build at all any more

Bug #1654023 reported by William Hua on 2017-01-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Critical
Alan Griffiths
0.25
Invalid
Undecided
Unassigned
mir (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to build GTK+ which uses mircommon and mirclient, I'm getting:

In file included from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/events/event.h:74:0,
                 from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/client_types.h:24,
                 from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/mir_connection.h:21,
                 from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/mir_client_library.h:21,
                 from /home/william/Code/jhbuild/checkout/gtk+/gdk/mir/gdkmir.h:22,
                 from /home/william/Code/jhbuild/checkout/gtk+/gdk/mir/gdkmircursor.c:22:
/home/william/.cache/install/mir/include/mirclient/mir_toolkit/events/input/input_event.h:23:48: fatal error: mir_toolkit/mir_input_device_types.h: No such file or directory
 #include "mir_toolkit/mir_input_device_types.h"
                                                ^
compilation terminated.
Makefile:652: recipe for target 'gdkmircursor.lo' failed
make[4]: *** [gdkmircursor.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
In file included from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/events/event.h:74:0,
                 from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/client_types.h:24,
                 from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/mir_connection.h:21,
                 from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/mir_client_library.h:21,
                 from /home/william/Code/jhbuild/checkout/gtk+/gdk/mir/gdkmir.h:22,
                 from /home/william/Code/jhbuild/checkout/gtk+/gdk/mir/gdkmirdevicemanager.c:25:
/home/william/.cache/install/mir/include/mirclient/mir_toolkit/events/input/input_event.h:23:48: fatal error: mir_toolkit/mir_input_device_types.h: No such file or directory
 #include "mir_toolkit/mir_input_device_types.h"
                                                ^
compilation terminated.
Makefile:652: recipe for target 'gdkmirdevicemanager.lo' failed
make[4]: *** [gdkmirdevicemanager.lo] Error 1
In file included from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/events/event.h:74:0,
                 from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/client_types.h:24,
                 from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/mir_connection.h:21,
                 from /home/william/.cache/install/mir/include/mirclient/mir_toolkit/mir_client_library.h:21,
                 from /home/william/Code/jhbuild/checkout/gtk+/gdk/mir/gdkmir.h:22,
                 from /home/william/Code/jhbuild/checkout/gtk+/gdk/mir/gdkmirdisplay.c:24:
/home/william/.cache/install/mir/include/mirclient/mir_toolkit/events/input/input_event.h:23:48: fatal error: mir_toolkit/mir_input_device_types.h: No such file or directory
 #include "mir_toolkit/mir_input_device_types.h"

It seems like this header was moved, or possibly it wasn't installed.

Alan Griffiths (alan-griffiths) wrote :

include/common/mir_toolkit/mir_input_device_types.h was added in -c 3893 (post 0.25), but src/common/CMakeLists.txt doesn't install the mir_toolkit subtree.

Changed in mir:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Alan Griffiths (alan-griffiths)
milestone: none → 0.26.0
Changed in mir:
status: Confirmed → In Progress
summary: Development headers reference unknown header
+ "mir_toolkit/mir_input_device_types.h"
Changed in mir:
importance: High → Critical
summary: Development headers reference unknown header
- "mir_toolkit/mir_input_device_types.h"
+ "mir_toolkit/mir_input_device_types.h" so some clients can't build at
+ all any more
summary: - Development headers reference unknown header
+ [regression] Development headers reference unknown header
"mir_toolkit/mir_input_device_types.h" so some clients can't build at
all any more
tags: added: clientapi regression
Daniel van Vugt (vanvugt) wrote :

Invalid for 0.25 since the bug only appeared in series 0.26. And since the bug has never been released it's not a critical problem.

Changed in mir:
importance: Critical → High
Changed in mir (Ubuntu):
status: New → Invalid
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.26.0

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

I take it back. Not being able to build clients would have been a critical problem. Fortunately the fix has now landed.

Changed in mir:
importance: High → Critical
Launchpad Janitor (janitor) wrote :
Download full text (7.2 KiB)

This bug was fixed in the package mir - 0.26.0+17.04.20170126.3-0ubuntu1

---------------
mir (0.26.0+17.04.20170126.3-0ubuntu1) zesty; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.26.0 (https://launchpad.net/mir/+milestone/0.26.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 43
      . mircommon ABI unchanged at 7
      . mirplatform ABI unchanged at 14
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI unchanged at 11
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI unchanged at 6
      . mircore ABI unchanged at 1
    - Enhancements:
      . New/improved toolkit APIs: MirInputConfig and related functions,
        MirWindow and related functions, DisplayConfig and related functions,
        MirScreencastSpec and related functions,
      . Support for configuring input configuration
      . Introduce toolkit extension mechanism for platform specific APIs.
      . Toolkit extensions for: mesa_drm_auth, set_gbm_device and
        window_coordinate_translation
      . Screencasting to a specific MirBuffer.
      . Add DisplayConfigurationController::base_configuration() so downstreams
        can get the base configuration. (Weirdly they can already set it.).
      . x11 platform: allow adjustable scale parameter.
      . Added EDID support: client API, server logging and in mirout.
      . mirout: Add newer attributes only available in the new display
        config API: scaling factor, subpixel arrangement and form factor.
      . mirout: Log the orientation and logical size of each output too.
      . Replace the mir::Server-overridable Reports with Observers.
      . Add xkbcommon to mirclient.pc Requires.private.
      . Deprecate legacy toolkit APIs that will be removed in Mir 1.0
      . Introduced 'client-side vsync', which dramatically reduces latency
        from the client to the screen (particularly for nested servers like
        Unity8).
    - Bugs fixed:
      . [performance] Restore support for better-than-triple buffering by
        default. (LP: #1240909)
      . Frame rate is artificially low on Diamondville Intel Atom systems due
        to aggressive power management (LP: #1388490)
      . [testsfail] failure in CI in
        AndroidInputReceiverSetup.slow_raw_input_doesnt_cause_frameskipping
        (LP: #1394369)
      . [trusted prompt sessions] Can't open two prompt sessions at the same
        time (LP: #1494197)
      . Changing scale, formFactor or DPI in display configuration causes
        renderer teardown/recreate unnecessarily (LP: #1556142)
      . [testsfail] ApplicationNotRespondingDetection.failure_to_pong_is_
        noticed (LP: #1570327)
      . CI failure in TestClientInput.receives_one_touch_event_per_frame
        (LP: #1570698)
      . Mir-on-X mouse input is jerky/stuttery compared to Mir-on-KMS
        (LP: #1576600)
      . [regression] Two fingers in mir_proving_server now resizes/moves app
        windows (two finger apps unusable) (LP: #1586311)
      . Pointer/cursor input lag in unity8 session (LP: #1591328)
      . PointerConfinement.test_we_update_our_confined_region_on_a_resize
      ...

Read more...

Changed in mir (Ubuntu):
status: Invalid → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers