Mir

[ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server

Bug #1646558 reported by Cemil Azizoglu on 2016-12-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Andreas Pokorny
mir (Ubuntu)
Undecided
Unassigned

Bug Description

10:25:12 11: [ RUN ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server
10:25:12 11: [2016-12-01 10:25:12.937701] mirserver: Starting
10:25:12 11: [2016-12-01 10:25:12.938796] mirserver: Selected driver: mir:stub-graphics (version 0.26.0)
10:25:13 11: [2016-12-01 10:25:13.123066] mirserver: Using software cursor
10:25:13 11: [2016-12-01 10:25:13.136371] mirserver: Selected input driver: mir:stub-input (version: 0.26.0)
10:25:13 11: [2016-12-01 10:25:13.137063] mirserver: Mir version 0.26.0
10:25:13 11: [2016-12-01 10:25:13.294651] mirserver: Initial display configuration:
10:25:13 11: [2016-12-01 10:25:13.294952] mirserver: Output 1: VGA connected, used
10:25:13 11: [2016-12-01 10:25:13.295168] mirserver: Physical size 0.0" 0x0mm
10:25:13 11: [2016-12-01 10:25:13.295349] mirserver: Power is on
10:25:13 11: [2016-12-01 10:25:13.295559] mirserver: Current mode 1920x1080 60.00Hz
10:25:13 11: [2016-12-01 10:25:13.295788] mirserver: Preferred mode 1920x1080 60.00Hz
10:25:13 11: [2016-12-01 10:25:13.295979] mirserver: Orientation normal
10:25:13 11: [2016-12-01 10:25:13.296175] mirserver: Logical size 1920x1080
10:25:13 11: [2016-12-01 10:25:13.296365] mirserver: Logical position +0+0
10:25:13 11: [2016-12-01 10:25:13.328187] mirserver: Starting
10:25:13 11: [2016-12-01 10:25:13.745478] mirserver: Using nested cursor
10:25:13 11: [2016-12-01 10:25:13.803440] mirserver: Mir version 0.26.0
10:25:13 11: [2016-12-01 10:25:13.960211] mirserver: Initial display configuration:
10:25:14 11: [2016-12-01 10:25:13.960729] mirserver: Output 1: VGA connected, used
10:25:14 11: [2016-12-01 10:25:13.960948] mirserver: Physical size 0.0" 0x0mm
10:25:14 11: [2016-12-01 10:25:13.961124] mirserver: Power is on
10:25:14 11: [2016-12-01 10:25:13.961364] mirserver: Current mode 1920x1080 60.00Hz
10:25:14 11: [2016-12-01 10:25:13.961572] mirserver: Preferred mode 1920x1080 60.00Hz
10:25:14 11: [2016-12-01 10:25:13.961753] mirserver: Orientation normal
10:25:14 11: [2016-12-01 10:25:13.961931] mirserver: Logical size 1920x1080
10:25:14 11: [2016-12-01 10:25:13.962107] mirserver: Logical position +0+0
10:25:16 11: [2016-12-01 10:25:16.218016] mirserver: Stopping
10:25:16 11: [2016-12-01 10:25:16.266813] mirserver: Stopping
10:25:16 11: /<<BUILDDIR>>/mir-0.25.0+yakkety3048bzr3857/tests/acceptance-tests/test_nested_input.cpp:368: Failure
10:25:16 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
10:25:16 11: Expected: to be called once
10:25:16 11: Actual: never called - unsatisfied and active
10:25:16 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (3440 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=yakkety/3020/consoleFull

Related branches

tags: added: testsfail
summary: + [ FAILED ]
NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server
Daniel van Vugt (vanvugt) wrote :

And again:

02:50:43 9: [ RUN ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server
...
02:50:48 9: /<<BUILDDIR>>/mir-0.25.0+yakkety3041bzr3846/tests/acceptance-tests/test_nested_input.cpp:368: Failure
02:50:48 9: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
02:50:48 9: Expected: to be called once
02:50:48 9: Actual: never called - unsatisfied and active
02:50:48 9: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (4946 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=yakkety/3013/consoleFull

Daniel van Vugt (vanvugt) wrote :

Multiple times in one day, and it's a new bug. Recent regression?...

04:28:13 11: /<<BUILDDIR>>/mir-0.25.0+xenial3060bzr3847/tests/acceptance-tests/test_nested_input.cpp:368: Failure
04:28:13 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
04:28:13 11: Expected: to be called once
04:28:13 11: Actual: never called - unsatisfied and active
04:28:13 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (3965 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3032/consoleFull

Daniel van Vugt (vanvugt) wrote :

Today:

11:13:11 11: /<<BUILDDIR>>/mir-0.25.0+xenial3087bzr3867/tests/acceptance-tests/test_nested_input.cpp:368: Failure
11:13:11 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
11:13:11 11: Expected: to be called once
11:13:11 11: Actual: never called - unsatisfied and active
11:13:11 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (3285 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/3059/consoleFull

This surely must be a recent regression...?

Daniel van Vugt (vanvugt) wrote :

Again:

10:24:49 11: /<<BUILDDIR>>/mir-0.25.0+yakkety3130bzr3874/tests/acceptance-tests/test_nested_input.cpp:368: Failure
10:24:49 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
10:24:49 11: Expected: to be called once
10:24:49 11: Actual: never called - unsatisfied and active
10:24:49 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (3982 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=yakkety/3101/consoleFull

Daniel van Vugt (vanvugt) wrote :

Looks like the offending test is relatively new:

revno: 3842 [merge]
author: Andreas Pokorny <email address hidden>
committer: Tarmac
branch nick: development-branch
timestamp: Thu 2016-11-24 03:48:02 +0000

tags: added: regression
Daniel van Vugt (vanvugt) wrote :

Again:

20:48:41 /<<BUILDDIR>>/mir-0.25.0+yakkety3183bzr3870/tests/acceptance-tests/test_nested_input.cpp:368: Failure
20:48:41 Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
20:48:41 Expected: to be called once
20:48:41 Actual: never called - unsatisfied and active
20:48:41 [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (3563 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=yakkety/3153/consoleFull

Daniel van Vugt (vanvugt) wrote :

Today:

05:30:48 11: /<<BUILDDIR>>/mir-0.26.0+yakkety3349bzr3906/tests/acceptance-tests/test_nested_input.cpp:368: Failure
05:30:48 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
05:30:48 11: Expected: to be called once
05:30:48 11: Actual: never called - unsatisfied and active
05:30:48 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (3483 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=yakkety/3319/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

06:50:40 11: /<<BUILDDIR>>/mir-0.26.0+xenial3351bzr3907/tests/acceptance-tests/test_nested_input.cpp:368: Failure
06:50:40 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
06:50:40 11: Expected: to be called once
06:50:40 11: Actual: never called - unsatisfied and active
06:50:40 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (5348 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3321/consoleFull

Changed in mir:
importance: High → Medium

This gets me every time. Raising priority to critical as it's seriously hindering my progress.

Changed in mir:
importance: Medium → Critical
Daniel van Vugt (vanvugt) wrote :

Yeah since it's a recent regression (comment #5) I asked anpok to take a look into it recently.

Although I don't think Critical is appropriate. According to Launchpad there are at least 7 'testsfail' bugs hotter than this one:

https://bugs.launchpad.net/mir/+bugs?field.tag=testsfail&orderby=-heat&start=0

Changed in mir:
importance: Critical → High
Daniel van Vugt (vanvugt) wrote :

And another:

7:26:41 11: /<<BUILDDIR>>/mir-0.26.0+xenial3411bzr3915/tests/acceptance-tests/test_nested_input.cpp:368: Failure
07:26:41 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
07:26:41 11: Expected: to be called once
07:26:41 11: Actual: never called - unsatisfied and active
07:26:41 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (4678 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/3381/consoleFull

Daniel van Vugt (vanvugt) wrote :

And again. At this rate the bug heat might increase :)

09:38:59 11: /<<BUILDDIR>>/mir-0.26.0+zesty3447bzr3916/tests/acceptance-tests/test_nested_input.cpp:368: Failure
09:38:59 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
09:38:59 11: Expected: to be called once
09:38:59 11: Actual: never called - unsatisfied and active
09:38:59 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (4324 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3417/consoleFull

Changed in mir:
assignee: nobody → Andreas Pokorny (andreas-pokorny)
Download full text (5.5 KiB)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/3462/consoleFull

NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (1886 ms)
12:06:19 11: [ RUN ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server
12:06:19 11: [2017-01-11 12:06:19.629499] mirserver: Starting
12:06:19 11: [2017-01-11 12:06:19.632592] mirserver: Selected driver: mir:stub-graphics (version 0.26.0)
12:06:19 11: [2017-01-11 12:06:19.818184] mirserver: Using software cursor
12:06:19 11: [2017-01-11 12:06:19.872011] mirserver: Selected input driver: mir:stub-input (version: 0.26.0)
12:06:19 11: [2017-01-11 12:06:19.873378] mirserver: Mir version 0.26.0
12:06:20 11: [2017-01-11 12:06:20.062507] mirserver: Initial display configuration:
12:06:20 11: [2017-01-11 12:06:20.062848] mirserver: Output 1: VGA connected, used
12:06:20 11: [2017-01-11 12:06:20.063111] mirserver: Physical size 0.0" 0x0mm
12:06:20 11: [2017-01-11 12:06:20.063305] mirserver: Power is on
12:06:20 11: [2017-01-11 12:06:20.063497] mirserver: Current mode 1920x1080 60.00Hz
12:06:20 11: [2017-01-11 12:06:20.063683] mirserver: Preferred mode 1920x1080 60.00Hz
12:06:20 11: [2017-01-11 12:06:20.063837] mirserver: Orientation normal
12:06:20 11: [2017-01-11 12:06:20.064000] mirserver: Logical size 1920x1080
12:06:20 11: [2017-01-11 12:06:20.064176] mirserver: Logical position +0+0
12:06:20 11: [2017-01-11 12:06:20.093870] mirserver: Starting
12:06:20 11: [2017-01-11 12:06:20.505330] mirserver: Using nested cursor
12:06:20 11: [2017-01-11 12:06:20.646156] mirserver: Mir version 0.26.0
12:06:20 11: [2017-01-11 12:06:20.830536] mirserver: Initial display configuration:
12:06:20 11: [2017-01-11 12:06:20.831134] mirserver: Output 1: VGA connected, used
12:06:20 11: [2017-01-11 12:06:20.831396] mirserver: Physical size 0.0" 0x0mm
12:06:20 11: [2017-01-11 12:06:20.831636] mirserver: Power is on
12:06:20 11: [2017-01-11 12:06:20.831902] mirserver: Current mode 1920x1080 60.00Hz
12:06:20 11: [2017-01-11 12:06:20.832092] mirserver: Preferred mode 1920x1080 60.00Hz
12:06:20 11: [2017-01-11 12:06:20.832276] mirserver: Orientation normal
12:06:20 11: [2017-01-11 12:06:20.832438] mirserver: Logical size 1920x1080
12:06:20 11: [2017-01-11 12:06:20.832593] mirserver: Logical position +0+0
12:06:23 11: [2017-01-11 12:06:23.160924] mirserver: Stopping
12:06:23 11: [2017-01-11 12:06:23.238742] mirserver: Stopping
12:06:23 11: /<<BUILDDIR>>/mir-0.26.0+xenial3492bzr3919/tests/acceptance-tests/test_nested_input.cpp:368: Failure
12:06:23 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
12:06:23 11: Expected: to be called once
12:06:23 11: Actual: never called - unsatisfied and active
12:06:23 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (3732 ms)

...

12:11:21 [ RUN ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server
12:11:21 [2017-01-11 12:06:19.629499] mirserver: Starting
12:11:21 [2017-01-11 12:06:19.632592] mirserver: Selected dr...

Read more...

Changed in mir:
status: New → In Progress
milestone: none → 0.26.0
Daniel van Vugt (vanvugt) wrote :

Again:

08:12:19 11: /<<BUILDDIR>>/mir-0.26.0+zesty3529bzr3917/tests/acceptance-tests/test_nested_input.cpp:368: Failure
08:12:19 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
08:12:19 11: Expected: to be called once
08:12:19 11: Actual: never called - unsatisfied and active
08:12:19 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (4036 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3499/consoleFull

Changed in mir:
milestone: 0.26.0 → 1.0.0
Daniel van Vugt (vanvugt) wrote :

Again:

15:45:19 11: /<<BUILDDIR>>/mir-0.26.0+xenial3537bzr3934/tests/acceptance-tests/test_nested_input.cpp:375: Failure
15:45:19 11: Value of: event_received.wait_for(60s)
15:45:19 11: Actual: false
15:45:19 11: Expected: true
15:45:19 11: [2017-01-13 15:45:19.706364] mirserver: Stopping
15:45:19 11: [2017-01-13 15:45:19.981966] mirserver: Stopping
15:45:20 11: /<<BUILDDIR>>/mir-0.26.0+xenial3537bzr3934/tests/acceptance-tests/test_nested_input.cpp:366: Failure
15:45:20 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
15:45:20 11: Expected: to be called once
15:45:20 11: Actual: never called - unsatisfied and active
15:45:20 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (64500 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3507/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

04:20:03 11: /<<BUILDDIR>>/mir-0.26.0+xenial3577bzr3920/tests/acceptance-tests/test_nested_input.cpp:375: Failure
04:20:03 11: Value of: event_received.wait_for(60s)
04:20:03 11: Actual: false
04:20:03 11: Expected: true
04:20:03 11: [2017-01-16 04:20:03.862646] mirserver: Stopping
04:20:03 11: [2017-01-16 04:20:03.961744] mirserver: Stopping
04:20:04 11: /<<BUILDDIR>>/mir-0.26.0+xenial3577bzr3920/tests/acceptance-tests/test_nested_input.cpp:366: Failure
04:20:04 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
04:20:04 11: Expected: to be called once
04:20:04 11: Actual: never called - unsatisfied and active
04:20:04 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62490 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/3546/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

08:10:10 9: /<<BUILDDIR>>/mir-0.26.0+zesty3583bzr3928/tests/acceptance-tests/test_nested_input.cpp:375: Failure
08:10:10 9: Value of: event_received.wait_for(60s)
08:10:10 9: Actual: false
08:10:10 9: Expected: true
08:10:10 9: [2017-01-16 08:10:10.578390] mirserver: Stopping
08:10:10 9: [2017-01-16 08:10:10.816357] mirserver: Stopping
08:10:10 9: /<<BUILDDIR>>/mir-0.26.0+zesty3583bzr3928/tests/acceptance-tests/test_nested_input.cpp:366: Failure
08:10:10 9: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
08:10:10 9: Expected: to be called once
08:10:10 9: Actual: never called - unsatisfied and active
08:10:10 9: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (63401 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=zesty/3552/consoleFull

Daniel van Vugt (vanvugt) wrote :

And here:

09:45:58 11: /<<BUILDDIR>>/mir-0.26.0+zesty3586bzr3934/tests/acceptance-tests/test_nested_input.cpp:375: Failure
09:45:58 11: Value of: event_received.wait_for(60s)
09:45:58 11: Actual: false
09:45:59 11: Expected: true
09:45:59 11: [2017-01-16 09:45:58.986294] mirserver: Stopping
09:45:59 11: [2017-01-16 09:45:59.155094] mirserver: Stopping
09:45:59 11: /<<BUILDDIR>>/mir-0.26.0+zesty3586bzr3934/tests/acceptance-tests/test_nested_input.cpp:366: Failure
09:45:59 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
09:45:59 11: Expected: to be called once
09:45:59 11: Actual: never called - unsatisfied and active
09:45:59 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62677 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3555/consoleFull

Alberto Aguirre (albaguirre) wrote :

Again here:

20:24:12 11: [ RUN ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server
20:24:12 11: [2017-01-18 20:24:12.307905] mirserver: Starting
20:24:12 11: [2017-01-18 20:24:12.309761] mirserver: Selected driver: mir:stub-graphics (version 0.26.0)
20:24:12 11: [2017-01-18 20:24:12.523745] mirserver: Using software cursor
20:24:12 11: [2017-01-18 20:24:12.539131] mirserver: Selected input driver: mir:stub-input (version: 0.26.0)
20:24:12 11: [2017-01-18 20:24:12.539700] mirserver: Mir version 0.26.0
20:24:12 11: [2017-01-18 20:24:12.668345] mirserver: Initial display configuration:
20:24:12 11: [2017-01-18 20:24:12.668566] mirserver: Output 1: VGA connected, used
20:24:12 11: [2017-01-18 20:24:12.668748] mirserver: Physical size 0.0" 0x0mm
20:24:12 11: [2017-01-18 20:24:12.668893] mirserver: Power is on
20:24:12 11: [2017-01-18 20:24:12.669069] mirserver: Current mode 1920x1080 60.00Hz
20:24:12 11: [2017-01-18 20:24:12.669241] mirserver: Preferred mode 1920x1080 60.00Hz
20:24:12 11: [2017-01-18 20:24:12.669393] mirserver: Orientation normal
20:24:12 11: [2017-01-18 20:24:12.669539] mirserver: Logical size 1920x1080
20:24:12 11: [2017-01-18 20:24:12.669680] mirserver: Logical position +0+0
20:24:12 11: [2017-01-18 20:24:12.687241] mirserver: Starting
20:24:13 11: [2017-01-18 20:24:13.338446] mirserver: Using nested cursor
20:24:13 11: [2017-01-18 20:24:13.398367] mirserver: Mir version 0.26.0
20:24:13 11: [2017-01-18 20:24:13.528605] mirserver: Initial display configuration:
20:24:13 11: [2017-01-18 20:24:13.528969] mirserver: Output 1: VGA connected, used
20:24:13 11: [2017-01-18 20:24:13.529173] mirserver: Physical size 0.0" 0x0mm
20:24:13 11: [2017-01-18 20:24:13.529319] mirserver: Power is on
20:24:13 11: [2017-01-18 20:24:13.529494] mirserver: Current mode 1920x1080 60.00Hz
20:24:13 11: [2017-01-18 20:24:13.529664] mirserver: Preferred mode 1920x1080 60.00Hz
20:24:13 11: [2017-01-18 20:24:13.529810] mirserver: Orientation normal
20:24:13 11: [2017-01-18 20:24:13.529959] mirserver: Logical size 1920x1080
20:24:13 11: [2017-01-18 20:24:13.530102] mirserver: Logical position +0+0
20:25:14 11: /<<BUILDDIR>>/mir-0.26.0+xenial3683bzr3951/tests/acceptance-tests/test_nested_input.cpp:375: Failure
20:25:14 11: Value of: event_received.wait_for(60s)
20:25:14 11: Actual: false
20:25:14 11: Expected: true
20:25:14 11: [2017-01-18 20:25:14.056756] mirserver: Stopping
20:25:14 11: [2017-01-18 20:25:14.139273] mirserver: Stopping
20:25:14 11: /<<BUILDDIR>>/mir-0.26.0+xenial3683bzr3951/tests/acceptance-tests/test_nested_input.cpp:366: Failure
20:25:14 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
20:25:14 11: Expected: to be called once
20:25:14 11: Actual: never called - unsatisfied and active
20:25:14 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (61904 ms)
20:25:14 11: [----------] 2 tests from NestedInputWithMouse (63612 ms total)

Changed in mir:
milestone: 1.0.0 → 0.26.0
Changed in mir:
milestone: 0.26.0 → 1.0.0
Daniel van Vugt (vanvugt) wrote :

Anything not yet landed targets the series of trunk. As soon as a fix appears in lp:mir/0.26 I'll also move the milestones.

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Oh, the branches are now identical. All committed fixes now go in 0.26.0 :)

Changed in mir:
milestone: 1.0.0 → 0.26.0
Daniel van Vugt (vanvugt) wrote :

Just happened again:

07:02:29 11: /<<BUILDDIR>>/mir-0.26.0+xenial3726bzr3969/tests/acceptance-tests/test_nested_input.cpp:375: Failure
07:02:29 11: Value of: event_received.wait_for(60s)
07:02:29 11: Actual: false
07:02:29 11: Expected: true
07:02:29 11: [2017-01-20 07:02:29.784437] mirserver: Stopping
07:02:29 11: [2017-01-20 07:02:29.849308] mirserver: Stopping
07:02:29 11: /<<BUILDDIR>>/mir-0.26.0+xenial3726bzr3969/tests/acceptance-tests/test_nested_input.cpp:366: Failure
07:02:29 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
07:02:29 11: Expected: to be called once
07:02:29 11: Actual: never called - unsatisfied and active
07:02:29 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62409 ms)

Changed in mir:
status: Fix Committed → Triaged
milestone: 0.26.0 → 1.0.0
Alberto Aguirre (albaguirre) wrote :
Download full text (3.1 KiB)

Again:

19:41:04 11: [ RUN ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server
19:41:04 11: [2017-01-23 19:41:04.381976] mirserver: Starting
19:41:04 11: [2017-01-23 19:41:04.383912] mirserver: Selected driver: mir:stub-graphics (version 0.26.0)
19:41:04 11: [2017-01-23 19:41:04.652845] mirserver: Using software cursor
19:41:04 11: [2017-01-23 19:41:04.669401] mirserver: Selected input driver: mir:stub-input (version: 0.26.0)
19:41:04 11: [2017-01-23 19:41:04.670474] mirserver: Mir version 0.26.0
19:41:04 11: [2017-01-23 19:41:04.905793] mirserver: Initial display configuration:
19:41:04 11: [2017-01-23 19:41:04.906179] mirserver: Output 1: VGA connected, used
19:41:04 11: [2017-01-23 19:41:04.906476] mirserver: Physical size 0.0" 0x0mm
19:41:04 11: [2017-01-23 19:41:04.906682] mirserver: Power is on
19:41:04 11: [2017-01-23 19:41:04.906944] mirserver: Current mode 1920x1080 60.00Hz
19:41:04 11: [2017-01-23 19:41:04.907188] mirserver: Preferred mode 1920x1080 60.00Hz
19:41:04 11: [2017-01-23 19:41:04.907395] mirserver: Orientation normal
19:41:04 11: [2017-01-23 19:41:04.907602] mirserver: Logical size 1920x1080
19:41:04 11: [2017-01-23 19:41:04.907811] mirserver: Logical position +0+0
19:41:05 11: [2017-01-23 19:41:04.936631] mirserver: Starting
19:41:05 11: [2017-01-23 19:41:05.648888] mirserver: Using nested cursor
19:41:05 11: [2017-01-23 19:41:05.739211] mirserver: Mir version 0.26.0
19:41:05 11: [2017-01-23 19:41:05.922967] mirserver: Initial display configuration:
19:41:05 11: [2017-01-23 19:41:05.923383] mirserver: Output 1: VGA connected, used
19:41:05 11: [2017-01-23 19:41:05.923647] mirserver: Physical size 0.0" 0x0mm
19:41:05 11: [2017-01-23 19:41:05.923835] mirserver: Power is on
19:41:05 11: [2017-01-23 19:41:05.924072] mirserver: Current mode 1920x1080 60.00Hz
19:41:05 11: [2017-01-23 19:41:05.924319] mirserver: Preferred mode 1920x1080 60.00Hz
19:41:05 11: [2017-01-23 19:41:05.924523] mirserver: Orientation normal
19:41:06 11: [2017-01-23 19:41:05.924735] mirserver: Logical size 1920x1080
19:41:06 11: [2017-01-23 19:41:05.924963] mirserver: Logical position +0+0
19:42:06 11: /<<BUILDDIR>>/mir-0.26.0+xenial3790bzr3968/tests/acceptance-tests/test_nested_input.cpp:375: Failure
19:42:06 11: Value of: event_received.wait_for(60s)
19:42:06 11: Actual: false
19:42:06 11: Expected: true
19:42:06 11: [2017-01-23 19:42:06.485869] mirserver: Stopping
19:42:06 11: [2017-01-23 19:42:06.544367] mirserver: Stopping
19:42:06 11: /<<BUILDDIR>>/mir-0.26.0+xenial3790bzr3968/tests/acceptance-tests/test_nested_input.cpp:366: Failure
19:42:06 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
19:42:06 11: Expected: to be called once
19:42:06 11: Actual: never called - unsatisfied and active
19:42:06 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62234 ms)
19:42:06 11: [----------] 2 tests from NestedInputWithMouse (64447 ms total)

In:https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3748/conso...

Read more...

Daniel van Vugt (vanvugt) wrote :

Again:

12:47:37 11: /<<BUILDDIR>>/mir-0.26.0+xenial3773bzr3939/tests/acceptance-tests/test_nested_input.cpp:375: Failure
12:47:37 11: Value of: event_received.wait_for(60s)
12:47:37 11: Actual: false
12:47:37 11: Expected: true
12:47:37 11: [2017-01-23 12:47:37.847693] mirserver: Stopping
12:47:37 11: [2017-01-23 12:47:37.962444] mirserver: Stopping
12:47:38 11: /<<BUILDDIR>>/mir-0.26.0+xenial3773bzr3939/tests/acceptance-tests/test_nested_input.cpp:366: Failure
12:47:38 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
12:47:38 11: Expected: to be called once
12:47:38 11: Actual: never called - unsatisfied and active
12:47:38 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62491 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3731/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

21:46:19 11: /<<BUILDDIR>>/mir-0.26.0+zesty3866bzr3993/tests/acceptance-tests/test_nested_input.cpp:375: Failure
21:46:19 11: Value of: event_received.wait_for(60s)
21:46:19 11: Actual: false
21:46:19 11: Expected: true
21:46:19 11: [2017-01-26 21:46:19.667380] mirserver: Stopping
21:46:19 11: [2017-01-26 21:46:19.737357] mirserver: Stopping
21:46:19 11: /<<BUILDDIR>>/mir-0.26.0+zesty3866bzr3993/tests/acceptance-tests/test_nested_input.cpp:366: Failure
21:46:19 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
21:46:19 11: Expected: to be called once
21:46:19 11: Actual: never called - unsatisfied and active
21:46:19 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62464 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3824/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

16:14:21 11: /<<BUILDDIR>>/mir-0.26.0+xenial3860bzr3973/tests/acceptance-tests/test_nested_input.cpp:375: Failure
16:14:21 11: Value of: event_received.wait_for(60s)
16:14:21 11: Actual: false
16:14:21 11: Expected: true
16:14:21 11: [2017-01-26 16:14:21.756849] mirserver: Stopping
16:14:22 11: [2017-01-26 16:14:21.982035] mirserver: Stopping
16:14:22 11: /<<BUILDDIR>>/mir-0.26.0+xenial3860bzr3973/tests/acceptance-tests/test_nested_input.cpp:366: Failure
16:14:22 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
16:14:22 11: Expected: to be called once
16:14:22 11: Actual: never called - unsatisfied and active
16:14:22 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (63607 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3818/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

09:38:45 11: /<<BUILDDIR>>/mir-0.26.0+xenial3907bzr4006/tests/acceptance-tests/test_nested_input.cpp:375: Failure
09:38:45 11: Value of: event_received.wait_for(60s)
09:38:45 11: Actual: false
09:38:45 11: Expected: true
09:38:45 11: [2017-02-01 09:38:45.538569] mirserver: Stopping
09:38:45 11: [2017-02-01 09:38:45.622413] mirserver: Stopping
09:38:45 11: /<<BUILDDIR>>/mir-0.26.0+xenial3907bzr4006/tests/acceptance-tests/test_nested_input.cpp:366: Failure
09:38:45 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
09:38:45 11: Expected: to be called once
09:38:45 11: Actual: never called - unsatisfied and active
09:38:45 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62116 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/3865/consoleFull

Daniel van Vugt (vanvugt) wrote :

And here:

04:02:12 11: /<<BUILDDIR>>/mir-0.26.0+xenial3926bzr4015/tests/acceptance-tests/test_nested_input.cpp:421: Failure
04:02:12 11: Value of: event_received.wait_for(60s)
04:02:12 11: Actual: false
04:02:12 11: Expected: true
04:02:12 11: [2017-02-02 04:02:12.100224] mirserver: Stopping
04:02:12 11: [2017-02-02 04:02:12.213581] mirserver: Stopping
04:02:12 11: /<<BUILDDIR>>/mir-0.26.0+xenial3926bzr4015/tests/acceptance-tests/test_nested_input.cpp:412: Failure
04:02:12 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
04:02:12 11: Expected: to be called once
04:02:12 11: Actual: never called - unsatisfied and active
04:02:12 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62607 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3884/consoleFull

Daniel van Vugt (vanvugt) wrote :

And:

04:33:19 9: /<<BUILDDIR>>/mir-0.26.0+zesty3941bzr4002/tests/acceptance-tests/test_nested_input.cpp:421: Failure
04:33:19 9: Value of: event_received.wait_for(60s)
04:33:19 9: Actual: false
04:33:19 9: Expected: true
04:33:19 9: [2017-02-03 04:33:19.625133] mirserver: Stopping
04:33:19 9: [2017-02-03 04:33:19.679908] mirserver: Stopping
04:33:19 9: /<<BUILDDIR>>/mir-0.26.0+zesty3941bzr4002/tests/acceptance-tests/test_nested_input.cpp:412: Failure
04:33:19 9: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
04:33:19 9: Expected: to be called once
04:33:19 9: Actual: never called - unsatisfied and active
04:33:19 9: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (61597 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=zesty/3899/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again here:

08:17:33 9: /<<BUILDDIR>>/mir-0.26.0+zesty3981bzr4009/tests/acceptance-tests/test_nested_input.cpp:421: Failure
08:17:33 9: Value of: event_received.wait_for(60s)
08:17:33 9: Actual: false
08:17:33 9: Expected: true
08:17:33 9: [2017-02-07 08:17:33.984819] mirserver: Stopping
08:17:34 9: [2017-02-07 08:17:34.075254] mirserver: Stopping
08:17:34 9: /<<BUILDDIR>>/mir-0.26.0+zesty3981bzr4009/tests/acceptance-tests/test_nested_input.cpp:412: Failure
08:17:34 9: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
08:17:34 9: Expected: to be called once
08:17:34 9: Actual: never called - unsatisfied and active
08:17:34 9: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62389 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=zesty/3932/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:
08:50:50 11: /<<BUILDDIR>>/mir-0.26.0+zesty3986bzr4021/tests/acceptance-tests/test_nested_input.cpp:421: Failure
08:50:50 11: Value of: event_received.wait_for(60s)
08:50:50 11: Actual: false
08:50:50 11: Expected: true
08:50:50 11: [2017-02-08 08:50:50.123733] mirserver: Stopping
08:50:50 11: [2017-02-08 08:50:50.255966] mirserver: Stopping
08:50:50 11: /<<BUILDDIR>>/mir-0.26.0+zesty3986bzr4021/tests/acceptance-tests/test_nested_input.cpp:412: Failure
08:50:50 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
08:50:50 11: Expected: to be called once
08:50:50 11: Actual: never called - unsatisfied and active
08:50:50 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62686 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3937/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again here:

14:27:17 11: /<<BUILDDIR>>/mir-0.26.0+zesty4014bzr4019/tests/acceptance-tests/test_nested_input.cpp:421: Failure
14:27:17 11: Value of: event_received.wait_for(60s)
14:27:17 11: Actual: false
14:27:17 11: Expected: true
14:27:17 11: [2017-02-09 14:27:17.704967] mirserver: Stopping
14:27:17 11: [2017-02-09 14:27:17.773259] mirserver: Stopping
14:27:17 11: /<<BUILDDIR>>/mir-0.26.0+zesty4014bzr4019/tests/acceptance-tests/test_nested_input.cpp:412: Failure
14:27:17 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
14:27:17 11: Expected: to be called once
14:27:17 11: Actual: never called - unsatisfied and active
14:27:17 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62074 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3965/consoleFull

Daniel van Vugt (vanvugt) wrote :

And here:

20:04:51 11: /<<BUILDDIR>>/mir-0.26.0+zesty4023bzr4021/tests/acceptance-tests/test_nested_input.cpp:421: Failure
20:04:51 11: Value of: event_received.wait_for(60s)
20:04:51 11: Actual: false
20:04:51 11: Expected: true
20:04:51 11: [2017-02-09 20:04:51.639497] mirserver: Stopping
20:04:51 11: [2017-02-09 20:04:51.730149] mirserver: Stopping
20:04:51 11: /<<BUILDDIR>>/mir-0.26.0+zesty4023bzr4021/tests/acceptance-tests/test_nested_input.cpp:412: Failure
20:04:51 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
20:04:51 11: Expected: to be called once
20:04:51 11: Actual: never called - unsatisfied and active
20:04:51 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62166 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3974/consoleFull

Changed in mir:
status: Triaged → In Progress
Daniel van Vugt (vanvugt) wrote :

Again:

14:35:28 11: /<<BUILDDIR>>/mir-0.26.0+xenial4042bzr4028/tests/acceptance-tests/test_nested_input.cpp:421: Failure
14:35:28 11: Value of: event_received.wait_for(60s)
14:35:28 11: Actual: false
14:35:28 11: Expected: true
14:35:28 11: [2017-02-13 14:35:28.869802] mirserver: Stopping
14:35:28 11: [2017-02-13 14:35:28.964317] mirserver: Stopping
14:35:29 11: /<<BUILDDIR>>/mir-0.26.0+xenial4042bzr4028/tests/acceptance-tests/test_nested_input.cpp:412: Failure
14:35:29 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
14:35:29 11: Expected: to be called once
14:35:29 11: Actual: never called - unsatisfied and active
14:35:29 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62774 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/3993/consoleFull

Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 1.0.0

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Again here:

03:10:02 11: /<<BUILDDIR>>/mir-0.26.0+xenial4077bzr4035/tests/acceptance-tests/test_nested_input.cpp:420: Failure
03:10:02 11: Value of: event_received.wait_for(60s)
03:10:02 11: Actual: false
03:10:02 11: Expected: true
03:10:02 11: [2017-02-16 03:10:02.956184] mirserver: Stopping
03:10:03 11: [2017-02-16 03:10:03.003541] mirserver: Stopping
03:10:03 11: /<<BUILDDIR>>/mir-0.26.0+xenial4077bzr4035/tests/acceptance-tests/test_nested_input.cpp:411: Failure
03:10:03 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
03:10:03 11: Expected: to be called once
03:10:03 11: Actual: never called - unsatisfied and active
03:10:03 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (61731 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/4028/consoleFull

Changed in mir:
status: Fix Committed → Confirmed
Daniel van Vugt (vanvugt) wrote :

And here:

04:18:29 9: /<<BUILDDIR>>/mir-0.26.0+zesty4120bzr4044/tests/acceptance-tests/test_nested_input.cpp:420: Failure
04:18:29 9: Value of: event_received.wait_for(60s)
04:18:29 9: Actual: false
04:18:29 9: Expected: true
04:18:29 9: [2017-02-21 04:18:29.612439] mirserver: Stopping
04:18:29 9: [2017-02-21 04:18:29.750321] mirserver: Stopping
04:18:29 9: /<<BUILDDIR>>/mir-0.26.0+zesty4120bzr4044/tests/acceptance-tests/test_nested_input.cpp:411: Failure
04:18:29 9: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
04:18:29 9: Expected: to be called once
04:18:29 9: Actual: never called - unsatisfied and active
04:18:29 9: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62374 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=zesty/4070/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

21:28:57 11: /<<BUILDDIR>>/mir-0.26.0+zesty4143bzr4043/tests/acceptance-tests/test_nested_input.cpp:420: Failure
21:28:57 11: Value of: event_received.wait_for(60s)
21:28:57 11: Actual: false
21:28:57 11: Expected: true
21:28:58 11: [2017-02-22 21:28:58.017941] mirserver: Stopping
21:28:58 11: [2017-02-22 21:28:58.168813] mirserver: Stopping
21:28:58 11: /<<BUILDDIR>>/mir-0.26.0+zesty4143bzr4043/tests/acceptance-tests/test_nested_input.cpp:411: Failure
21:28:58 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
21:28:58 11: Expected: to be called once
21:28:58 11: Actual: never called - unsatisfied and active
21:28:58 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (63045 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/4093/consoleFull

Daniel van Vugt (vanvugt) wrote :

And again:

10:39:05 11: /<<BUILDDIR>>/mir-0.26.0+xenial4146bzr4051/tests/acceptance-tests/test_nested_input.cpp:420: Failure
10:39:05 11: Value of: event_received.wait_for(60s)
10:39:05 11: Actual: false
10:39:05 11: Expected: true
10:39:05 11: [2017-02-23 10:39:05.885803] mirserver: Stopping
10:39:06 11: [2017-02-23 10:39:06.075373] mirserver: Stopping
10:39:06 11: /<<BUILDDIR>>/mir-0.26.0+xenial4146bzr4051/tests/acceptance-tests/test_nested_input.cpp:411: Failure
10:39:06 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
10:39:06 11: Expected: to be called once
10:39:06 11: Actual: never called - unsatisfied and active
10:39:06 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (63491 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/4096/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

12:40:26 11: /<<BUILDDIR>>/mir-0.26.0+xenial4191bzr4058/tests/acceptance-tests/test_nested_input.cpp:420: Failure
12:40:26 11: Value of: event_received.wait_for(60s)
12:40:26 11: Actual: false
12:40:26 11: Expected: true
12:40:26 11: [2017-02-28 12:40:26.753878] mirserver: Stopping
12:40:26 11: [2017-02-28 12:40:26.847590] mirserver: Stopping
12:40:26 11: /<<BUILDDIR>>/mir-0.26.0+xenial4191bzr4058/tests/acceptance-tests/test_nested_input.cpp:411: Failure
12:40:26 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
12:40:26 11: Expected: to be called once
12:40:26 11: Actual: never called - unsatisfied and active
12:40:26 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62496 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/4141/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

18:09:09 11: /<<BUILDDIR>>/mir-0.26.0+xenial4196bzr4059/tests/acceptance-tests/test_nested_input.cpp:420: Failure
18:09:09 11: Value of: event_received.wait_for(60s)
18:09:09 11: Actual: false
18:09:09 11: Expected: true
18:09:09 11: [2017-02-28 18:09:09.931049] mirserver: Stopping
18:09:10 11: [2017-02-28 18:09:10.045498] mirserver: Stopping
18:09:10 11: /<<BUILDDIR>>/mir-0.26.0+xenial4196bzr4059/tests/acceptance-tests/test_nested_input.cpp:411: Failure
18:09:10 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
18:09:10 11: Expected: to be called once
18:09:10 11: Actual: never called - unsatisfied and active
18:09:10 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62659 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/4146/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

09:29:01 9: /<<BUILDDIR>>/mir-0.26.0+zesty4203bzr4060/tests/acceptance-tests/test_nested_input.cpp:420: Failure
09:29:01 9: Value of: event_received.wait_for(60s)
09:29:01 9: Actual: false
09:29:01 9: Expected: true
09:29:01 9: [2017-03-01 09:29:01.635044] mirserver: Stopping
09:29:01 9: [2017-03-01 09:29:01.727907] mirserver: Stopping
09:29:01 9: /<<BUILDDIR>>/mir-0.26.0+zesty4203bzr4060/tests/acceptance-tests/test_nested_input.cpp:411: Failure
09:29:01 9: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
09:29:01 9: Expected: to be called once
09:29:01 9: Actual: never called - unsatisfied and active
09:29:01 9: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (62719 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=zesty/4153/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

17:38:29 9: /<<BUILDDIR>>/mir-0.26.0+zesty4227bzr4064/tests/acceptance-tests/test_nested_input.cpp:420: Failure
17:38:29 9: Value of: event_received.wait_for(60s)
17:38:29 9: Actual: false
17:38:29 9: Expected: true
17:38:29 9: [2017-03-02 17:38:29.313703] mirserver: Stopping
17:38:29 9: [2017-03-02 17:38:29.404150] mirserver: Stopping
17:38:29 9: /<<BUILDDIR>>/mir-0.26.0+zesty4227bzr4064/tests/acceptance-tests/test_nested_input.cpp:411: Failure
17:38:29 9: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(final_x, final_y), mt::PointerEventWithDiff(x[2], y[2]))))...
17:38:29 9: Expected: to be called once
17:38:29 9: Actual: never called - unsatisfied and active
17:38:29 9: [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_host_server (61745 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=zesty/4177/consoleFull

Changed in mir:
status: Confirmed → In Progress
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 1.0.0

Changed in mir:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (8.3 KiB)

This bug was fixed in the package mir - 0.27.0+17.10.20170630-0ubuntu1

---------------
mir (0.27.0+17.10.20170630-0ubuntu1) artful; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.27.0 (https://launchpad.net/mir/+milestone/0.27.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 44
      . mircommon ABI unchanged at 7
      . mirplatform ABI bumped to 61
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI bumped to 13
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI bumped to 7
      . mircore ABI unchanged at 1
    - Enhancements:
      . Mostly groundwork required to support major enhancements coming in
        future Mir versions.
      . Removed android-input and eliminated the entire "3rd_party/" subtree.
        Now the Mir source tree contains original code only.
      . Added mir_prompt_session_new_fds_for_prompt_providers_sync API.
      . mirout: Added load and save options for keeping display configs
        on disk.
      . mirout: Added "--" support for applying configuration changes under
        Unity8.
      . Fixed failure of DRM hardware cursor {hide(); show(image);}
      . Added server option: "--cursor software" (MIR_SERVER_CURSOR=software)
      . Added letterboxing/black bars support to the GL renderer in preparation
        for generic output cloning.
      . Added client API for getting the logical size of an output.
      . Migrated MirCookie to use SHA-256.
      . Ensure RealKMSOutputConfiguration stays in sync with actual hardware
        state.
      . Added support for drag-and-drop.
      . Lots of other client API enhancements.
      . Minor clean-ups, optimizations and dead code removal.
      . Added support for building on Ubuntu 17.10 artful.
      . Update example code to use undeprecated API.
      . mesa-kms: Support hardware cursors in hybrid setups.
      . Rework and publish the graphics platform APIs
    - Bugs fixed:
      . [enhancement] Make able to get version information from client /
        server APIs (LP: #1195540)
      . Touch screen coordinates don't rotate with the screen (LP: #1349660)
      . Subpixel order not included in Mir display information (LP: #1393578)
      . [enhancement] Missing client API for relative surface movement (e.g.
        dragging client-decorated windows) (LP: #1420334) . Mir does not reset
        key states when paused or resumed (modifiers get stuck after VT
        switching) (LP: #1536279)
      . NBS never uses mc::MultiMonitorMode::single_monitor_fast, even when
        only a single monitor is plugged in (LP: #1561418)
      . Inconsistent behaviour of Num Lock (LP: #1588237)
      . A scaled (not panned or clipped) mirror/clone mode is desired
        (LP: #1639226)
      . Rotating an output left or right without restarting the
        compositor distorts the image (LP: #1643488)
      . support display scaling slider in unity8 (LP: #1645372)
      . [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_
        server_are_accumulated (LP: #1646375)
      . [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_
        ho...

Read more...

Changed in mir (Ubuntu):
status: New → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers