Mir

[ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated

Bug #1646375 reported by Daniel van Vugt on 2016-12-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
High
Andreas Pokorny
mir (Ubuntu)
Undecided
Unassigned

Bug Description

04:37:34 [ RUN ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated
...
04:37:34 unknown file: Failure
04:37:34
04:37:34 Unexpected mock function call - returning default value.
04:37:34 Function call: handle(pointer_event(when=14575773119920512 (76.256763ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none))
04:37:34 Returns: false
04:37:34 Google Mock tried the following 3 expectations, but none matched:
04:37:34
04:37:34 /<<BUILDDIR>>/mir-0.25.0+yakkety3044bzr3857/tests/acceptance-tests/test_nested_input.cpp:321: tried expectation #0: EXPECT_CALL(nested_event_filter, handle(mt::InputDeviceStateEvent()))...
04:37:34 Expected arg #0: input device state event
04:37:34 Actual: pointer_event(when=14575773119920512 (28.550649ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none)
04:37:34 Expected: to be called once
04:37:34 Actual: called once - saturated and active
04:37:34 /<<BUILDDIR>>/mir-0.25.0+yakkety3044bzr3857/tests/acceptance-tests/test_nested_input.cpp:326: tried expectation #1: EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
04:37:34 Expected arg #0: (pointer event with position (30, 30)) and (pointer event with diff (30, 30))
04:37:34 Actual: pointer_event(when=14575773119920512 (71.013865ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none)
04:37:34 Expected: to be called once
04:37:34 Actual: never called - unsatisfied and active
04:37:34 /<<BUILDDIR>>/mir-0.25.0+yakkety3044bzr3857/tests/acceptance-tests/test_nested_input.cpp:342: tried expectation #2: EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x + second_movement_x, initial_movement_y + second_movement_y), mt::PointerEventWithDiff(second_movement_x, second_movement_y))))...
04:37:34 Expected arg #0: (pointer event with position (35, 28)) and (pointer event with diff (5, -2))
04:37:34 Actual: pointer_event(when=14575773119920512 (73.772187ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none)
04:37:34 Expected: to be called once
04:37:34 Actual: never called - unsatisfied and active
04:37:34 [2016-12-01 04:33:06.521662] mirserver: Stopping
04:37:34 [2016-12-01 04:33:06.601438] mirserver: Stopping
04:37:34 /<<BUILDDIR>>/mir-0.25.0+yakkety3044bzr3857/tests/acceptance-tests/test_nested_input.cpp:326: Failure
04:37:34 Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
04:37:34 Expected: to be called once
04:37:34 Actual: never called - unsatisfied and active
04:37:34 /<<BUILDDIR>>/mir-0.25.0+yakkety3044bzr3857/tests/acceptance-tests/test_nested_input.cpp:342: Failure
04:37:34 Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x + second_movement_x, initial_movement_y + second_movement_y), mt::PointerEventWithDiff(second_movement_x, second_movement_y))))...
04:37:34 Expected: to be called once
04:37:34 Actual: never called - unsatisfied and active
04:37:34 [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (5578 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=yakkety/3016/consoleFull

Related branches

description: updated
Daniel van Vugt (vanvugt) wrote :
Download full text (3.5 KiB)

Again today:

03:09:20 9: Unexpected mock function call - returning default value.
03:09:20 9: Function call: handle(pointer_event(when=2318257310821860 (123.849703ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none))
03:09:20 9: Returns: false
03:09:20 9: Google Mock tried the following 3 expectations, but none matched:
03:09:20 9:
03:09:20 9: /<<BUILDDIR>>/mir-0.25.0+yakkety3080bzr3866/tests/acceptance-tests/test_nested_input.cpp:321: tried expectation #0: EXPECT_CALL(nested_event_filter, handle(mt::InputDeviceStateEvent()))...
03:09:20 9: Expected arg #0: input device state event
03:09:20 9: Actual: pointer_event(when=2318257310821860 (60.853686ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none)
03:09:20 9: Expected: to be called once
03:09:20 9: Actual: called once - saturated and active
03:09:20 9: /<<BUILDDIR>>/mir-0.25.0+yakkety3080bzr3866/tests/acceptance-tests/test_nested_input.cpp:326: tried expectation #1: EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
03:09:20 9: Expected arg #0: (pointer event with position (30, 30)) and (pointer event with diff (30, 30))
03:09:20 9: Actual: pointer_event(when=2318257310821860 (114.533973ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none)
03:09:20 9: Expected: to be called once
03:09:20 9: Actual: never called - unsatisfied and active
03:09:20 9: /<<BUILDDIR>>/mir-0.25.0+yakkety3080bzr3866/tests/acceptance-tests/test_nested_input.cpp:342: tried expectation #2: EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x + second_movement_x, initial_movement_y + second_movement_y), mt::PointerEventWithDiff(second_movement_x, second_movement_y))))...
03:09:20 9: Expected arg #0: (pointer event with position (35, 28)) and (pointer event with diff (5, -2))
03:09:20 9: Actual: pointer_event(when=2318257310821860 (119.493427ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none)
03:09:20 9: Expected: to be called once
03:09:20 9: Actual: never called - unsatisfied and active
03:09:22 9: [2016-12-05 03:09:22.527089] mirserver: Stopping
03:09:22 9: [2016-12-05 03:09:22.691921] mirserver: Stopping
03:09:22 9: /<<BUILDDIR>>/mir-0.25.0+yakkety3080bzr3866/tests/acceptance-tests/test_nested_input.cpp:326: Failure
03:09:22 9: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
03:09:22 9: Expected: to be called once
03:09:22 9: Actual: never called - unsatisfied and active
03:09:22 9: /<<BUILDDIR>>/mir-0.25.0+yakkety3080bzr3866/tests/acceptance-tests/test_nested_input.cpp:342: Failure
03:09:22 9: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x + second_movement_x, initial_movement_y + secon...

Read more...

Daniel van Vugt (vanvugt) wrote :
Download full text (3.6 KiB)

And again:

03:18:54 11: Unexpected mock function call - returning default value.
03:18:54 11: Function call: handle(pointer_event(when=15003323353711999 (51.537392ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none))
03:18:54 11: Returns: false
03:18:54 11: Google Mock tried the following 3 expectations, but none matched:
03:18:54 11:
03:18:54 11: /<<BUILDDIR>>/mir-0.25.0+yakkety3091bzr3864/tests/acceptance-tests/test_nested_input.cpp:321: tried expectation #0: EXPECT_CALL(nested_event_filter, handle(mt::InputDeviceStateEvent()))...
03:18:54 11: Expected arg #0: input device state event
03:18:54 11: Actual: pointer_event(when=15003323353711999 (20.832019ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none)
03:18:54 11: Expected: to be called once
03:18:54 11: Actual: called once - saturated and active
03:18:54 11: /<<BUILDDIR>>/mir-0.25.0+yakkety3091bzr3864/tests/acceptance-tests/test_nested_input.cpp:326: tried expectation #1: EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
03:18:54 11: Expected arg #0: (pointer event with position (30, 30)) and (pointer event with diff (30, 30))
03:18:54 11: Actual: pointer_event(when=15003323353711999 (47.871041ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none)
03:18:54 11: Expected: to be called once
03:18:54 11: Actual: never called - unsatisfied and active
03:18:54 11: /<<BUILDDIR>>/mir-0.25.0+yakkety3091bzr3864/tests/acceptance-tests/test_nested_input.cpp:342: tried expectation #2: EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x + second_movement_x, initial_movement_y + second_movement_y), mt::PointerEventWithDiff(second_movement_x, second_movement_y))))...
03:18:54 11: Expected arg #0: (pointer event with position (35, 28)) and (pointer event with diff (5, -2))
03:18:54 11: Actual: pointer_event(when=15003323353711999 (50.149491ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none)
03:18:54 11: Expected: to be called once
03:18:54 11: Actual: never called - unsatisfied and active
03:18:56 11: [2016-12-06 03:18:56.720848] mirserver: Stopping
03:18:56 11: [2016-12-06 03:18:56.763882] mirserver: Stopping
03:18:56 11: /<<BUILDDIR>>/mir-0.25.0+yakkety3091bzr3864/tests/acceptance-tests/test_nested_input.cpp:326: Failure
03:18:56 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
03:18:56 11: Expected: to be called once
03:18:56 11: Actual: never called - unsatisfied and active
03:18:56 11: /<<BUILDDIR>>/mir-0.25.0+yakkety3091bzr3864/tests/acceptance-tests/test_nested_input.cpp:342: Failure
03:18:56 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x + second_movement_x,...

Read more...

Daniel van Vugt (vanvugt) wrote :

Looks like the offending test is relatively new:

revno: 3842 [merge]
author: Andreas Pokorny <email address hidden>
committer: Tarmac
branch nick: development-branch
timestamp: Thu 2016-11-24 03:48:02 +0000

tags: added: regression
Changed in mir:
importance: High → Medium
Alan Griffiths (alan-griffiths) wrote :
Download full text (11.0 KiB)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3421/consoleFull

NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated
14:37:49 11: [2017-01-10 14:37:49.081169] mirserver: Starting
14:37:49 11: [2017-01-10 14:37:49.086512] mirserver: Selected driver: mir:stub-graphics (version 0.26.0)
14:37:49 11: [2017-01-10 14:37:49.374743] mirserver: Using software cursor
14:37:49 11: [2017-01-10 14:37:49.472982] mirserver: Selected input driver: mir:stub-input (version: 0.26.0)
14:37:49 11: [2017-01-10 14:37:49.478280] mirserver: Mir version 0.26.0
14:37:49 11: [2017-01-10 14:37:49.658588] mirserver: Initial display configuration:
14:37:49 11: [2017-01-10 14:37:49.659096] mirserver: Output 1: VGA connected, used
14:37:49 11: [2017-01-10 14:37:49.659354] mirserver: Physical size 0.0" 0x0mm
14:37:49 11: [2017-01-10 14:37:49.659564] mirserver: Power is on
14:37:49 11: [2017-01-10 14:37:49.659838] mirserver: Current mode 1920x1080 60.00Hz
14:37:49 11: [2017-01-10 14:37:49.660054] mirserver: Preferred mode 1920x1080 60.00Hz
14:37:49 11: [2017-01-10 14:37:49.660203] mirserver: Orientation normal
14:37:49 11: [2017-01-10 14:37:49.660359] mirserver: Logical size 1920x1080
14:37:49 11: [2017-01-10 14:37:49.660507] mirserver: Logical position +0+0
14:37:49 11: [2017-01-10 14:37:49.700426] mirserver: Starting
14:37:50 11: [2017-01-10 14:37:50.256729] mirserver: Using nested cursor
14:37:50 11: [2017-01-10 14:37:50.433649] mirserver: Mir version 0.26.0
14:37:50 11: [2017-01-10 14:37:50.605717] mirserver: Initial display configuration:
14:37:50 11: [2017-01-10 14:37:50.606549] mirserver: Output 1: VGA connected, used
14:37:50 11: [2017-01-10 14:37:50.606758] mirserver: Physical size 0.0" 0x0mm
14:37:50 11: [2017-01-10 14:37:50.606920] mirserver: Power is on
14:37:50 11: [2017-01-10 14:37:50.607230] mirserver: Current mode 1920x1080 60.00Hz
14:37:50 11: [2017-01-10 14:37:50.607430] mirserver: Preferred mode 1920x1080 60.00Hz
14:37:50 11: [2017-01-10 14:37:50.607595] mirserver: Orientation normal
14:37:50 11: [2017-01-10 14:37:50.607772] mirserver: Logical size 1920x1080
14:37:50 11: [2017-01-10 14:37:50.607935] mirserver: Logical position +0+0
14:37:53 11: unknown file: Failure
14:37:53 11:
14:37:53 11: Unexpected mock function call - returning default value.
14:37:53 11: Function call: handle(pointer_event(when=5469973890470079 (97.283700ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none))
14:37:53 11: Returns: false
14:37:53 11: Google Mock tried the following 3 expectations, but none matched:
14:37:53 11:
14:37:53 11: /<<BUILDDIR>>/mir-0.26.0+xenial3451bzr3917/tests/acceptance-tests/test_nested_input.cpp:321: tried expectation #0: EXPECT_CALL(nested_event_filter, handle(mt::InputDeviceStateEvent()))...
14:37:53 11: Expected arg #0: input device state event
14:37:53 11: Actual: pointer_event(when=5469973890470079 (43.210829ms ago), from=2, motion, button_state=0, x=5, y=0, dx=5, dy=-2, vscroll=0, hscroll=0, modifiers=none)
14:37:53 11: Expected: to be called once
14:37:53 11: Actual: called once - saturated and active
14:37:...

Changed in mir:
assignee: nobody → Andreas Pokorny (andreas-pokorny)
Daniel van Vugt (vanvugt) wrote :

Again:

08:24:21 /<<BUILDDIR>>/mir-0.26.0+zesty3584bzr3934/tests/acceptance-tests/test_nested_input.cpp:334: Failure
08:24:21 Value of: event_received.wait_for(60s)
08:24:21 Actual: false
08:24:21 Expected: true
08:24:21 [2017-01-16 08:18:33.186351] mirserver: Stopping
08:24:21 [2017-01-16 08:18:33.353165] mirserver: Stopping
08:24:21 /<<BUILDDIR>>/mir-0.26.0+zesty3584bzr3934/tests/acceptance-tests/test_nested_input.cpp:324: Failure
08:24:21 Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
08:24:21 Expected: to be called once
08:24:21 Actual: never called - unsatisfied and active
08:24:21 [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3553/consoleFull

Changed in mir:
importance: Medium → High

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3656/consoleFull

06:09:18 11: [ RUN ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated
06:09:18 11: [2017-01-19 06:09:18.379691] mirserver: Starting
06:09:18 11: [2017-01-19 06:09:18.383742] mirserver: Selected driver: mir:stub-graphics (version 0.26.0)
06:09:18 11: [2017-01-19 06:09:18.612337] mirserver: Using software cursor
06:09:18 11: [2017-01-19 06:09:18.686150] mirserver: Selected input driver: mir:stub-input (version: 0.26.0)
06:09:18 11: [2017-01-19 06:09:18.688313] mirserver: Mir version 0.26.0
06:09:18 11: [2017-01-19 06:09:18.847944] mirserver: Initial display configuration:
06:09:18 11: [2017-01-19 06:09:18.848318] mirserver: Output 1: VGA connected, used
06:09:18 11: [2017-01-19 06:09:18.848593] mirserver: Physical size 0.0" 0x0mm
06:09:18 11: [2017-01-19 06:09:18.848834] mirserver: Power is on
06:09:18 11: [2017-01-19 06:09:18.849119] mirserver: Current mode 1920x1080 60.00Hz
06:09:18 11: [2017-01-19 06:09:18.849402] mirserver: Preferred mode 1920x1080 60.00Hz
06:09:18 11: [2017-01-19 06:09:18.850020] mirserver: Orientation normal
06:09:18 11: [2017-01-19 06:09:18.850281] mirserver: Logical size 1920x1080
06:09:18 11: [2017-01-19 06:09:18.850509] mirserver: Logical position +0+0
06:09:18 11: [2017-01-19 06:09:18.883464] mirserver: Starting
06:09:20 11: [2017-01-19 06:09:19.993258] mirserver: Using nested cursor
06:09:20 11: [2017-01-19 06:09:20.295503] mirserver: Mir version 0.26.0
06:09:20 11: [2017-01-19 06:09:20.444004] mirserver: Initial display configuration:
06:09:20 11: [2017-01-19 06:09:20.445527] mirserver: Output 1: VGA connected, used
06:09:20 11: [2017-01-19 06:09:20.445856] mirserver: Physical size 0.0" 0x0mm
06:09:20 11: [2017-01-19 06:09:20.446109] mirserver: Power is on
06:09:20 11: [2017-01-19 06:09:20.446426] mirserver: Current mode 1920x1080 60.00Hz
06:09:20 11: [2017-01-19 06:09:20.446738] mirserver: Preferred mode 1920x1080 60.00Hz
06:09:20 11: [2017-01-19 06:09:20.447050] mirserver: Orientation normal
06:09:20 11: [2017-01-19 06:09:20.447277] mirserver: Logical size 1920x1080
06:09:20 11: [2017-01-19 06:09:20.447448] mirserver: Logical position +0+0
06:10:21 11: /<<BUILDDIR>>/mir-0.26.0+xenial3694bzr3960/tests/acceptance-tests/test_nested_input.cpp:334: Failure
06:10:21 11: Value of: event_received.wait_for(60s)
06:10:21 11: Actual: false
06:10:21 11: Expected: true
06:10:21 11: [2017-01-19 06:10:21.148330] mirserver: Stopping
06:10:21 11: [2017-01-19 06:10:21.290556] mirserver: Stopping
06:10:21 11: /<<BUILDDIR>>/mir-0.26.0+xenial3694bzr3960/tests/acceptance-tests/test_nested_input.cpp:324: Failure
06:10:21 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
06:10:21 11: Expected: to be called once
06:10:21 11: Actual: never called - unsatisfied and active
06:10:21 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (63049 ms)

Changed in mir:
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Again:

08:18:21 11: /<<BUILDDIR>>/mir-0.26.0+zesty3763bzr3969/tests/acceptance-tests/test_nested_input.cpp:334: Failure
08:18:21 11: Value of: event_received.wait_for(60s)
08:18:21 11: Actual: false
08:18:21 11: Expected: true
08:18:21 11: [2017-01-23 08:18:21.369946] mirserver: Stopping
08:18:21 11: [2017-01-23 08:18:21.489434] mirserver: Stopping
08:18:21 11: /<<BUILDDIR>>/mir-0.26.0+zesty3763bzr3969/tests/acceptance-tests/test_nested_input.cpp:324: Failure
08:18:21 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
08:18:21 11: Expected: to be called once
08:18:21 11: Actual: never called - unsatisfied and active
08:18:21 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (62551 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3721/consoleFull

Daniel van Vugt (vanvugt) wrote :

And today:

02:00:39 11: /<<BUILDDIR>>/mir-0.26.0+zesty3837bzr3986/tests/acceptance-tests/test_nested_input.cpp:334: Failure
02:00:39 11: Value of: event_received.wait_for(60s)
02:00:39 11: Actual: false
02:00:39 11: Expected: true
02:00:39 11: [2017-01-25 02:00:39.461511] mirserver: Stopping
02:00:39 11: [2017-01-25 02:00:39.747808] mirserver: Stopping
02:00:39 11: /<<BUILDDIR>>/mir-0.26.0+zesty3837bzr3986/tests/acceptance-tests/test_nested_input.cpp:324: Failure
02:00:39 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
02:00:39 11: Expected: to be called once
02:00:39 11: Actual: never called - unsatisfied and active
02:00:39 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (65408 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3795/consoleFull

Daniel van Vugt (vanvugt) wrote :

And here:

16:15:36 11: /<<BUILDDIR>>/mir-0.26.0+xenial3860bzr3973/tests/acceptance-tests/test_nested_input.cpp:334: Failure
16:15:36 11: Value of: event_received.wait_for(60s)
16:15:36 11: Actual: false
16:15:36 11: Expected: true
16:15:36 11: [2017-01-26 16:15:36.440955] mirserver: Stopping
16:15:36 11: [2017-01-26 16:15:36.753833] mirserver: Stopping
16:15:36 11: /<<BUILDDIR>>/mir-0.26.0+xenial3860bzr3973/tests/acceptance-tests/test_nested_input.cpp:324: Failure
16:15:36 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
16:15:36 11: Expected: to be called once
16:15:36 11: Actual: never called - unsatisfied and active
16:15:36 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (64748 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/3818/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

12:33:05 11: /<<BUILDDIR>>/mir-0.26.0+xenial3912bzr4004/tests/acceptance-tests/test_nested_input.cpp:334: Failure
12:33:05 11: Value of: event_received.wait_for(60s)
12:33:05 11: Actual: false
12:33:05 11: Expected: true
12:33:05 11: [2017-02-01 12:33:05.394872] mirserver: Stopping
12:33:05 11: [2017-02-01 12:33:05.483155] mirserver: Stopping
12:33:05 11: /<<BUILDDIR>>/mir-0.26.0+xenial3912bzr4004/tests/acceptance-tests/test_nested_input.cpp:324: Failure
12:33:05 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
12:33:05 11: Expected: to be called once
12:33:05 11: Actual: never called - unsatisfied and active
12:33:05 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (62062 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/3870/consoleFull

Daniel van Vugt (vanvugt) wrote :

And again:

18:35:22 11: /<<BUILDDIR>>/mir-0.26.0+xenial4020bzr4020/tests/acceptance-tests/test_nested_input.cpp:380: Failure
18:35:22 11: Value of: event_received.wait_for(60s)
18:35:22 11: Actual: false
18:35:22 11: Expected: true
18:35:22 11: [2017-02-09 18:35:22.832121] mirserver: Stopping
18:35:22 11: [2017-02-09 18:35:22.876024] mirserver: Stopping
18:35:22 11: /<<BUILDDIR>>/mir-0.26.0+xenial4020bzr4020/tests/acceptance-tests/test_nested_input.cpp:370: Failure
18:35:22 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
18:35:22 11: Expected: to be called once
18:35:22 11: Actual: never called - unsatisfied and active
18:35:22 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (61466 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/3971/consoleFull

Daniel van Vugt (vanvugt) wrote :

And:

03:29:14 11: /<<BUILDDIR>>/mir-0.26.0+xenial4036bzr4022/tests/acceptance-tests/test_nested_input.cpp:380: Failure
03:29:14 11: Value of: event_received.wait_for(60s)
03:29:14 11: Actual: false
03:29:14 11: Expected: true
03:29:14 11: [2017-02-13 03:29:14.177450] mirserver: Stopping
03:29:14 11: [2017-02-13 03:29:14.278179] mirserver: Stopping
03:29:14 11: /<<BUILDDIR>>/mir-0.26.0+xenial4036bzr4022/tests/acceptance-tests/test_nested_input.cpp:370: Failure
03:29:14 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
03:29:14 11: Expected: to be called once
03:29:14 11: Actual: never called - unsatisfied and active
03:29:14 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (61975 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3987/consoleFull

Changed in mir:
milestone: none → 1.0.0
status: Confirmed → In Progress
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 1.0.0

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Still happening here:

08:18:52 11: /<<BUILDDIR>>/mir-0.26.0+zesty4056bzr4025/tests/acceptance-tests/test_nested_input.cpp:379: Failure
08:18:52 11: Value of: event_received.wait_for(60s)
08:18:52 11: Actual: false
08:18:52 11: Expected: true
08:18:52 11: [2017-02-14 08:18:52.211481] mirserver: Stopping
08:18:52 11: [2017-02-14 08:18:52.259543] mirserver: Stopping
08:18:52 11: /<<BUILDDIR>>/mir-0.26.0+zesty4056bzr4025/tests/acceptance-tests/test_nested_input.cpp:369: Failure
08:18:52 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
08:18:52 11: Expected: to be called once
08:18:52 11: Actual: never called - unsatisfied and active
08:18:52 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (61741 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/4007/consoleFull

Changed in mir:
status: Fix Committed → Confirmed
Daniel van Vugt (vanvugt) wrote :

Again here:

09:08:44 11: /<<BUILDDIR>>/mir-0.26.0+xenial4058bzr4025/tests/acceptance-tests/test_nested_input.cpp:379: Failure
09:08:44 11: Value of: event_received.wait_for(60s)
09:08:44 11: Actual: false
09:08:44 11: Expected: true
09:08:44 11: [2017-02-14 09:08:44.292317] mirserver: Stopping
09:08:44 11: [2017-02-14 09:08:44.334108] mirserver: Stopping
09:08:44 11: /<<BUILDDIR>>/mir-0.26.0+xenial4058bzr4025/tests/acceptance-tests/test_nested_input.cpp:369: Failure
09:08:44 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
09:08:44 11: Expected: to be called once
09:08:44 11: Actual: never called - unsatisfied and active
09:08:44 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (62254 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/4009/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

07:32:07 11: /<<BUILDDIR>>/mir-0.26.0+xenial4095bzr4042/tests/acceptance-tests/test_nested_input.cpp:379: Failure
07:32:07 11: Value of: event_received.wait_for(60s)
07:32:07 11: Actual: false
07:32:07 11: Expected: true
07:32:07 11: [2017-02-17 07:32:07.768686] mirserver: Stopping
07:32:07 11: [2017-02-17 07:32:07.959209] mirserver: Stopping
07:32:08 11: /<<BUILDDIR>>/mir-0.26.0+xenial4095bzr4042/tests/acceptance-tests/test_nested_input.cpp:369: Failure
07:32:08 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
07:32:08 11: Expected: to be called once
07:32:08 11: Actual: never called - unsatisfied and active
07:32:08 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (63245 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/4045/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

06:32:31 9: /<<BUILDDIR>>/mir-0.26.0+zesty4105bzr4045/tests/acceptance-tests/test_nested_input.cpp:379: Failure
06:32:31 9: Value of: event_received.wait_for(60s)
06:32:31 9: Actual: false
06:32:31 9: Expected: true
06:32:31 9: [2017-02-20 06:32:31.656109] mirserver: Stopping
06:32:31 9: [2017-02-20 06:32:31.743269] mirserver: Stopping
06:32:31 9: /<<BUILDDIR>>/mir-0.26.0+zesty4105bzr4045/tests/acceptance-tests/test_nested_input.cpp:369: Failure
06:32:31 9: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
06:32:31 9: Expected: to be called once
06:32:31 9: Actual: never called - unsatisfied and active
06:32:31 9: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (62069 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=clang,platform=mesa,release=zesty/4055/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

12:39:05 11: /<<BUILDDIR>>/mir-0.26.0+xenial4191bzr4058/tests/acceptance-tests/test_nested_input.cpp:379: Failure
12:39:05 11: Value of: event_received.wait_for(60s)
12:39:05 11: Actual: false
12:39:05 11: Expected: true
12:39:05 11: [2017-02-28 12:39:05.751013] mirserver: Stopping
12:39:05 11: [2017-02-28 12:39:05.829014] mirserver: Stopping
12:39:05 11: /<<BUILDDIR>>/mir-0.26.0+xenial4191bzr4058/tests/acceptance-tests/test_nested_input.cpp:369: Failure
12:39:05 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
12:39:05 11: Expected: to be called once
12:39:05 11: Actual: never called - unsatisfied and active
12:39:05 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (62115 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=xenial+overlay/4141/consoleFull

Changed in mir:
status: Confirmed → In Progress
Changed in mir:
status: In Progress → Fix Committed
status: Fix Committed → Confirmed
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

And here today:

02:11:55 11: /<<BUILDDIR>>/mir-0.26.2+xenial4389bzr4046/tests/acceptance-tests/test_nested_input.cpp:334: Failure
02:11:55 11: Value of: event_received.wait_for(60s)
02:11:55 11: Actual: false
02:11:55 11: Expected: true
02:11:55 11: [2017-03-22 02:11:55.606599] mirserver: Stopping
02:11:55 11: [2017-03-22 02:11:55.663475] mirserver: Stopping
02:11:55 11: /<<BUILDDIR>>/mir-0.26.2+xenial4389bzr4046/tests/acceptance-tests/test_nested_input.cpp:324: Failure
02:11:55 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
02:11:55 11: Expected: to be called once
02:11:55 11: Actual: never called - unsatisfied and active
02:11:55 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (61794 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/4344/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

14:53:16 11: /<<BUILDDIR>>/mir-0.26.2+xenial4404bzr4046/tests/acceptance-tests/test_nested_input.cpp:334: Failure
14:53:16 11: Value of: event_received.wait_for(60s)
14:53:16 11: Actual: false
14:53:16 11: Expected: true
14:53:16 11: [2017-03-22 14:53:16.965933] mirserver: Stopping
14:53:17 11: [2017-03-22 14:53:17.064663] mirserver: Stopping
14:53:17 11: /<<BUILDDIR>>/mir-0.26.2+xenial4404bzr4046/tests/acceptance-tests/test_nested_input.cpp:324: Failure
14:53:17 11: Actual function call count doesn't match EXPECT_CALL(nested_event_filter, handle(AllOf(mt::PointerEventWithPosition(initial_movement_x, initial_movement_y), mt::PointerEventWithDiff(initial_movement_x, initial_movement_y))))...
14:53:17 11: Expected: to be called once
14:53:17 11: Actual: never called - unsatisfied and active
14:53:17 11: [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_server_are_accumulated (62806 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/4359/consoleFull

Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 1.0.0

Changed in mir:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (8.3 KiB)

This bug was fixed in the package mir - 0.27.0+17.10.20170630-0ubuntu1

---------------
mir (0.27.0+17.10.20170630-0ubuntu1) artful; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.27.0 (https://launchpad.net/mir/+milestone/0.27.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 44
      . mircommon ABI unchanged at 7
      . mirplatform ABI bumped to 61
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI bumped to 13
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI bumped to 7
      . mircore ABI unchanged at 1
    - Enhancements:
      . Mostly groundwork required to support major enhancements coming in
        future Mir versions.
      . Removed android-input and eliminated the entire "3rd_party/" subtree.
        Now the Mir source tree contains original code only.
      . Added mir_prompt_session_new_fds_for_prompt_providers_sync API.
      . mirout: Added load and save options for keeping display configs
        on disk.
      . mirout: Added "--" support for applying configuration changes under
        Unity8.
      . Fixed failure of DRM hardware cursor {hide(); show(image);}
      . Added server option: "--cursor software" (MIR_SERVER_CURSOR=software)
      . Added letterboxing/black bars support to the GL renderer in preparation
        for generic output cloning.
      . Added client API for getting the logical size of an output.
      . Migrated MirCookie to use SHA-256.
      . Ensure RealKMSOutputConfiguration stays in sync with actual hardware
        state.
      . Added support for drag-and-drop.
      . Lots of other client API enhancements.
      . Minor clean-ups, optimizations and dead code removal.
      . Added support for building on Ubuntu 17.10 artful.
      . Update example code to use undeprecated API.
      . mesa-kms: Support hardware cursors in hybrid setups.
      . Rework and publish the graphics platform APIs
    - Bugs fixed:
      . [enhancement] Make able to get version information from client /
        server APIs (LP: #1195540)
      . Touch screen coordinates don't rotate with the screen (LP: #1349660)
      . Subpixel order not included in Mir display information (LP: #1393578)
      . [enhancement] Missing client API for relative surface movement (e.g.
        dragging client-decorated windows) (LP: #1420334) . Mir does not reset
        key states when paused or resumed (modifiers get stuck after VT
        switching) (LP: #1536279)
      . NBS never uses mc::MultiMonitorMode::single_monitor_fast, even when
        only a single monitor is plugged in (LP: #1561418)
      . Inconsistent behaviour of Num Lock (LP: #1588237)
      . A scaled (not panned or clipped) mirror/clone mode is desired
        (LP: #1639226)
      . Rotating an output left or right without restarting the
        compositor distorts the image (LP: #1643488)
      . support display scaling slider in unity8 (LP: #1645372)
      . [ FAILED ] NestedInputWithMouse.mouse_pointer_coordinates_in_nested_
        server_are_accumulated (LP: #1646375)
      . [ FAILED ] NestedInputWithMouse.mouse_pointer_position_is_in_sync_with_
        ho...

Read more...

Changed in mir (Ubuntu):
status: New → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers