Mir

[ FAILED ] NestedServer.nested_platform_connects_and_disconnects

Bug #1643432 reported by Daniel van Vugt on 2016-11-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Alberto Aguirre
mir (Ubuntu)
Undecided
Unassigned

Bug Description

[ FAILED ] NestedServer.nested_platform_connects_and_disconnects:

05:45:16 11: [ RUN ] NestedServer.nested_platform_connects_and_disconnects
...
05:45:19 11: [2016-11-21 05:45:19.675640] mirserver: Stopping
05:45:19 11: [2016-11-21 05:45:19.935809] mirserver: Stopping
05:45:20 11: /<<BUILDDIR>>/mir-0.25.0+xenial2940bzr3835/tests/acceptance-tests/test_nested_mir.cpp:721: Failure
05:45:20 11: Actual function call count doesn't match EXPECT_CALL(*mock_session_mediator_report, session_disconnect_called(_))...
05:45:20 11: Expected: to be called once
05:45:20 11: Actual: never called - unsatisfied and active
05:45:20 11: [ FAILED ] NestedServer.nested_platform_connects_and_disconnects (4157 ms)

Related branches

Daniel van Vugt (vanvugt) wrote :

Again:

16:31:18 11: /<<BUILDDIR>>/mir-0.25.0+yakkety3078bzr3863/tests/acceptance-tests/test_nested_mir.cpp:722: Failure
16:31:18 11: Actual function call count doesn't match EXPECT_CALL(*mock_session_mediator_report, session_disconnect_called(_))...
16:31:18 11: Expected: to be called once
16:31:18 11: Actual: never called - unsatisfied and active
16:31:18 11: [ FAILED ] NestedServer.nested_platform_connects_and_disconnects (6712 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=yakkety/3050/consoleFull

Daniel van Vugt (vanvugt) wrote :

Afain:

09:06:59 11: /<<BUILDDIR>>/mir-0.25.0+yakkety3224bzr3885/tests/acceptance-tests/test_nested_mir.cpp:722: Failure
09:06:59 11: Actual function call count doesn't match EXPECT_CALL(*mock_session_mediator_report, session_disconnect_called(_))...
09:06:59 11: Expected: to be called once
09:06:59 11: Actual: never called - unsatisfied and active
09:06:59 11: [ FAILED ] NestedServer.nested_platform_connects_and_disconnects (3904 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=yakkety/3194/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

15:03:44 11: /<<BUILDDIR>>/mir-0.26.0+yakkety3317bzr3945/tests/acceptance-tests/test_nested_mir.cpp:722: Failure
15:03:44 11: Actual function call count doesn't match EXPECT_CALL(*mock_session_mediator_report, session_disconnect_called(_))...
15:03:44 11: Expected: to be called once
15:03:44 11: Actual: never called - unsatisfied and active
15:03:44 11: [ FAILED ] NestedServer.nested_platform_connects_and_disconnects (5639 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=yakkety/3287/consoleFull

Changed in mir:
importance: High → Low
importance: Low → Medium
Daniel van Vugt (vanvugt) wrote :

Again:

07:27:49 11: /<<BUILDDIR>>/mir-0.26.0+xenial3528bzr3925/tests/acceptance-tests/test_nested_mir.cpp:724: Failure
07:27:49 11: Actual function call count doesn't match EXPECT_CALL(*mock_session_mediator_report, session_disconnect_called(_))...
07:27:49 11: Expected: to be called once
07:27:49 11: Actual: never called - unsatisfied and active
07:27:49 11: [ FAILED ] NestedServer.nested_platform_connects_and_disconnects (6676 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3498/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:
07:48:48 11: /<<BUILDDIR>>/mir-0.26.0+zesty3583bzr3928/tests/acceptance-tests/test_nested_mir.cpp:722: Failure
07:48:48 11: Actual function call count doesn't match EXPECT_CALL(*mock_session_mediator_report, session_disconnect_called(_))...
07:48:48 11: Expected: to be called once
07:48:48 11: Actual: never called - unsatisfied and active
07:48:49 11: [ FAILED ] NestedServer.nested_platform_connects_and_disconnects (8472 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=amd64,compiler=gcc,platform=mesa,release=zesty/3552/consoleFull

Daniel van Vugt (vanvugt) wrote :

Again:

14:10:11 11: /<<BUILDDIR>>/mir-0.26.0+xenial3594bzr3941/tests/acceptance-tests/test_nested_mir.cpp:722: Failure
14:10:11 11: Actual function call count doesn't match EXPECT_CALL(*mock_session_mediator_report, session_disconnect_called(_))...
14:10:11 11: Expected: to be called once
14:10:11 11: Actual: never called - unsatisfied and active
14:10:11 11: [ FAILED ] NestedServer.nested_platform_connects_and_disconnects (7719 ms)

https://mir-jenkins.ubuntu.com/job/build-2-binpkg-mir/arch=i386,compiler=gcc,platform=mesa,release=xenial+overlay/3563/consoleFull

Changed in mir:
status: New → In Progress
assignee: nobody → Alberto Aguirre (albaguirre)
Alberto Aguirre (albaguirre) wrote :

This is caused by a race between the test stopping the server (and therefore stopping the main loop) and the main loop dispatching the observation queued by SessionMediatorObserverMultiplexer (i.e. session_disconnect_called).

Changed in mir:
milestone: none → 1.0.0
Mir CI Bot (mir-ci-bot) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 1.0.0

Changed in mir:
status: In Progress → Fix Committed
Changed in mir:
milestone: 1.0.0 → 0.26.0
Launchpad Janitor (janitor) wrote :
Download full text (7.2 KiB)

This bug was fixed in the package mir - 0.26.0+17.04.20170126.3-0ubuntu1

---------------
mir (0.26.0+17.04.20170126.3-0ubuntu1) zesty; urgency=medium

  [ Daniel van Vugt ]
  * New upstream release 0.26.0 (https://launchpad.net/mir/+milestone/0.26.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 43
      . mircommon ABI unchanged at 7
      . mirplatform ABI unchanged at 14
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI unchanged at 11
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI unchanged at 6
      . mircore ABI unchanged at 1
    - Enhancements:
      . New/improved toolkit APIs: MirInputConfig and related functions,
        MirWindow and related functions, DisplayConfig and related functions,
        MirScreencastSpec and related functions,
      . Support for configuring input configuration
      . Introduce toolkit extension mechanism for platform specific APIs.
      . Toolkit extensions for: mesa_drm_auth, set_gbm_device and
        window_coordinate_translation
      . Screencasting to a specific MirBuffer.
      . Add DisplayConfigurationController::base_configuration() so downstreams
        can get the base configuration. (Weirdly they can already set it.).
      . x11 platform: allow adjustable scale parameter.
      . Added EDID support: client API, server logging and in mirout.
      . mirout: Add newer attributes only available in the new display
        config API: scaling factor, subpixel arrangement and form factor.
      . mirout: Log the orientation and logical size of each output too.
      . Replace the mir::Server-overridable Reports with Observers.
      . Add xkbcommon to mirclient.pc Requires.private.
      . Deprecate legacy toolkit APIs that will be removed in Mir 1.0
      . Introduced 'client-side vsync', which dramatically reduces latency
        from the client to the screen (particularly for nested servers like
        Unity8).
    - Bugs fixed:
      . [performance] Restore support for better-than-triple buffering by
        default. (LP: #1240909)
      . Frame rate is artificially low on Diamondville Intel Atom systems due
        to aggressive power management (LP: #1388490)
      . [testsfail] failure in CI in
        AndroidInputReceiverSetup.slow_raw_input_doesnt_cause_frameskipping
        (LP: #1394369)
      . [trusted prompt sessions] Can't open two prompt sessions at the same
        time (LP: #1494197)
      . Changing scale, formFactor or DPI in display configuration causes
        renderer teardown/recreate unnecessarily (LP: #1556142)
      . [testsfail] ApplicationNotRespondingDetection.failure_to_pong_is_
        noticed (LP: #1570327)
      . CI failure in TestClientInput.receives_one_touch_event_per_frame
        (LP: #1570698)
      . Mir-on-X mouse input is jerky/stuttery compared to Mir-on-KMS
        (LP: #1576600)
      . [regression] Two fingers in mir_proving_server now resizes/moves app
        windows (two finger apps unusable) (LP: #1586311)
      . Pointer/cursor input lag in unity8 session (LP: #1591328)
      . PointerConfinement.test_we_update_our_confined_region_on_a_resize
      ...

Read more...

Changed in mir (Ubuntu):
status: New → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers